LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   ddd and lesstif (https://www.linuxquestions.org/questions/linux-newbie-8/ddd-and-lesstif-85480/)

deluc 08-25-2003 09:59 AM

ddd and lesstif
 
hi,

i tried to build ddd 3.3.1 on osX. i first installed the Lestiff library from a binary which worked fine. this gave me the Xfree86 folder.
the problem is when i run './configure' for the ddd-installation. apparently everything is fine except that the script doenst find the motif library. i got the following configure error:

checking for X11/Xmu/Editres.h... yes
configure: error: The Motif library '-lXm' could not be found.
Please use the configure options '--with-motif-includes=DIR'
and '--with-motif-libraries=DIR' to specify the Xm location.
See the files 'config.log' and 'ddd/config.log'
for further diagnostics.

i also tried to run it with: ./configure --with-motif-includes=/usr/X11R6/XFree86/include/Xm-2.0/ --with-motif-libraries=/usr/X11R6/XFree86/lib/ and received the same error as above.
which library does ddd need from Lesstiff. in my Xfree86/lib/ there are:

DtPrint.a Mrm_12.map Mrm_21.lib Uil_20.dll Xm_12.a Xm_20.map
DtPrint.def Mrm_20.a Mrm_21.map Uil_20.lib Xm_12.def Xm_21.a
DtPrint.dll Mrm_20.def Uil_12.a Uil_20.map Xm_12.dll Xm_21.def
DtPrint.lib Mrm_20.dll Uil_12.def Uil_21.a Xm_12.lib Xm_21.dll
DtPrint.map Mrm_20.lib Uil_12.dll Uil_21.def Xm_12.map Xm_21.lib
Mrm_12.a Mrm_20.map Uil_12.lib Uil_21.dll Xm_20.a Xm_21.map
Mrm_12.def Mrm_21.a Uil_12.map Uil_21.lib Xm_20.def
Mrm_12.dll Mrm_21.def Uil_20.a Uil_21.map Xm_20.dll
Mrm_12.lib Mrm_21.dll Uil_20.def X11 Xm_20.lib

if i run it with the option '--run-without-motif' it works fine. can anyone tell me which path for the lib and include i have to use for the ddd-configure?

thanks very much in advance

cheers lukas

acid_kewpie 08-25-2003 04:15 PM

please choose your forums more carefullly.... moved to a suitable forum "Linux - Newbie"


All times are GMT -5. The time now is 02:49 AM.