LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   dbus exception while running sync-engine (https://www.linuxquestions.org/questions/linux-newbie-8/dbus-exception-while-running-sync-engine-716239/)

akbarbasha 04-02-2009 01:40 AM

dbus exception while running sync-engine
 
Hello everyone,

I am trying to build synce-0.13 in fedora-6.

The installation of synce-engine was successful. Then after copied the .xml file to local folder.
On runnig the sync-engine following error message is displayed.

SynCE sync-engine starting up
2009-04-02 10:43:54,668 DEBUG syncengine : running main loop
2009-04-02 10:43:54,669 DEBUG syncengine : creating SyncEngine object
Traceback (most recent call last):
File "/usr/local/bin/sync-engine", line 5, in ?
pkg_resources.run_script('sync-engine==0.13', 'sync-engine')
File "/usr/local/lib/python2.4/site-packages/setuptools-0.6c9-py2.4.egg/pkg_resources.py", line 448, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "/usr/local/lib/python2.4/site-packages/setuptools-0.6c9-py2.4.egg/pkg_resources.py", line 1166, in run_script
execfile(script_filename, namespace, namespace)
File "/usr/local/lib/python2.4/site-packages/sync_engine-0.13-py2.4.egg/EGG-INFO/scripts/sync-engine", line 149, in ?
engine = SyncEngine(configObj,mainloop)
File "/usr/local/lib/python2.4/site-packages/sync_engine-0.13-py2.4.egg/SyncEngine/kernel.py", line 98, in __init__
self.odccm_manager = dbus.Interface(dbus.SystemBus().get_object(DBUS_DBUS_BUSNAME, DBUS_DBUS_OBJPATH), DBUS_DBUS_IFACE)
File "/usr/local/lib/python2.4/site-packages/dbus/_dbus.py", line 202, in __new__
private=private)
File "/usr/local/lib/python2.4/site-packages/dbus/_dbus.py", line 108, in __new__
bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
File "/usr/local/lib/python2.4/site-packages/dbus/bus.py", line 125, in __new__
bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /usr/local/var/run/dbus/system_bus_socket: No such file or directory


/usr/local/var/run/dbus/ folder is empty. system_bus_socket file is there in /var/run/dbus/ but is of 0 bytes.
I also tried to create a symbolic link between /usr/local/var/run/dbus/ and /var/run/dbus/ but still no progress.

Anyone has the solution please suggest us

Thanks


All times are GMT -5. The time now is 02:03 AM.