Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 04-16-2009, 06:00 AM   #1
LQ Newbie
Registered: Mar 2008
Posts: 22

Rep: Reputation: 15
cygwin problem


i want to connect to my linux desktop from windows machines.
and i am not able to connect.i also rum following commands on linux

[root@rnctest1 ~]# export DISPLAY=<ip>:0.0
[root@rnctest1 ~]# xhost +
Xlib: connection to "=<ip>:" refused by server
Xlib: No protocol specified

xhost: unable to open display "=<ip>:"
[root@rnctest1 ~]# xhost +
Xlib: connection to "=<ip>:0.0" refused by server
Xlib: No protocol specified

xhost: unable to open display "=<ip>::0.0"
Old 04-16-2009, 07:46 AM   #2
Senior Member
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96

Two things:
1) Do you have an X server running on the Cygwin host (ps -ef | grep X)?
2) The DISPLAY=<ip>:0.0 should be run on the Cygwin host, not the linux host.

Old 04-16-2009, 07:59 AM   #3
Registered: Apr 2009
Posts: 108

Rep: Reputation: 24
This might sound extremely silly, but do you really write <ip> all the time, or have you replaced it with a real and valid IP number? This is not supposed to be an intimidation, but people using windows boxes sometimes are much too strict when typing sample code from tutorials. Your posting doesn't make that clear.

Last edited by Tinkster; 10-30-2010 at 03:14 PM.
Old 04-16-2009, 08:48 AM   #4
Registered: Jan 2009
Posts: 165

Rep: Reputation: 44
If you can't connect at all from the Windows machine to the Linux one - then please give more details on how you are trying to connect. I assume that you are using ssh, so here is what you need to make sure:

1) The Linux machine should have ssh server working. You don't mention which Linux you have, but often the ssh server is not installed by default. Check if the package is installed.

2) From cygwin, you can connect with 'ssh -X <ip_address_of_linux>'. This will save you the need to set the DISPLAY variable by yourself. You will be able to start GUI apps and see them on Windows. You need to have X installed on the cygwin host, as Dave already mentioned, and you need ssh client which is also not installed by default with cygwin (the cygwin package is called openssh).
Old 04-17-2009, 12:50 AM   #5
LQ Newbie
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 15
Question cgwin poblem..

i have installed cygwin on windows machine and i want to connect to my linux box.I think some configuration needed to be done at linux box side so as enable the display of linux box.
obviously i have used my machines ip in place of <ip>:....;-)
can any one help me out..???


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Have you ever used cygwin, i've met a problem with the command stat from cygwin andy820303 Linux - Newbie 0 03-11-2009 03:37 AM
Problem with using ld in Cygwin alex1983-0112 Programming 4 09-05-2008 07:23 AM
cygwin Problem scbops Linux - General 2 04-06-2006 03:32 AM
problem with cygwin linuxmandrake General 1 01-15-2005 02:26 PM
a problem about cygwin tony_bupt Linux - Newbie 4 09-05-2004 07:50 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:40 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration