LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-14-2011, 01:20 AM   #1
rakesh@linuxforum
LQ Newbie
 
Registered: Jul 2011
Posts: 1

Rep: Reputation: Disabled
Red face cvs [commit aborted]: 'root' is not allowed to commit files


I m new to setup the CVS in linux , i have tried lots but every time whenever i try to commit the change in module or file this error has been generated : cvs [commit aborted]: 'root' is not allowed to commit files

please kindly help me and if u know how to configure CVS on linux pls let me know.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 07-14-2011, 09:43 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,132

Rep: Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456
Quote:
Originally Posted by rakesh@linuxforum View Post
I m new to setup the CVS in linux , i have tried lots but every time whenever i try to commit the change in module or file this error has been generated : cvs [commit aborted]: 'root' is not allowed to commit files

please kindly help me and if u know how to configure CVS on linux pls let me know.
Spell out your words.

The error is clear...the root user is not allowed to commit files to the CVS repository. Did you try to read the documentation?
http://www.network-theory.co.uk/docs...rmessages.html
Code:
'root' is not allowed to commit files
    When committing a permanent change, CVS makes a log entry of who committed the change. If you are committing the change logged
 in as "root" (not under "su" or other root-priv giving program), CVS cannot determine who is actually making the change. As such,
 by default, CVS disallows changes to be committed by users logged in as "root". (You can disable this option by passing the 
--enable-rootcommit option to ‘configure’ and recompiling CVS. On some systems this means editing the appropriate ‘config.h’ file
 before building CVS.)
Have you tried using a different user ID to do it? And it would help if you said what version/distro of Linux, and what version of CVS you're using.
 
Old 09-26-2013, 11:26 AM   #3
sadi20107
LQ Newbie
 
Registered: Sep 2013
Posts: 1

Rep: Reputation: Disabled
cvs commit aborted 'root' is not allowed to commit files

hi TB0ne

could you please tell me the commands use to allow root user to commit file.

which command i have to use to perform below action.
(You can disable this option by passing the
--enable-rootcommit option to ‘configure’ and recompiling CVS.



please help me
 
Old 09-26-2013, 11:53 AM   #4
rtmistler
Member
 
Registered: Mar 2011
Location: Milford, MA. USA
Distribution: MontaVista, Ubuntu, MINT
Posts: 964
Blog Entries: 7

Rep: Reputation: 443Reputation: 443Reputation: 443Reputation: 443Reputation: 443
The whole purpose of CVS is to record the user who made the changes as well as track the changes. Therefore using root defeats a main part of the purpose for CVS. Although you can override this feature, I don't suggest that you do this.

@rakesh, are you able to commit as a non-root user? If not, then respond to TBOne's notes about your distro and version information.
 
Old 09-26-2013, 12:56 PM   #5
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,132

Rep: Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456
Quote:
Originally Posted by sadi20107 View Post
hi TB0ne
could you please tell me the commands use to allow root user to commit file.

which command i have to use to perform below action.
(You can disable this option by passing the
--enable-rootcommit option to ‘configure’ and recompiling CVS.
Did you not read what you posted?? You run the "configure" command (as it says), with "--enable-rootcommit" after it, and recompile CVS. And again, this is a BAD IDEA, and it's disabled by default for a REASON.
 
Old 09-26-2013, 12:59 PM   #6
suicidaleggroll
Senior Member
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 2,603

Rep: Reputation: 940Reputation: 940Reputation: 940Reputation: 940Reputation: 940Reputation: 940Reputation: 940Reputation: 940
Quote:
Originally Posted by TB0ne View Post
Did you not read what you posted?? You run the "configure" command (as it says), with "--enable-rootcommit" after it, and recompile CVS. And again, this is a BAD IDEA, and it's disabled by default for a REASON.
Not to mention that logging in and operating the machine as root is a bad idea to begin with.
 
2 members found this post helpful.
Old 09-26-2013, 01:11 PM   #7
rtmistler
Member
 
Registered: Mar 2011
Location: Milford, MA. USA
Distribution: MontaVista, Ubuntu, MINT
Posts: 964
Blog Entries: 7

Rep: Reputation: 443Reputation: 443Reputation: 443Reputation: 443Reputation: 443
@sadi20107, TBOne was not advising someone to configure in this way, they had copied the statements from documentation about this restriction; which unfortunately also notes that this is "possible" if you do the following actions.

My questions are:

Has rakesh@linuxforum gotten their problem resolved?

@sadi20107 is there a different problem you're facing? Are you working with rakesh, or the same person in different logins? Or did you notice TBOne's answer, misinterpret it, and think committing as root was a recommended idea?
 
2 members found this post helpful.
Old 09-26-2013, 03:53 PM   #8
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,320

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
OP was 2011-07-14

just thought I would mention that

and as has already been mentioned

doing 'routine' day to day things as root is not a good idea

root should only be used when absolutely needed

via
Code:
su -c "SomeCommand andItsArgs"
# or
sudo SomeCommand andItsArgs
sometimes it is convenient to get a shell.. but you need to log out as soon as you can.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CVS Commit message divyashree Linux - Newbie 1 09-07-2010 03:51 AM
cvs commit error ShaqDiesel Programming 3 05-28-2009 08:06 PM
cvs [commit aborted]: 'root' is not allowed to commit files r_ramya06 Linux - Newbie 5 07-08-2008 09:04 AM
CVS won't allow "root" to commit changes RFlaugher Linux - Software 3 10-07-2004 02:43 PM
emailing on cvs commit allan_y Linux - Software 2 07-02-2004 09:30 AM


All times are GMT -5. The time now is 12:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration