LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cups error "cannot specify model number" when trying to set up my new printer (https://www.linuxquestions.org/questions/linux-newbie-8/cups-error-cannot-specify-model-number-when-trying-to-set-up-my-new-printer-4175601125/)

Linsoo 03-05-2017 01:11 PM

cups error "cannot specify model number" when trying to set up my new printer
 
I am completely new to linux and completely computer illiterate. I have linux mint (cinnamon) and purchased a canon pixma mx922 printer not realizing I should have purchased a specific printer. When I go to CUPS it did find the printer. It has all the specs listed for it and everything but then it asks me to select the model and there is not an exact match to this one. It tells me it has my printer modified and everything looks great but when I actually try to print, it gives me the "cannot specify model number" error.

allend 03-05-2017 04:13 PM

Welcome to LQ!

Your printer needs to have the driver installed.
https://sites.google.com/site/easylinuxtipsproject/18
https://forums.linuxmint.com/viewtopic.php?t=191624

Linsoo 03-07-2017 04:05 PM

Yes, I have already seen those pages and believe I have the driver installed but, of course, not sure. I believe I do, because that is why I think that CUPS could find the printer to start with. My issue is, however, that my printer is completely wireless. I cannot plug it into the computer with a usb. I feel like if I could do this, then my problem would be solved.

allend 03-07-2017 04:51 PM

This page provides wireless setup and troubleshooting support for your device (under Wireless help), but typical for Canon there is no Linux specific support. https://www.usa.canon.com/internet/p...s-inkjet/mx922
Are you confident that your device has a working wireless connection?
Does your device show in the output of the command 'lpstat -t' run in a terminal window?

Linsoo 03-07-2017 05:50 PM

It looks like it does show. Here is the output I got after running your command:

device for canon: socket://192.168.1.4
device for Canon-MX920-series_00-BB-C1-1D-3A-C0: cnijnet:/00-BB-C1-1D-3A-C0
6500-Series accepting requests since Sun 05 Mar 2017 09:11:50 AM CST
canon accepting requests since Sun 05 Mar 2017 09:10:33 AM CST
Canon-MX920-series_00-BB-C1-1D-3A-C0 accepting requests since Sun 05 Mar 2017 12:50:41 PM CST

printer canon is idle. enabled since Sun 05 Mar 2017 09:10:33 AM CST
printer Canon-MX920-series_00-BB-C1-1D-3A-C0 is idle. enabled since Sun 05 Mar 2017 12:50:41 PM CST

allend 03-08-2017 05:08 AM

Quote:

device for Canon-MX920-series_00-BB-C1-1D-3A-C0: cnijnet:/00-BB-C1-1D-3A-C0
...
Canon-MX920-series_00-BB-C1-1D-3A-C0 accepting requests since Sun 05 Mar 2017 12:50:41 PM CST
This seems to indicate that your device is active.
However,
Quote:

device for canon: socket://192.168.1.4
...
canon accepting requests since Sun 05 Mar 2017 09:10:33 AM CST
indicates that there is a second Canon printer with a wired network connection present.
Also
Quote:

6500-Series accepting requests since Sun 05 Mar 2017 09:11:50 AM CST
suggests a further device but without a corresponding 'device for'. I also do not see lines like:
Code:

scheduler is running
system default destination: <some printer name>

in the posted output.
It is possible that other devices are causing conflicts.
I would suggest temporarily changing to 'LogLevel debug' in /etc/cups/cupsd.conf, restarting cups, and then trying another print so that a more verbose error log is generated. The error log should be accessible by entering 'localhost:631' in the address line of a browser and then clicking on Administration.

PS - When posting listings at LQ, please place between [code][/code] tags (or use the button in the Advanced editor). It preserves spacing and is easier to view due to scrolling.

Linsoo 03-08-2017 01:21 PM

I am sorry but I did not understand anything you said at the end. I am not even sure what your PS asked me to do but since I am not pasting anything this time, I am hoping it won't matter.

The 6500 comment in the code is referencing an old printer so yes, maybe there is some confusion ... I really hope that is all it is ... but I did not understand what changing to 'LogLevel debug' in /etc/cups/cupsd.conf meant.

I tried pasting both of those in a terminal but got nowhere.

I can access the error log in localhost:631 but refrained from posting it because I was not sure how you wanted it.

allend 03-08-2017 01:52 PM

Thanks for confirming the reference to an old printer. Is there also a second current printer present? For further information on editing the configuration file and restarting CUPS see
https://help.ubuntu.com/lts/serverguide/cups.html

Linsoo 03-08-2017 02:08 PM

No there is no second canon printer. I think that came from my first efforts to "install" the printer. Then I tried "find" the printer on CUPS and it found it. I just deleted the old printer and the 'bad' one that I created.

I then tried to restart CUPS from the directions on the page you sent by typing

sudo systemctl restart cups.service

in a terminal but I got

sudo: systemctl: command not found


as a response. Sorry, again, I think this is what your PS referenced. In other words, don't paste it like this but I am not sure how you wanted me to paste it. If it helps you understand my predicament ... I am old ... so I am having a really hard time understanding.

allend 03-08-2017 02:35 PM

I have never used Linux Mint, so I do not know the exact command to restart CUPS. Perhaps it is 'sudo service cups restart'. If all else fails, reboot :)

If you paste a listing, type [code] before the listing, then type [/code] after the listing.

Quote:

If it helps you understand my predicament ... I am old ... so I am having a really hard time understanding.
I do not believe a word of that! ;)

ferrari 03-08-2017 03:30 PM

Hi Linsoo. As allend has already mentioned, the lpstat output indicates multiple printer configurations defined. The Ubuntu printer configuration utility can probably help with deleting the incorrect one. Based on the following I would suggest the first printer config is not right for your Canon Pixma MX922 printer, while the second is indicative of the Canon proprietary driver (ie using the cnijnet backend)
Code:

device for canon: socket://192.168.1.4
device for Canon-MX920-series_00-BB-C1-1D-3A-C0: cnijnet:/00-BB-C1-1D-3A-C0

This could be checked by examining the corresponding .ppd files which are located in the /etc/cups/ppd/ directory. These might not mean much to you, but the following command can be used to examine some useful information about the ppd files you have configured, including the underlying driver information
Code:

egrep "Name|Model|Filter" /etc/cups/ppd/*
* Note when posting output, enclose the output between code tags for easier reading.

The 'lpadmin' command can be used to remove the first 'canon' configuration like this
Code:

sudo lpadmin -x canon
The 'Canon-MX920-series_00-BB-C1-1D-3A-C0' configuration is defined using the cnijnet CUPS backend and the printer's unique MAC address. This command should produce a testpage...
Code:

lpr -P Canon-MX920-series_00-BB-C1-1D-3A-C0 /usr/share/cups/data/testprint

ferrari 03-08-2017 03:41 PM

BTW, if you need to increase the CUPS logging verbosity for diagnostic purposes, the easiest way is via a terminal using the 'cupsctl' command like this
Code:

sudo cupsctl --debug-logging
It will make the required change and restart CUPS as part of the process. Then when a print job is sent, additional logging to error_log will occur.

To turn it off again, do
Code:

sudo cupsctl --no-debug-logging
To kill all stale/stuck print jobs, you can do
Code:

cancel -a

Linsoo 03-10-2017 01:32 PM

OK it looks like maybe I have everything all messed up, if I can interpret any of this correctly.

First I did as allend suggested and examined the .ppd files. I got this

Code:


*PCFileName:        "STP00164.PPD"
*ModelName:    "Canon PIXMA MX870"
*ShortNickName: "Canon PIXMA MX870"
*NickName:      "Canon PIXMA MX870 - CUPS+Gutenprint v5.2.8-pre1"
*cupsFilter:        "application/vnd.cups-raster 100 rastertogutenprint.5.2"
*StpDriverName:        "bjc-MULTIPASS-MX870"
*StpDriverModelFamily:        "9000870_canon"
*ColorKeyWords: "ColorModel"
*OpenUI *ColorModel/Color Model: PickOne
*OPOptionHints ColorModel: "radiobuttons"
*OrderDependency: 2 AnySetup *ColorModel
*DefaultColorModel: RGB
*StpDefaultColorModel: RGB
*ColorModel Gray/Grayscale:        "<</cupsColorSpace 0/cupsColorOrder 0>>setpagedevice"
*ColorModel Black/Inverted Grayscale:        "<</cupsColorSpace 3/cupsColorOrder 0>>setpagedevice"
*ColorModel RGB/RGB Color:        "<</cupsColorSpace 1/cupsColorOrder 0>>setpagedevice"
*ColorModel CMY/CMY Color:        "<</cupsColorSpace 4/cupsColorOrder 0>>setpagedevice"
*ColorModel CMYK/CMYK:        "<</cupsColorSpace 6/cupsColorOrder 0>>setpagedevice"
*ColorModel KCMY/KCMY:        "<</cupsColorSpace 8/cupsColorOrder 0>>setpagedevice"
*CloseUI: *ColorModel

I notice at the top it mentions Canon Pixma 870. When I was first trying to set it up, since there was not an exact match for my Pixma MX922, I tried some that were close. It has the printer listed but then forces me to also choose from a list where it is not listed (if that makes sense).

Then I tried the command to remove the first cannon printer and got this

Code:

lpadmin: The printer or class does not exist.
I had already removed the 'bad' cannon and the lexmark 6500 in CUPS so maybe they really were removed??

I then tried to produce a testpage and a popup window keeps popping up telling me it is printing a test page but it really never does. When I go to CUPS it gives me the same error hold error "cannot specify error model" I guess it just keeps trying to print it because periodically the popup box comes up saying it is printing a testpage.

So then I moved to the advice from ferrari. I entered the command but when I look at the error log on CUPS it is VERY long. I am assuming you don't want me to paste that here, or do you??

Linsoo 03-10-2017 01:34 PM

Correction: sorry the error it is giving is still "cannot specify model number"

ferrari 03-10-2017 02:35 PM

Based on your your examination of the PPD file(s), the proprietary Canon driver PPD doesn't seem to be there. You're using a gutenprint driver for the wrong model. From a quick check of the gutenprint (version 5.2.12) package I have installed, there is a driver for the Pixma MX922 printer specifically. Which version of Mint are you using? That will have a likely bearing on which gutenprint version you have installed.

https://community.linuxmint.com/soft...ver-gutenprint

I suggest starting over by at least deleting the exiting printer configurations or by removing /etc/cups/printers.conf entirely. It will be recreated the next time you configure a printer anyway.

I usually use the CUPS web interface for all administration/configuration tasks, but a printer configuration utility should be able to do the same. The former is done via a browser

http://localhost:631/admin

Your choices are to try using the proprietary driver which will use the cnijnet:/ backend, or the gutenprint driver (and perhaps the socket:// backend for network printing).


All times are GMT -5. The time now is 12:38 AM.