-   Linux - Newbie (
-   -   ctrl-c to terminate a process does not work (

geek1234 12-26-2007 02:09 PM

ctrl-c to terminate a process does not work

On ubuntu gutsy, I cannot terminate a process by using ctrl-c as i used to on fedora 4. Should I be doing something to set this up? I can set up a shortcut, but to what?

For example, if i run ping, I cannot terminate it by ctrl-c. Using ctrl-z does it, but it doesnt seem as clean since the process seems to be orphaned. If i reember, ctrl-c is sigint signal while ctrl-z is something else. In the ubuntu terminal, I tried various options in edit->send signal, but none stopped the process as I wanted. They either did nothing, or killed the terminal window.

btmiller 12-26-2007 02:34 PM

Works fine here on my Kubuntu 7.10 system. What does the output of "stty -a" show? You should have "intr = ^C" somewhere in there. If it's not set do "stty intr ^C" and see if that fixes it (you may need to put it into your shell startup file). Ping should always terminate on SIGINTR, but not all programs will (some catch SIGINTR and do not exit). Make sure that the program you're trying to terminate is actually set up to temrinate on SIGINTR.

All times are GMT -5. The time now is 06:27 PM.