LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cross compiling LFTP fails (https://www.linuxquestions.org/questions/linux-newbie-8/cross-compiling-lftp-fails-948651/)

rahulps 06-05-2012 12:00 PM

Cross compiling LFTP fails
 
Hi,
I am trying to cross compile lftp-4.3.5 for my arm based board. Its failing at some point. Below are few lines from log:

....
checking for util.h... no
checking sys/stropts.h usability... yes
checking sys/stropts.h presence... yes
checking for sys/stropts.h... yes
checking pty.h usability... yes
checking pty.h presence... yes
checking for pty.h... yes
checking for library containing openpty... -lutil
checking for _getpty... configure: error: in `/home/xxxx/yyyy/lftp-4.3.5':
checking whether posix_fallocate() works... no
configure: error: cannot run test program while cross compiling
See `config.log' for more details


I tried to run the config file as:
./configure --host=arm-montavista-linux CC=/home/mvdev/montavista/tools/arm-gnueabi/bin/arm-montavista-linux-gnueabi-gcc

Can anybody help me pointing out what is the issue here.
Thanks

weibullguy 06-06-2012 08:50 PM

Did you
Quote:

Originally Posted by lftp-4.3.5 configure script
See `config.log' for more details

as was suggested by the configure script?

rahulps 06-07-2012 12:16 PM

I checked the config.log, but could not figure out what is the issue here. I tried to fix this issue and then getting another problem now. This config system is not able to find readline package though I have given both the include and lib path as mentioned in http://www.friendlyarm.net/forum/topic/3424 but of no help (this thread not telling the final solution).

My ubuntu machine has this readline package, even I downloaded the package and cross-compiled it, and provided the same path to config system but of no use.

Any help pls.

Thanks


All times are GMT -5. The time now is 10:19 AM.