LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-19-2016, 07:44 AM   #1
sachinmm
Member
 
Registered: Oct 2015
Posts: 67

Rep: Reputation: Disabled
Smile cross compile opencv via LTIB for ARM


hello everyone,
finally after 1 month now i am reaching my target for cross compile opencv via LTIB but following are the net connection issue cant get it...

Processing: opencv
====================
Build path taken because: no prebuilt rpm,
Testing network connectivity
OK GPP:

Try opencv-1.1.0.tar.gz.md5 from the GPP
http://bitshrine.org/gpp/opencv-1.1.0.tar.gz.md5:
18:07:44 ERROR 404: Not Found.
Try opencv-1.1.0.tar.gz from the GPP
http://bitshrine.org/gpp/opencv-1.1.0.tar.gz:
18:07:45 ERROR 404: Not Found.
Can't get: opencv-1.1.0.tar.gz at ./ltib line 802.


f_buildrpms() returned an error, exiting
traceback:
main:572


Started: Fri Feb 19 18:07:41 2016
Ended: Fri Feb 19 18:07:45 2016
Elapsed: 4 seconds

These packages failed to build:
opencv

Build Failed

anyone know how to fix it?
 
Old 02-19-2016, 08:48 AM   #2
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,591

Rep: Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068
Quote:
Originally Posted by sachinmm View Post
hello everyone,
finally after 1 month now i am reaching my target for cross compile opencv via LTIB but following are the net connection issue cant get it...

Processing: opencv
====================
Build path taken because: no prebuilt rpm,
Testing network connectivity
OK GPP:

Try opencv-1.1.0.tar.gz.md5 from the GPP
http://bitshrine.org/gpp/opencv-1.1.0.tar.gz.md5:
18:07:44 ERROR 404: Not Found.
Try opencv-1.1.0.tar.gz from the GPP
http://bitshrine.org/gpp/opencv-1.1.0.tar.gz:
18:07:45 ERROR 404: Not Found.
Can't get: opencv-1.1.0.tar.gz at ./ltib line 802.


f_buildrpms() returned an error, exiting
traceback:
main:572


Started: Fri Feb 19 18:07:41 2016
Ended: Fri Feb 19 18:07:45 2016
Elapsed: 4 seconds

These packages failed to build:
opencv

Build Failed

anyone know how to fix it?
go back up to your orginal post, then click on your links to your tar balls then read what it tells you, that is your problem as of now.

the solution should then be apparent

Last edited by BW-userx; 02-19-2016 at 08:50 AM.
 
Old 02-19-2016, 11:00 AM   #3
sachinmm
Member
 
Registered: Oct 2015
Posts: 67

Original Poster
Rep: Reputation: Disabled
Yes I know but how it can be fixed??if I put another URL instead of old one this one also not taken and show same error...
 
Old 02-19-2016, 11:03 AM   #4
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,591

Rep: Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068
Quote:
Originally Posted by sachinmm View Post
Yes I know but how it can be fixed??if I put another URL instead of old one this one also not taken and show same error...
I'd not knowing exaclty what it is you're doing only that you need a good link to them tar balls.

take just the name of the tar ball in question .. copy it then paste the name of it into google search bar, then add the words "download" afterwords, then click it, then find a valid link address to each of them and try using them instead. if they are open ports it should work.

if you got wget or axel .

right click on the address or look here;

Code:
[DIR] Parent Directory                                   -   
[   ] ArSpeech.tgz                  21-Jul-2005 03:05   42M  
[   ] CanonVCC4.tar.gz              20-May-2005 09:49   23K  
[   ] Imaging-1.1.5.tar.gz          20-May-2005 09:49  420K  
[   ] MDP-1.1.0.tar.gz              31-May-2006 00:18   78K  
[   ] Numeric-23.8.win32-py2.3.exe  23-Jul-2005 14:25  1.0M  
[   ] Numeric-23.8.win32-py2.4.exe  23-Jul-2005 14:24  1.0M  
[   ] Numeric-24.0b2.tar.gz         20-May-2005 09:49  714K  
[   ] PIL-1.1.5.win32-py2.4.exe     28-Mar-2005 02:53  521K  
[   ] PeopleBot.tar.gz              20-May-2005 09:49  6.4K  
[   ] gazebo-0.5.2-fc3.i386.rpm     19-Jul-2005 15:46  2.5M  
[   ] gazebo-0.7.0.tgz              13-Feb-2007 19:38  2.3M  
[   ] gdal-1.2.6-fc3.i386.rpm       19-Jul-2005 15:46  2.6M
right click on the tar you need then select "copy link location". Then use wget or axel and try to pull it off of that link.

Code:
axel -n 500 # then paste the address after that then hit enter
wget #same thing
if it starts downloading it then you know you have an open link.

Last edited by BW-userx; 02-19-2016 at 11:12 AM.
 
Old 02-19-2016, 11:08 AM   #5
sachinmm
Member
 
Registered: Oct 2015
Posts: 67

Original Poster
Rep: Reputation: Disabled
I have try but 404 page not found error occurred I will try again with some different URL link for download and get the opencv setup...
 
Old 02-19-2016, 11:15 AM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,591

Rep: Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068
Quote:
Originally Posted by sachinmm View Post
I will try again with some different URL link for download and get the opencv setup...
exactly get a good link them other ones are prob so old they are no longer there.

opencv setup Installation in Linux

and you might want to check there too. Just in case

Last edited by BW-userx; 02-19-2016 at 11:17 AM.
 
  


Reply

Tags
opencv


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cross-compile cherokee for ARM xbyte1024 Linux - Software 0 04-05-2012 09:43 AM
Help to cross compile vlc to arm 4monkeys Linux - Embedded & Single-board computer 3 03-14-2011 06:33 AM
Libtool has syntax errors when running after GLib-2 cross compile for PPC using LTIB? maztech Linux - General 7 07-15-2010 01:39 PM
Trying to cross-compile mono for ARM hal_2001 Programming 2 05-11-2010 04:18 PM
how to cross compile tslib for arm ? sunr2007 Linux - Embedded & Single-board computer 3 06-29-2009 01:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration