-   Linux - Newbie (
-   -   Cron service and oracle service stopped unexpectedly. Can't restart oracle. (

camron 05-05-2010 08:17 PM

Cron service and oracle service stopped unexpectedly. Can't restart oracle.
I am running Fedora 11 with an Oracle 11g database installed. I came to check on it and found out that the oracle service had stopped.

I also have a script that gets run by cron every minute. I noticed that the last entry in the log /var/log/cron was March 24 at 4:26. Which was really close (not exactly to the second but within a few minutes) of the last log entry in the database translator logs (the database was processing data and it outputs a log).

I rebooted the machine and cron started running again, but I can't get the oracle service to start again. Normally it runs at startup, but if I need to run it or check it, I use

/sbin/service oracle restart
Is there another log that I could look at to see what would be the cause of the stoppage?

Any suggestions on how to get the oracle service started again?

What further details would be helpful to post here for a better description of the problem?

Thanks to anyone who can help.

kbp 05-05-2010 08:52 PM

try /var/log/messages ... how does your disk space look ?

camron 05-06-2010 12:06 PM

I have about 800 GB free on a 1 terabyte drive.

I have learned more since yesterday and it might be helpful if I tell a little history.

I had been having trouble with the screen resolution when logging in from windows remote desktop from Windows XP SP3 and xrdp installed in Fedora 11. Soon it stopped letting me in all together. After it quit letting me in, I rebooted the fedora computer. It took longer than 10 mins to boot and never made it past the white progress bar(May 4th). We did a hard shutdown and tried again. When it still took forever, I just let it sit overnight thinking that it would be the same when I came in the morining.
So when I showed up (May 5th), it was at the login screen. I logged in and it never showed the desktop... only the blue fedora background wallpaper (logging-in in person at the remote desktop).

When I rebooted, it gave me a screen that said that there were hard disk inconsistencies and that I had to do a fsck (or go through the endless loop of automatic restart if I selected to not do the fsck).

So I did it. Took about a half an hour and now it boots again.

Here's the real puzzler:
Everything from March 24th until May 4th (the day of that first reboot) is erased. All the log entries in the cron log, messages, my oracle database logger, maillog, and secure are all missing. They just end on March 24th at about 3:22 and then pick up again on May 4th when we rebooted the computer.
All the test data files we created during that time are gone.

It seems like it has been restored to a previous date. Does fedora have restore points or some mechanism to select a certain date and revert?

But I still can't restart the oracle service. And I don't understand why I have all this missing data.

kbp 05-06-2010 07:12 PM

Hard drive might be on the way out .... what partition was the missing data on ?

ramram29 05-11-2010 11:57 AM

Have you tried starting the Oracle database manually through sqlplus? What does the alert.log say?

camron 06-10-2010 01:35 PM

There was too much data loss to try and recover from there.. It seemed like everything was gone as if the computer hadn't been turned on since March.
I am sorry to say that the solution was to reinstall the database on Oracle's Enterprise Linux and add the data again. However, now it's running smoothly.

I highly recommend to anyone trying to use Oracle on Fedora to just put it on OEL and many of your problems will be magically solved.

chrism01 06-10-2010 07:00 PM

Fedora is the (bleeding edge) R&D distro for things that may appear later in RHEL. OEL, Centos and others are copies of RHEL.

All times are GMT -5. The time now is 12:13 AM.