-   Linux - Newbie (
-   -   Cron not working / updating Opensuse 11.0 (

elnita 05-04-2010 12:54 AM

Cron not working / updating Opensuse 11.0
I am new to Linux and have done an install of Moodle 1.9.8 on Linux OpenSuse 11.0

I have created my cron via the terminal (crontab -e) root crontab - see below

*/5 * * * * http/moodle/moodle/admin/cron.php

I have run the followings scripts as well:

# ls -lut /etc/init.d/cron
-rwxróró1 root root 4363 Apr 29 10:29 /etc/init.d/cron

# ps -el | grep cron
1 S 0 5220 1 0 80 0 - -- 3652 - ? 00:00:00 cron

# ls -lut /etc/crontab
-rw-róról root root 326 Apr 29 10:29 /etc/crontab

# chkconfig --list | grep cron
cron 0-off 1-off 2-on 3-on 4-off 5-on 6-off

When going to /var/log/messages my cron entries appear as they should but my backup does not run and every morning when I go to the Notifications tab it tells me my crom maintenance script has not run in 24hours.

I would also like to get this in a log file and emailed to me.

Any assistance is welcome

rdgreenlaw 05-05-2010 06:43 PM

have you tried webmin?
Try installing Webmin, then use webmin to configure the crontab table. Compare webmin's output with your hand-created table to see what's different. This might help you to determine the problem. Also, it is possible to restrict cron to only run for specific users. If this is the case on your system you have 2 options. 1. Enable cron for your username 2. put your crontab entries in the root crontab. Either way your crontab entries should work.

Allowing a program like webmin ( to create a system configuration for you and then tweaking the created table is a great way to learn. Webmin is a very small web server that runs on your system through your web browser (http://localhost:10000) If you are running a system that restricts root access (like Ubuntu) you will need to use a non-privileged user with root access via sudo to login to webmin, otherwise login with root and the root password to add your user name to the user table. Webmin's creator is very helpful to new users answering help requests quickly and correctly.

vikas027 05-05-2010 08:40 PM

Have you tried to restart crond daemon.


service crond restart

All times are GMT -5. The time now is 02:06 PM.