LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Creating and mounting FAT32 partition (https://www.linuxquestions.org/questions/linux-newbie-8/creating-and-mounting-fat32-partition-460565/)

Maverick1182 07-03-2006 09:39 AM

Creating and mounting FAT32 partition
 
I've tried to follow a lot of the recommendations (eg. using chmod 777, editing fstab, changing permisisions in KDE) in the threads on how to make a FAT32 system which can be editted by a normal user but i still keep getting errors. I'm going to create the partition again and start afresh. Could someone tell me step by step how i can create a FAT32 which i can then access as a normal user hassle free?

Thanks.

xpromisex 07-03-2006 10:07 AM

To create the partition, I would use something like gParted / qtParted - but that's because I don't feel that I personally am good enough to use fdisk when I don't HAVE too.

To mount the partition add a line like this to your /etc/fstab:

/dev/hda5 /mnt/windows vfat users,iocharset=utf8,umask=000 0 0

I'm not sure if it is 'users' or 'user', but it really doesn't matter as it is getting mounted on boot and the user doesn't have to mount it manually. Also make sure that your windows partition is /dev/hda* or you will recieve errors. Same deal with the mount point - make sure that it exists.

ethics 07-03-2006 10:14 AM

the umask=000 is probably the bit you were lacking before, it means that every file is set to 777 (umask works in reverse, subtracting from the permissions).

pronoy 07-03-2006 10:24 AM

Assume that you want to create a partition in /dev/hda,
follow these steps and check if works:

1. fdisk /dev/hda and use the subsequent commands in fdisk, 'm' for help page
n => new partition
select primary and follow the instruction
p => print the partition table
l => to see the id for vfat, its 'b'
t=> to chage the id, and then enter 'b', the vfat id
w=> save the changes.

now make a vfat partions on the newly created /dev/hda1 partition
# mkfs.vfat /dev/hda1

hope it will help.

kstan 07-03-2006 10:39 AM

I mount my fat32 partition with edit the /etc/fstab,
/dev/hda1 /media/windows vfat defaults,uid=kstan,rw 0 0
Please have a try.

Maverick1182 07-04-2006 06:28 PM

kstan's line seems to have worked although azureus still complains on first trying to creat folders (which i can probably live with)

At least I can create folders and copy files which is the main issue!

thanks guys!


All times are GMT -5. The time now is 12:32 AM.