LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Crashed Again (https://www.linuxquestions.org/questions/linux-newbie-8/crashed-again-701272/)

MooseMagnet 01-31-2009 01:12 PM

Crashed Again
 
This is the second time it's crashed in two weeks. This time it was because I added some text to xorg.conf, trying to get the stupid touchpad to work. Trying to use gsynaptics, instead of synaptics - Intrepid on Dell Inspiron - I haven't been able to get the touchpad to work right with Intrepid. (It worked with Dapper, Edgy, and Feisty.)

It crashed when I restarted the laptop.

When it crashed, it displayed text only. These are the last few lines:

No resume image, doing normal boot...
Ubuntu 8.10 rich-laptop tty1
rich-laptop login:

Then I enter login and password, and it gives me the terminal prompt. I tried several things, but could not get the system back.

How can I get the system back if it does this again? This is the second time it's done it in the past 2 weeks. I've lost data and had to rebuild from iso disk each time.

(The first time it crashed the same way, because a Launchpad helper sent a command to install a different driver, and that driver had a bug.)

Thanks.

jhwilliams 01-31-2009 02:29 PM

Quote:

Originally Posted by MooseMagnet (Post 3427401)
No resume image, doing normal boot...
Ubuntu 8.10 rich-laptop tty1
rich-laptop login:

This has nothing to do with the problem. "Resume image" is a memory dump in swap space that gets created when you hibernate. It won't exist unless you're coming out of a hibernate.

I would suggest that you read your Xorg logs in /var/log. You can start the gui from the command line by typing gdm. If it starts up okay, then make sure gdm is on at the appropriate run levels, and that your system has a default run level 5 in inittab.

MooseMagnet 01-31-2009 04:33 PM

My thanks and apologies, but I understand about 10% of what you wrote.

syg00 01-31-2009 06:39 PM

You can probably get everything to work without an xorg.conf at all. Try "mv /etc/X11/xorg.conf /etc/X11/xorg.conf.saveit" then reboot.
Intrepid uses a different xorg-server - try searching on evdev for background.


All times are GMT -5. The time now is 05:59 AM.