LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-25-2012, 10:57 PM   #1
killingthemonkey
Member
 
Registered: Mar 2011
Location: Winston-Salem, NC
Distribution: Fedora, CentOS
Posts: 127

Rep: Reputation: 12
CR-48/Ubuntu/WINE/Steam/Terraria


I have Ubuntu installed on a CR-48. Istalled latest WINE. Installed Steam. Through Steam installed Terraria. Try to start Terraria and get the Steam notification, "Preparing to start Teraria." Notification goes away. Game doesn't open.

Ubuntu 11.10
Latest WINE, with loader

Thanks for any help.
 
Old 02-27-2012, 10:23 AM   #2
rizzy
Member
 
Registered: Mar 2004
Distribution: Debian
Posts: 283

Rep: Reputation: 68
have you looked through this?: http://appdb.winehq.org/objectManage...sion&iId=24915

You'll need to post errors you get then running the game in terminal: " Notification goes away. Game doesn't open." is far too little information for anyone to be able to help you.
 
1 members found this post helpful.
Old 02-27-2012, 08:10 PM   #3
killingthemonkey
Member
 
Registered: Mar 2011
Location: Winston-Salem, NC
Distribution: Fedora, CentOS
Posts: 127

Original Poster
Rep: Reputation: 12
OK, fair point. How do I run the game in terminal?
 
Old 02-28-2012, 04:11 AM   #4
rizzy
Member
 
Registered: Mar 2004
Distribution: Debian
Posts: 283

Rep: Reputation: 68
Find were the executable for the game is, it'll be somewhere in /home/username/.wine/Drive_C/Steam/... Using cd (change directory) command in terminal change to that directory then run "wine teraria.exe" - post output in the terminal.
 
1 members found this post helpful.
Old 02-28-2012, 05:24 PM   #5
killingthemonkey
Member
 
Registered: Mar 2011
Location: Winston-Salem, NC
Distribution: Fedora, CentOS
Posts: 127

Original Poster
Rep: Reputation: 12
Thanks, rizzy. BRB with output.
 
Old 02-28-2012, 05:37 PM   #6
killingthemonkey
Member
 
Registered: Mar 2011
Location: Winston-Salem, NC
Distribution: Fedora, CentOS
Posts: 127

Original Poster
Rep: Reputation: 12
Here's the error in terminal:

Code:
wine: Install Mono 2.8 or greater for Windows to run .NET 4.0 applications.
So I need to figure out how to install Mono. apt-get install did not work. Also, need to learn what it is.

Thanks for your help.
 
Old 02-28-2012, 06:01 PM   #7
killingthemonkey
Member
 
Registered: Mar 2011
Location: Winston-Salem, NC
Distribution: Fedora, CentOS
Posts: 127

Original Poster
Rep: Reputation: 12
OK, it says I need 2.8 or greater, but I have 2.10.5 installed.

Output from mono --version:

Mono JIT compiler version 2.10.5 (Debian 2.10.5-1)
Copyright (C) 2002-2011 Novell, Inc, Xamarin, Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: x86
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: Included Boehm (with typed GC and Parallel Mark)

Last edited by killingthemonkey; 02-28-2012 at 06:36 PM.
 
Old 02-29-2012, 01:11 PM   #8
rizzy
Member
 
Registered: Mar 2004
Distribution: Debian
Posts: 283

Rep: Reputation: 68
make sure you have winetricks installed ( sudo apt-get install winetricks ) then install mono:

winetricks mono28
 
Old 03-01-2012, 11:18 AM   #9
killingthemonkey
Member
 
Registered: Mar 2011
Location: Winston-Salem, NC
Distribution: Fedora, CentOS
Posts: 127

Original Poster
Rep: Reputation: 12
Quote:
Originally Posted by rizzy View Post
make sure you have winetricks installed ( sudo apt-get install winetricks ) then install mono:

winetricks mono28
Done.

New error.

Code:
implement type compare for 1b!

abnormal program termination
err:mscoree:expect_no_runtimes Process exited with a Mono runtime loaded.
 
Old 03-01-2012, 12:01 PM   #10
rizzy
Member
 
Registered: Mar 2004
Distribution: Debian
Posts: 283

Rep: Reputation: 68
not at my PC right now,
but a couple of things to try:
1. run wine with sudo just to make sure there aren't any permissions issues: sudo wine ./terraria
2. pre-set wine environment to 32bit: env WINEARCH=win32 wine ./terraria
3. Check that wine is 1.3.19 or greater

I look at it once more at my PC.
 
Old 03-01-2012, 01:18 PM   #11
killingthemonkey
Member
 
Registered: Mar 2011
Location: Winston-Salem, NC
Distribution: Fedora, CentOS
Posts: 127

Original Poster
Rep: Reputation: 12
Quote:
Originally Posted by rizzy View Post
not at my PC right now,
but a couple of things to try:
1. run wine with sudo just to make sure there aren't any permissions issues: sudo wine ./terraria
2. pre-set wine environment to 32bit: env WINEARCH=win32 wine ./terraria
3. Check that wine is 1.3.19 or greater

I look at it once more at my PC.

sudo wine Terraria.exe

and

sudo wine ./terraria

both yield:
Code:
.wine is not owned by you
WINEARCH=win32 wine Terraria.exe

yields:
Code:
wine: cannot find L"C:\\windows\\system32\\Terraria.exe"
 
Old 03-01-2012, 02:14 PM   #12
rizzy
Member
 
Registered: Mar 2004
Distribution: Debian
Posts: 283

Rep: Reputation: 68
Having had a good look on google:
1.Not sure if you hardware (graphics chip) has XNA support - apparently required to run the game.
2. Your error "err:mscoree:expect_no_runtimes Process exited with a Mono runtime loaded" - most common solution seems to be:
Quote:
Here is a hint: you have to start with a brand new 32-bit (this is important) wine folder. so, rename your current .wine and run

WINEARCH=win32 winecfg

After that, follow this guide step by step:

http://tom-geiger.de/?p=163
Sorry, short of buying the game i can't be of more help but it might be worth asking at Terraria forums: http://www.terrariaonline.com/forum/#terraria.5
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Steam on Wine, cannot login,"Steam is having trouble connecting to the Steam servers" cantab Linux - Games 1 06-19-2010 07:32 AM
help with steam and wine hekark Linux - Software 7 01-31-2006 01:19 PM
Steam with Wine the_sLiDe Linux - Software 0 10-02-2004 01:02 PM
Wine and Steam 1.6 chewysplace Linux - Software 11 08-29-2004 06:49 PM
hl under wine ( not steam) samhob Linux - Games 2 01-12-2004 12:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration