LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-20-2006, 10:59 AM   #1
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 524

Rep: Reputation: 31
cp -u doesn´ t update


Hi!

I bought an external HDD in order to have always all my datas with me. I would like to be abble to stick it into my computer at work, make a
Code:
cp -Rpuv
in order to get my workstation updated; then when I´ m done with my work:
Code:
cp -Rpuv
but this time to have my external HDD updated, then the same thing at home.

the problem ist that even though I say cp -u (update) it copies all the datas all over again even though they are unchanged.
Did I oversee something? Why doesn´ t seem to work correctly?
Is there any more appropriate command for my need?

Thanks.
 
Old 12-20-2006, 12:12 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Please take a look at rsync
You'll find it much more useful!
 
Old 12-26-2006, 03:00 PM   #3
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 524

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by tredegar
Please take a look at rsync
You'll find it much more useful!
Thanks for the advice.
I tried this:
Quote:
rsync -urlpogDt
then I tried this
Quote:
rsync -urlpogDtn
(with -n --dry-run to show what would have been transferred)
And still it copies the whole datas again even though nothing has changed! I really don't understand why.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Beta_5iso doesn’t boot. ArchAngeL13 MEPIS 4 06-16-2006 07:22 AM
sshd doesn`t work TiCkO Linux - Networking 12 02-11-2006 06:00 PM
Microphone doesn' work Lars79 Slackware 20 08-30-2005 10:24 AM
python doesn´t work little_ball Linux - Newbie 4 12-04-2004 10:09 AM
kopete doesn´t work maZ Linux - Software 1 07-31-2003 04:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration