Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 06-04-2007, 07:15 AM   #1
Registered: Dec 2005
Location: Lahore, PK
Distribution: Fedora 14
Posts: 105

Rep: Reputation: 16
Couldn't mount Local Drive vfat Partitions on Boot.

I am facing problem in mounting my local drive vfat partitions on boot. I have to mount them manually after boot even i have configured the /etc/fstab file to mount them at boot. My configuration is given below
OS: Fedora Core 6
HDD: Segate 40GB configured as Primary Master

Partition Table:
[root@mustu ~]# fdisk -l

Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 1211 9727326 83 Linux
/dev/hda2 1212 1290 634567+ 82 Linux swap / Solaris
/dev/hda3 1291 4865 28716187+ f W95 Ext'd (LBA)
/dev/hda5 1291 3078 14362078+ b W95 FAT32
/dev/hda6 3079 4865 14354046 b W95 FAT32
Entries i put in my /etc/fstab file:
[root@mustu ~]# cat /etc/fstab

/mnt/d /dev/hda5 vfat defaults 0 0
/mnt/e /dev/hda6 vfat defaults 0 0
Could anyone tell me what is the problem. And what is the command that instructs to re-read the /etc/fstab files?
Old 06-04-2007, 07:25 AM   #2
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
There is an option "auto" to mount drives from /etc/fstab on boot.
Old 06-04-2007, 07:42 AM   #3
Registered: Aug 2002
Posts: 16,430

Rep: Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938
FYI auto is a default option. The order for an fstab entry is:
device mountpoint filesystem type options dump fsck

and not mountpoint device.

See fstab man pages for additional details.

Last edited by michaelk; 06-04-2007 at 07:46 AM.
Old 06-04-2007, 10:24 AM   #4
Registered: Jan 2007
Distribution: Slackware
Posts: 341

Rep: Reputation: 31
The line can be:
/dev/hda1        /mnt/wins-c      vfat        ro               1   0
Have you created d and e dirs in /mnt?
Old 06-05-2007, 02:52 PM   #5
Registered: Dec 2005
Location: Lahore, PK
Distribution: Fedora 14
Posts: 105

Original Poster
Rep: Reputation: 16
yes i've creatd the d and e dires in /mnt
Old 06-05-2007, 05:11 PM   #6
Senior Member
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
You can attempt to mount the filesystems that you have put into the fstab by simply saying "mount /mnt/d" or "mount /mnt/e" depending on which one you need to mount. If it doesn't mount, then the fstab entry is wrong (since you have already stated you created the /mnt/d and /mnt/e directories).

Did you make the change to your fstab as michaelk stated above?

The entries should be:
/dev/hda5 /mnt/d vfat defaults 1 0
/dev/hda6 /mnt/e vfat defaults 1 0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA - VFAT local mount for all user write access... dolvmin Linux - Software 13 12-21-2006 04:50 PM
Pleaase help me to mount VFAT drive to everyone kikkubey Linux - Hardware 3 10-21-2005 08:40 AM
Can't mount flash drive with vfat? maq Linux - Hardware 2 04-10-2005 05:57 PM
Users cannot mount or access mounted windows vfat partitions (Distro: Gentoo Linux) kamel Linux - Software 6 05-15-2004 07:08 PM
mount a vfat hard drive allelopath Linux - Hardware 16 04-06-2003 02:48 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:59 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration