LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Could not enter directory mnt/cdrom (https://www.linuxquestions.org/questions/linux-newbie-8/could-not-enter-directory-mnt-cdrom-65584/)

mgbgt 06-14-2003 12:07 PM

Could not enter directory mnt/cdrom
 
Hi,
Using mandrake 9.1 and not getting on too well , this is day 2 the desktop is fine and the floppy reads any way.
But cdroms dont read music or data cds. They are on the desktop and and the context menu (right click) has an unmount option. I seem to have set it up for auto logon as am mostly only user, but do have root passsord.
Also need to get modem correctly recognised, I have new driver but that is another days work.
Regards
martin

MasterC 06-14-2003 02:24 PM

Hi Martin!

(side note) you might wanna see about removing the blank space in your signature...

(On topic) When you place a data cd into the ROM, does an icon appear on your desktop? If so, can you then click on that icon to access the data cd? I don't quite follow what you have tried to do (or haven't tried) so it's going to kind of be hard to help ;)

Just let us know what you have tried so we can then give you options/suggestions to go with from there.

As for audio CD's, normally linux doesn't mount an audio CD, instead one of the CD playing applications (such as koncd or grip) will simply play them straight from the device.

Cool

mgbgt 06-14-2003 05:14 PM

Mandrake 9.1 no CD play
 
Thanks Master C,
This is a magazine free 2 CD copy of 'drake 9.1 , with KDE only installed
The CD icons are on the Desktop by default as is the
floppy icon,. when I put a data/music cd and try to open
I get and error dialog from Konquerer - Could not enter
directory mnt/cdrom. I also have a music player in the Sys. tray ( same term as windows??) KsCD which does not play but does flash the light on one of the CD rom drives also just noticed a tool tip over the KsCD icon in Sys Tray Quote " no matching freedb entry fo... "Thanks for your help and interest
Martin.
P.S. The space in the signature was an
attempt to do this 9_.1_ or I have half of Mandrake.
2
Do'nt think I have a future as a super coder.

Qzukk 06-15-2003 12:50 PM

Ok, first music cds cannot be mounted or browsed. This is why you get the "cannot enter /mnt/cdrom" when you try to use a music CD.

Second, it looks like its trying to play the cd properly (since the light on the cdrom drive comes on). You mention that it flashes on "one of the cdrom drives"... is it the correct cdrom drive? You may need to look at its configuration to change the cdrom drive it is trying to play. Also check and make sure your volume is turned up. Check both the main volume and the CD Audio volume controls. If it is, and you're still not getting sound from it, check and make sure you have the little audio cable going from the cdrom drive to your soundcard. Should be a tiny gray cable with either 4 pins (old style) or 2 pins (spdif type).

mgbgt 06-15-2003 05:27 PM

Sound wire was missing!!!
 
Thanks Qzukk.
I have dual boot with XP, and both CD and CDRW play music with XP and only have the wire because it came with recent CDRW but as origonal CD player played music without sound wire I thought not to install it on new CDRW. I have now connected sound wire to CDrom and 'drake is making music, and XP plays music on CDRW without sound wire.
Even though new to PCing I think very much in MS terms and now because I have an auto log in as user I can't acess a cd with a modem driver I need I want the right click menu to give me the option to acess the drive as "root" but it does'nt so I have to click your good self if your still interested . I'm impressed with this 'drake but I just do'nt take to it like a duck to water.
Regards
martin
P.SS- Solved this now by altering permissions in Security Control Panel

lectraplayer 06-17-2003 08:50 PM

Does the light stay on or keep flashing when playing an audio CD? If so, you just gotta run a cable from the CD-ROM to your sound card, or turn it up in kMix. ...as far as like browsing a UT2003 CD, is that what you have problems with?

PS: Remember you can hit Ctrl-F1 and get to the konsole. It's really handy. Need root there? Just hit "su" and go.


All times are GMT -5. The time now is 10:50 PM.