Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 06-01-2009, 09:47 AM   #16
LQ Newbie
Registered: Jun 2009
Posts: 1

Rep: Reputation: 0


I have got the same problem/error message. Another process blocks Port 80, but the strange thing about it is:
# netstat -ltnup
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
tcp        0      0 *               LISTEN     32514/bash          
tcp        0      0*               LISTEN     3310/mysqld         
tcp        0      0 *               LISTEN     3354/perl           
tcp        0      0    *               LISTEN     5517/proftpd: (acce 
tcp        0      0    *               LISTEN     597/master          
tcp6       0      0 :::3690                 :::*                    LISTEN     21003/svnserve      
tcp6       0      0 :::110                  :::*                    LISTEN     30145/couriertcpd   
tcp6       0      0 :::143                  :::*                    LISTEN     27641/couriertcpd   
tcp6       0      0 :::80                   :::*                    LISTEN     32514/bash          
tcp6       0      0 :::22                   :::*                    LISTEN     2594/sshd                 
udp        0      0 *                          3354/perl
It looks like bash is blocking Port 80. I have a VServer, so I have to connect via SSH to get a shell. So, when I kill this process, I get disconnected of course. But after killing it, Port 80 is still blocked by another program. I found out by running a port-scan. When I run the Apache on a different Port it works pretty good...

Do you have any idea, how I could fix this? I already tried many solutions mentioned here. But none seems to work for me.
Old 08-08-2009, 12:09 AM   #17
LQ Newbie
Registered: Aug 2009
Posts: 1

Rep: Reputation: 0
Restart apache2 as root user (sudo)

I got this error when I ran the command:
/etc/init.d/apache2 restart

I just added sudo (ran the command as root user)
sudo /etc/init.d/apache2 restart

and it worked!

Hope this is useful.
Old 01-18-2012, 12:55 AM   #18
LQ Newbie
Registered: Dec 2011
Posts: 9

Rep: Reputation: Disabled
listen to 80 port in cent 5.6 final, kernel 2.6.18

I find post that make listen port in httpd.conf file like this
/etc/httpd/conf/httpd.conf Listen 80 & this
/etc/httpd/conf.d/ssl.conf Listen 443

I have cent 5.6 with kernel 2.6.18-238.12.1.e15 on an i686

but I faced with
-bash: /etc/httpd/conf/httpd.conf: permission denied

also with 443 I found

/etc/httpd/conf.d/ssl.conf: permission denied

can you help me..
Old 01-18-2012, 12:59 AM   #19
LQ Guru
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.10, Centos 7.5
Posts: 17,569

Rep: Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426
Please do NOT resurrect a 3 year old thread; start a new one instead.
FYI, looks like you don't realise you need to be root user to edit that file.

Welcome to LQ


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
(98)Address already in use: make_sock: could not bind to address bruvajon Linux - Software 34 11-30-2011 04:08 PM
Bind : address already in use on solaris blackhole123 Solaris / OpenSolaris 2 12-14-2005 06:38 AM
how can i remove an address bind sibu_rajappan Linux - Networking 0 12-24-2004 02:50 AM
bind : Address already in use sheni Linux - Networking 1 11-11-2004 01:41 PM
cannot bind to socket: address already in use exfacior Linux - Wireless Networking 0 09-27-2004 01:34 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:51 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration