LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-04-2012, 08:09 PM   #1
janejanehsu
LQ Newbie
 
Registered: Sep 2012
Posts: 1

Rep: Reputation: Disabled
Correct GRUB command line for SATA AHCI controller


Hi,

I am trying to enable SATA AHCI flow for our virtual platform (all software models).

I have SATA controller working in AHCI mode, not IDE mode anymore. And use SVOS image to try to enable AHCI flow.

To make it simple, port 0 of SATA AHCI controller connects Harddisk Drive (software model).

After INT19, I see the GRUB command line (preset already in
our SVOS image file) as the following:

Command line: root=/dev/sda5 mem=svos@256M idle=poll lpj=1 ide=no_ide_inprogress_test noapic f11kdb console=ttyS0,9600n8 console=tty0 ro

Then the kernel command line is the same as the above.

Then I saw the kernel booting message in my LCD display as the following:

RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
loop: loaded (max 8 devices)
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx

So I think somehow the "IDE driver code" is kick in from here.

Is this correct? Because my SATA controller now only supports AHCI mode not IDE mode.

Is it okay to let it continue to boot, get "IRQ probe failed" message, and ignore those messages.

Is there a command option like "ide=off" to disable the IDE driver code?

Here is the continuing messages from the booting:

hda: IRQ probe failed (0xfffffffffffffcfa)
hda: IRQ probe failed (0xfffffffffffffcfa)
hda: IRQ probe failed (0xfffffffffffffcfa)
hda: IRQ probe failed (0xfffffffffffffcfa)
hdb: IRQ probe failed (0xfffffffffffffcfa)
hdb: IRQ probe failed (0xfffffffffffffcfa)
hdb: IRQ probe failed (0xfffffffffffffcfa)
hdb: IRQ probe failed (0xfffffffffffffcfa)
hdc: IRQ probe failed (0xfffffffffffffcfa)
hdc: IRQ probe failed (0xfffffffffffffcfa)
hdc: IRQ probe failed (0xfffffffffffffcfa)
hdc: IRQ probe failed (0xfffffffffffffcfa)
hdd: IRQ probe failed (0xfffffffffffffcfa)
hdd: IRQ probe failed (0xfffffffffffffcfa)
hdd: IRQ probe failed (0xfffffffffffffcfa)
hdd: IRQ probe failed (0xfffffffffffffcfa)
ide2: I/O resource 0x3EE-0x3EE not free.
ide2: ports already in use, skipping probe
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:1f.2[B] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
ahci 0000:00:1f.2: AHCI 0001.0200 1 slots 4 ports ? Gbps 0x9 impl SATA mode
ahci 0000:00:1f.2: flags: 64bit ncq stag pm led clo only pio slum part
HOST IRQ = 11
ata1: SATA max UDMA/133 cmd 0xffffc2000001a100 ctl 0x0000000000000000 bmdma 0x0000000000000000 irq 11
ata2: SATA max UDMA/133 cmd 0xffffc2000001a180 ctl 0x0000000000000000 bmdma 0x0000000000000000 irq 11
ata3: SATA max UDMA/133 cmd 0xffffc2000001a200 ctl 0x0000000000000000 bmdma 0x0000000000000000 irq 11
ata4: SATA max UDMA/133 cmd 0xffffc2000001a280 ctl 0x0000000000000000 bmdma 0x0000000000000000 irq 11
scsi0 : ahci
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)

Will really appreciate for any inputs for this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"TRUSTED RECEIVE" command failed on 631xESB/632xESB SATA AHCI Controller sergnk Linux - Hardware 0 08-31-2012 11:24 AM
Asking for an Utility to switch SATA AHCI to ATA or IDE ( BIOS hides SATA option) lahdili.reda Linux - Newbie 2 07-14-2012 08:19 AM
Can Grub load SATA device through PCI controller? tessx Fedora 12 01-05-2009 06:51 AM
Intel ICH8M SATA AHCI Controller kidzmom3 Linux - Hardware 3 01-26-2008 11:12 AM
GRUB problem - Error 21 + SATA controller (Promise PDC20376) klorko Linux - Software 1 12-09-2005 10:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration