LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-11-2004, 05:47 PM   #16
fiets
LQ Newbie
 
Registered: Dec 2003
Posts: 13

Original Poster
Rep: Reputation: 0

Hi JDW,

I've been playing, toggling, trying and thinking a lot over the weekend with only moderate result:

as it is I've now created 3 different users, one for chinput, one for xcin and one for cfitx. I've been trying all 3 users with oowriter & kmail, the results so far:

chinput user

chinput & oowriter: it works somehow, at least I get to choose some characters: most of the numbers entries however are empty, I get to choose from characters that aren't even written that way in pinyin (e.g. I put in ma and get a character like fu) and when I choose the character what is put in the document is a completely different ma character).

chinput & kmail does not work at all, the character list doesn't even show

xcin user

xcin & oowriter: pinyin input and most others (that I hardly now how to use) does not work.

xcin & kmail: astonishingly xcin responds just as together with oowriter

fcixt

fcixt & oowriter: now this is a very intelligent im: fcitx works perfectly with oowriter.
(And evolution, which I also tried). First of all I could not believe it as this new 2.0 version only gives you the choice of 5 different characters only but it does work!
One snag or bug I discovered though: fcitx does not recognize nu (woman) at all, instead it gives you anger, fury. First I thought I did something wrong but if you try nu cesuo (women's toilet) you'll see my point.

fcitx & kmail: fcitx works, but I'm not able to copy the selected characters to the kmail document.

I tried to copy some Chinese with German special character text which was performed excellently in oowriter to kmail:
the Chinese was pasted perfectly but the German special characters disappeared.
Therefore I suspect the whole thing has got something to do with unicode settings, KDE font settings or maybe with Chinese fonts itself?

Are you using any other Chinese fonts than the ones that come with the mandrake 9.2 distro (the AR PI Kaitim, Mingti and Sungti)?
What font have you configured in KDE?
 
Old 01-11-2004, 09:14 PM   #17
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
contemplations on Linux and Chinese wordprocessing

Hi Fiets,

There is no real need to create separate users for xcin, chinput & fcitx. You can get them working on the same user with different apps, but personally speaking, I am very happy just to use fcitx 2.0.

One thing I did on the weekend was install Mozilla Firebird browser & Thunderbird email client, wow, I am impressed with those, and the good news :- Firebird rendered the Chinese websites I visited quite nicely, and I could easily type emails in Chinese with Thunderbird/fcitx...I can highly recommend these lightweight, quick apps for browsing & emailing...(go to www.mozilla.org/ and hit the products tab)

typing "nü" - woman (yes, they give me anger & fury too, I'm married! ;-) is done by typing "nv", so "lüguan" - "hotel" will be entered by "lvguan"...too easy!

I'm not sure what you mean that you cannot copy or paste these characters, when you input some pinyin (e.g. "beijing") and you get 2 choices (1. Beijing, the city 2. beijing, meaning background), then you can press the space bar to enter the first selection, or the number to select any of the other selections - if I wanted to say background in this example, I would type "beijing" and then the number "2" and the characters will be automatically inputted into the document or app that you are using...

I've never tried Chinese with German special characters, so I cannot really help you there...

For (many) extra Chinese fonts, I trawled the web for sites where you can download all sorts of different styles of Chinese fonts, so give Google a try...have a good look around, some of these font providers charge a fortune...

cheers,

jdw
 
Old 01-13-2004, 11:35 AM   #18
fiets
LQ Newbie
 
Registered: Dec 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
There is no real need to create separate users for xcin, chinput & fcitx.
That somehow did the trick in may way of thinking! I thought one needed different users for different input managers.
But now I realise one just needs 2: one for GB and big5 each.

Realising that and noting your remarks on how to input "v" fpr "ü", I tried again and bingo! xcin now does work properly and perfectly, it all comes fdown to realising how the system works. I never found a document explaining how to use it, so it was just try and error.

So now I got both fcitx and xcin running properly, even though fcitx still does not work under kde applications (kmail, kwriter). I hope to sort this out in a later stage.


Quote:
'm not sure what you mean that you cannot copy or paste these characters
here I was referring to copying Chinese text created with fcitx from oowriter to kmail.

I already downloaded some extra fonts (and will try to see how I can install them and work properly. here's a good link for Chinese fonts

After I manage that, I will kind of make a draft for a mandrake 9.2 specific howto for newbies, including your remarks for your perusal before I publish it: then maybe we can have some other more experienced users to comment and add to it.

As for now, thanks ;-)!
 
Old 01-13-2004, 04:44 PM   #19
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
contemplations on Linux and Chinese wordprocessing

Hi Fiets,

Maybe the KDE applications (Kmail, Kwrite) will work if you set your KDE settings as well to Simplified Chinese - sorry, I should have mentioned this before!

It's very easy to do - log out of your English (or German/Dutch) user and log into your chinese user with KDE.

From the main KDE menu, select Configuration/Accessability (this is in Mandrake 9.2, I am not sure about the default menu setup in other distros), and select "Country & Language".

Then set the country to P.R. China, and it will set the language to Chinese Simplified. Press "Apply/OK" and log out, and log in again, and then all the menus etc. in KDE will have changed. The standard KDE apps should all work now too with fcitx...

If you are going to do a proper How-To at tldp.org, I would like to be involved in some way and make my small contribution to the Linux community, albeit those members of the community who use Chinese text-processing! (well, there are probably a few througout China alone!).

cheers,

jdw
 
Old 01-17-2004, 05:46 PM   #20
fiets
LQ Newbie
 
Registered: Dec 2003
Posts: 13

Original Poster
Rep: Reputation: 0

[b}To previous readers of this message: please note the message has been edited on January 19th after receiving new instructions from the author, Gerrit Fricke: see code at /home/.i18n has been changed but now everything works.

Also please note that a new revised manual will be uploaded shortly to be shown at the link address mentioned underneath where the original German text is displayed.

Further revisions might be added later on for those who want to be able to add a 3d, different language locale environment
[/b]


Howdy, JDW,

I've been trying and errowing these last few days.
In the mean time I found this. It's a manual written by Gerrit Fricke on how to display Chinese in a German environment.
It's basically what we want, however I've not been able to implement everything 100 % as Gnome applications (e.g. GIMP, GnuCash, Evolution) still do not display correctly in my western environment. This however may have to do with my own settings.

As it is, the article is written with the presumption to create a German environment with SCIM. I subsitituted German with Dutch and SCIM with fcitx and it works flawless for me in a KDE environment. I have no reason to doubt why it would not work in any other western language environment. After consulting Gerrit Fricke I translated the article. My comments are in a different colour in between:

quote

Problem: I installed everything but my IME (input method editor) will only start when I'm logged in with locale Chinese. But I don't like my menus to be Chinese. Do I have to chance locales every time I want to write Chinese or is there a method to activate the IME even when my desktop is localised to German?

This manual is to help all those that would like to be able to write Chinese with a German localised desktop without having to change the locale continuously.

My distro is Mandrake 9.1 with KDE 3.1.4. but this manual is supposed to work with Mandrake 9.0/9.1/9.2, in case you have any other distribution you will have to try yourself.. When installing Mandrake, I also installed the locales-de for German and locales-zh for Chinese. These are the locale packages from the installation CD's for German and Chinese support. Furthermore the font packages ttf-gb2312 and ttf-big5 should have been installed from the CD's as well as well as kde-i18-zh, the Chinese environment for the KDE desktop in case you want the desktop to be displayed in simplified Chinese and kde-i18-de for a German desktop.

Now, using LocaleDrake you are able to switch to Chinese quite easily. OK so far , but how do I write Chinese? Mandrake ships with Chinput and XCIN. Chinput does not work under Mandrake 9.1 (at least not the version on the distro CD) and XCIN is not really my thing. So what's next?

I downloaded SCIM from turbolinux. The default packages work flawless, even if there are some dependency problems with GTK2, which however you may circumvent quite easily by opening a console (as root) and by typing:

urpmi --allow-nodeps packagename

Obviously you will have to be in the directory with the rpm packages you want to install. GTK2 should be installed (which is usually installed by default with Mandrake 9.1).

You have to download and install scim (actual version scim-0.8.2-1.i586.rpm by the time of writing this article) and scim-chinese-0.2.6-1.i586 rpm (for pinyin input method)

last update of this online article was Nov. 8th 2003

Furthermore you have to modify the file /etc/X11/xinit/XIM (as root). Given the locale this file decides which IME is to be used and to be started at the same time. In case you want to use SCIM, you will have to delete everything that stands underneath:

Code:
zh_CN*) # Simplified Chinese
and replace it with
Code:
if type - scim > /dev/null 2>&1 ; then
export modifiers="@im=SCIM"
scim -d
elif type -p xcin > /dev/null 2>&1 ; then
export XMODIFIERS="@im=XCIN-zh_CN"
LANG=zh_CN LC_ALL=zh_CN xcin &
fi
;;
Save. Now use LocaleDrake and change the language to simplified Chinese. Now log out and start KDE again. Now you are able to write Chinese: just press CTRL and SPACE and the IME starts.

even when setting fcitx as IME iso SCIM I got the Mandrake standard installed Chinput as IME at this point but this will be solved automatically later on

Unfortunately all IME's I'm aware of only work with the corresponding locale, in this case with simplified Chinese as the desktop language. Most people however prefer a Desktop completely in German while still being able to input Chinese. To achieve this open the .i18n file in your home directory (please note the dot in front, meaning it is a hidden file, so adjust your konqueror to show hidden files) and open the file with Kwrite. The contents of this file with Chinese locale should look something like this:

Code:
LANGUAGE=zh_CN.GB2312:zh_CN:zh
LC_ADDRESS=zh_CN.UTF-8
LC_COLLATE=zh_CN.UTF-8
LC_NAME=zh_CN.UTF-8
XIM=chinput
LC_NUMERIC=zh_CN.UTF-8
LC_TIME=zh_CN.UTF-8
LC_MEASUREMENT=zh_CN.UTF-8
LANG=zh_CN.UTF-8
LC_MESSAGES=zh_CN.UTF-8
LC_IDENTIFICATION=zh_CN.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_TELEPHONE=zh_CN.UTF-8
CONSOLE_NOT_LOCALIZED=yes
LC_MONETARY=zh_CN.UTF-8
XIM_PROGRAM=chinput
LC_PAPER=zh_CN.UTF-8
XMODIFIERS="@im=chinput"

Replace it with:

Code:
LANGUAGE=de_DE:de_DE.UTF-8:de
LC_ADDRESS=de_DE.UTF-8
LC_COLLATE=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
XIM=scim>
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LANG=de_DE.UTF-8
LC_MESSAGES=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_TELEPHONE=de_DE.UTF-8
CONSOLE_NOT_LOCALIZED=yes
LC_MONETARY=de_DE.UTF-8
XIM_PROGRAM=scim
LC_PAPER=de_DE.UTF-8
XMODIFIERS="@im=scim
here I put nl_NL.UTF.8 for Dutch iso de.DE.UTF.8 and fcitx iso SCIM

Save. Very important are
Code:
LC_MESSAGES=de_DE.UTF-8
and
Code:
LANGUAGE=de_DE:de_DE.UTF-8:de 
as these point to /usr/share/locale/de/LC_Messages , the directory that contains the translations of programs in German. This is to say we maintain simplified Chinese as the language for the desktop but the files for the applications are being retrieved from the directory with the German translations. OK, now log out and start KDE again.
obviously for Dutch I put in Languague=nl_NL:de_DE.UTF-8:nl iso LANGUAGE=de_DE:de_DE.UTF-8:de

There you are! KDE in German and you can still input Chinese! But these terrible fonts! How do we change them? Go the the KDE configuration center and change the font overthere into our favorite one (in my case helvetica or arial). Now KDE looks decent again. But what about GTK2 applications? They apparently still use the font AR PL SungtiL GB. That's may be fine for Chinese applications, but look terrible with the latin alphabet. So we'll make a file called .gtkrc-2.0 .Write

Code:
gtk-font-name="fontofyourchoice 10"
And save it to your /home directory. Fontofyourchoice may be helvetica or whatever you prefer and you may also change the size.

GTK1 applications now still look messy. You can change that by opening /etc/gtk/gtkrc.iso-8859-15 with Kwrite as root and save it as /etc/gtk/gtkrc.zh_CN.utf8. Before you do so however, make sure you save the original file /etc/gtrk/gtkrc.zh_CN.utf8under a different name , e.g. /etc/gtk/gtkrc.zh_CN.utf8-original . You can never tell, mayvbe someday you would still like to have a Desktop in Chinese.
Now GIMP 1.2 or GRIP should also contain the fontofyourchoice, that you may change anytime by modifying /etc/gtk/gtkrc.zh_CN.utf8.

Now you're ready configuring. A German desktop, Chinese IME and the fonts of your choice.
that is, a Dutch desktop for me...


Special remarks for OpenOffice:
As this suite does not recognize "OnTheSpot-Modus", you will have to delete this option while setting up SCIM under (B]Frontend/X Window[/B]. At the same time deactivate the "show status" box. Please make sure you have installed OpenOffice 1.1 or upgrade as this version finally supports CJK decently.
Now configure the options under tools/options/language settings. For mixed documents make sure you have German iso standard/default. as the locale setting. Now in case you write a mixed Chinese/German document, you are able to use different fonts for German and Chinese, in case you configured OpenOffice under tools/options/textdocument/basic fonts (western, asian). As default for simplified Chinese you should use AR PL KaitiM GB or AR PL SungtiL Gb. In case you have installed windows fonts you can also use Simsun or SimHei.

OpenOffice works perfectly for me with these settings in Dutch environment

Have fun toggling Chinese.

This manual is to be used at your own risk. The author is neither liable for any damages nor can he exclude any errors. However this document has been written to his best knowledge.

This text is published under the GNU free document licence (FDL). In case you pass it on, please do so only when mentioning the name of the author.

copywright Gerrit Fricke
published on Pro Linux, last update November 8th 2003

unquote

Gerrit Fricke has been informed on the translation published here and who knows, he might join us in our contemplations.
Where nearing the Linux nirvana as far as this topic is concerned and as soon as I've been able to get my GNOME applications working under a proper Dutch environment, I'll have reached my destination.

So JDW, give it a try and tell me what you think about it. Just remember that with this setting, your solution does not work anymore, so make an appropriate back up before you try it out (and it takes some time, so don't do it in your lunch break ;-).

hasta la pasta,

Last edited by fiets; 01-19-2004 at 12:45 PM.
 
Old 01-30-2004, 02:18 PM   #21
Jiawen
Member
 
Registered: Aug 2003
Location: Twin Cities, MN, US
Distribution: Mandriva -> Ubuntu
Posts: 106

Rep: Reputation: 15
I hope it's okay if I add something here. I've got similar problems...

Inspired by Fiets' experience with SCIM, I decided to try installing it again. I got it installed via RPMs, then changed three different files: /etc/sysconfig/i18n, /etc/X11/xinit/xinitrc and /etc/X11/xinit/XIM. I changed them as I've seen indicated on this and other threads. I restarted Gnome, and SCIM was working fine. At least, it works fine in OpenOffice.org. In Firebird, Quanta and seemingly other programs, the character choice bar refuses to open, even though the main control bar comes up and stays up. I therefore can't do input in anything but OpenOffice.org, it seems.

I have two questions:

1) How do I get the character chooser bar to come up in Firebird, Quanta, etc.? Perhaps I haven't really fully installed SCIM?

2) Is there any way to specify tones in SCIM? Intelligent Pinyin is great, but it would be even faster if I could actually designate tones, instead of having to page through the whole list.

I am using Mandrake 9.1 with Chinese-Taiwan locale and Big5 traditional characters.

Thanks in advance for any help!
 
Old 01-31-2004, 12:41 PM   #22
fiets
LQ Newbie
 
Registered: Dec 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Howdy Jiawen,

Quote:
Inspired by Fiets' experience with SCIM
First of all please note: I don't think I have any experience with SCIM, I installed fcitx. But the author of this manual used SCIM, so that should not be the problem.
You mention you changed various files as mentioned in this and other threads. I'm not proficient enough in the whole matter to be able to answer your questions. Maybe there are counterproductive hints in various threads. I started from (virgin) scratch and it all worked for me. Furthermore you mention you changed "/etc/X11/xinit/xinitrc" and folllowing the manual, I do not recall I changed that.

I'm not sure about firebird, but Quanta certainly is a GTK application. Does it work in KDE applications like kmail? And what about Gnome applications in general?

I'll leave it up to others to comment on the specifics of SCIM in general.

If anything else comes to mind, I'll get back on this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
linux chinese support psa Linux - Newbie 5 02-14-2005 02:15 AM
contemplations on Red Flag Linux.... fiets Linux - Newbie 5 03-11-2004 05:21 AM
Linux for Chinese 00Scott Linux - Newbie 3 07-13-2003 03:46 PM
Linux for Chinese? 00Scott LinuxQuestions.org Member Intro 1 07-12-2003 04:01 AM
chinese in linux vhg119 Linux - General 1 12-01-2002 12:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration