LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Connection to remote FTP server which has the same domain name as my network (https://www.linuxquestions.org/questions/linux-newbie-8/connection-to-remote-ftp-server-which-has-the-same-domain-name-as-my-network-185500/)

dws 05-25-2004 01:02 AM

Connection to remote FTP server which has the same domain name as my network
 
I am using a Linux Slackware box as DSL router. The box controls DHCP and DNS. Our web/ftp site is hosted by an ISP. If I try to connect to my website i connect fine, but if I try to connect to my ftp site, the connection bombs out.

I suspect this is because my local domain name and my Internet domain name are the same....but why then can I connect to my www address? I can connect to other ftp sites without any hassle. I have tried using LeapFTP (This is what I usually use to connect to other ftp sites) to connect to the site as well as the default windows XP browser. LeapFTP gives me the following message: "ERROR: No Data" and XP gives me a message saying that the "folder is read only because the proxy server is not setup to allow full access", but when I close that message box, I get the error page "The requested URL could not be retrieved". I am pretty sure that the problem lies in the fact that the ftp software is trying to connect to the linux box instead of the ISP's server.

Any ideas on how to get around this, besides changing our local domain to another name?

bipul4b 05-26-2004 12:07 AM

Hi,

Please try IP address of your site in LeapFTP to connect . If problem is because of domain name then it will be solved.


or post again what error it gives and what steps you taken in detail.

Best luck

bye

:newbie:

np complete 05-26-2004 08:39 AM

I'm going to guess that your FTP port is being blocked by your "router".

Try opening port 21 (common ftp port) or whatever you set it to, and connect again.
Should solve your problem


All times are GMT -5. The time now is 08:24 PM.