LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-11-2009, 06:46 PM   #1
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Rep: Reputation: 17
Connecting to the network not reliable


Hi,

I have Slackware 12.2 installed on my HP dvt6 laptop. I used netconfig to setup the network for DHCP. The problem is that it doesn't connect to the network every time I start up. It's probably not the cable connection itself because it has never been a problem for Windows. So may be I haven't setup something right in Linux.

Here's some info which might be helpful. Of course this is when I was connected to the network.

##### ifconfig #####

eth0 Link encap:Ethernet HWaddr 00:23:8b:c8:d5:71
inet addr:10.1.11.50 Bcast:10.1.11.255 Mask:255.255.255.0
inet6 addr: fe80::223:8bff:fec8:d571/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2890 errors:0 dropped:112591799 overruns:0 frame:0
TX packets:2195 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2941965 (2.8 MiB) TX bytes:264888 (258.6 KiB)
Interrupt:17 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

##### rc.inet1.conf ####

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Default gateway IP address:
GATEWAY=""

The eth1, eth2 and eth3 are all empty.

##### lspci ####

02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

Any suggestions on how I could make it more reliable?
Also let's say it didn't connect to the network on startup. Is there a way to manually force it?

Thanks in advance,

Ash.
 
Old 09-11-2009, 06:53 PM   #2
salemboot
Member
 
Registered: Mar 2007
Location: America
Distribution: Linux
Posts: 161

Rep: Reputation: 36
It could be your network card driver isn't loading before the connection is being brought up.

Identify the card, add an entry into the /etc/rc.d/rc.modules file near the bottom.

For instances:

/sbin/modprobe 8139too

I'm not sure the name of your driver.

lsmod | less

and look for it.
 
Old 09-11-2009, 07:14 PM   #3
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Original Poster
Rep: Reputation: 17
Here's the list from lsmod. So how do I know which is my driver?

Code:
Module                  Size  Used by
snd_seq_dummy           6788  0 
snd_seq_oss            33408  0 
snd_seq_midi_event     10240  1 snd_seq_oss
snd_seq                50928  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10380  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            40480  0 
snd_mixer_oss          17920  1 snd_pcm_oss
ipv6                  241956  18 
pcmcia                 36524  0 
pcmcia_core            35604  1 pcmcia
lp                     13572  0 
ppdev                  11268  0 
parport_pc             28196  0 
parport                34796  3 lp,ppdev,parport_pc
fuse                   54684  1 
snd_hda_intel         367756  0 
snd_pcm                70788  2 snd_pcm_oss,snd_hda_intel
snd_timer              23176  2 snd_seq,snd_pcm
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
uvcvideo               57096  0 
compat_ioctl32          5120  1 uvcvideo
snd_hwdep              10756  1 snd_hda_intel
videodev               36736  1 uvcvideo
i2c_i801               12688  0 
snd                    51748  9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
sg                     30516  0 
intel_agp              29116  1 
agpgart                32584  1 intel_agp
psmouse                40592  0 
ac                      8196  0 
button                 10128  0 
thermal                19484  0 
video                  20624  0 
output                  6656  1 video
v4l1_compat            17924  2 uvcvideo,videodev
r8169                  31236  0 
serio_raw               9220  0 
processor              36648  1 thermal
evdev                  13088  8 
thermal_sys            15144  3 thermal,video,processor
battery                14340  0 
wmi                     9768  0 
mii                     8448  1 r8169
hwmon                   6300  1 thermal_sys
soundcore              10080  1 snd

Last edited by ash_zz_00; 09-15-2009 at 11:39 PM. Reason: Fixed the format
 
Old 09-15-2009, 11:47 PM   #4
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Original Poster
Rep: Reputation: 17
Earlier the lsmod list was not formatted correctly. Figured out how to fix it so it's more readable. Could someone tell me which is my network driver?

It happened again today. I thought may be if I run the dhcp client after startup (assuming all the necessary modules are loaded), it might connect to the network. So I ran dhcpcd but that failed too. I had to reboot to get the network connection working.

Thanks,

Ash.

Last edited by ash_zz_00; 09-16-2009 at 01:03 AM. Reason: Corrected grammer
 
Old 09-16-2009, 12:45 AM   #5
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Quote:
Originally Posted by ash_zz_00 View Post
Could someone tell me which is my network driver?
In that lsmod list, your network driver for the realtek ethernet is "r8169"

I have a couple minor suggestions for the time being, though I'm not 100% sure whether either of them will completely solve the issue:

A) Search around LQ a bit for how to disable IPv6 for your network on Slackware. It's pretty easy; it takes two lines in a new file in /etc/modprobe.d as well as one optional line in /etc/rc.d/rc.inet1.conf and doing this may fix the problem. IPv6 is known to cause intermittent network bugginess, not to mention slightly slowing down browsers and DNS/DHCP systems. If you look, I guarantee you will find the instructions here.

B) Also in /etc/modprobe.d in the same file as mentioned above, OR in another new file, I suggest making an "alias" as follows:
Code:
alias eth0 r8169
options r8169 blah blah # this line is optional
What this does, is assure you that when the kernel discovers your NIC during boot, it will automatically associate it with the r8169 driver. The idea here is to make sure that the kernel is not being confused because you have 2 NICs on the machine. The "options" line is only needed if you need to pass some additional arguments to the r8169 module when it gets modprobed.

In addition to (B) above, it'd be a good idea to NAME your eth0 device in /etc/rc.d/rc.inet1.conf, like so, even though eth0 is the default (and here's one of the two things I mentioned for disabling IPv6 ):
Code:
NETWORKING_IPV6="no"
IFNAME="eth0"
Best of luck; if this-all doesn't solve the problem, let us know -- we'll keep looking
Sasha

Last edited by GrapefruiTgirl; 09-16-2009 at 12:57 AM.
 
Old 09-16-2009, 01:16 AM   #6
RockyMarrone
LQ Newbie
 
Registered: Sep 2009
Posts: 8

Rep: Reputation: 0
Hi, ash_zz_00

i think in the ~/.bashrc u will write a function like

# network settings function
function set_network() {
sudo ifconfig eth0 10.1.11.50 netmask 255.255.255.0
sudo route add default gw 10.1.11.1
ping www.google.com
}

then on the shell just write source ~/.bashrc and then set_network
i think it should work just after logging in to the Linux u just have to write set_network

Note: if you are not loggined as root u then should have entry into the
/etc/sudoers file
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Manager not Connecting to Network gjblackford Ubuntu 2 10-09-2007 01:02 AM
Connecting my PC to a network adilturbo Linux - Networking 8 10-14-2006 06:01 PM
Connecting two Network Together m4st3rc1p0 Linux - Networking 2 10-13-2006 12:25 AM
Connecting to a Network rgarg Linux - Newbie 1 06-19-2003 05:47 AM
Connecting in network ardi76 Linux - Networking 9 04-10-2003 12:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration