LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-28-2003, 11:47 PM   #31
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33

well, as far as the mouse goes, make sure (as root) that the input pointer section in your XF86Config files has the following uncommented (w/out # in front)

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

Option "Protocol" "IMPS/2"

# The mouse device. The device is normally set to /dev/mouse,
# which is usually a symbolic link to the real device.

Option "Device" "/dev/mouse"


this is assuming your logitech is a wheel mouse. buttons 4 and 5 are scroll up/down with the wheel, respectively. if that still doesn't work, it's not a usb mouse is it? you might have forgotten to add usb support...i don't know.

i had trouble with my onboard ethernet card because of ACPI, which i had to disable in my BIOS - hold DEL or F2 during boot to access your BIOS.

now, let's see, what else. when you type dmesg at command prompt, can you see where it recognizes your drives? any errors? (scroll by holding down the right shift key and pressing pageUP/pageDOWN).

in fact, if you could post any part of dmesg here that you think is relevant (the whole thing is kinda long, but any errors you see, or places where it recognizes your mouse, usb, eth0 - that sort of thing), that would help troubleshoot too.

i'm going to look around for other stuff to help you out, post back in a bit.
 
Old 08-28-2003, 11:56 PM   #32
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Original Poster
Rep: Reputation: 15
I just outta nowhere typed ls at root and saw a file called xf86config.new. I typed xf86config and it came up with like a configure xf86 wizard. Started walking me through it, but i had to abort cause I don't know the refresh rate of my monitor and some other weird value.

If you find anything ...post. This thread's growing quite a tail. Thanks again y'all.
 
Old 08-28-2003, 11:57 PM   #33
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Original Poster
Rep: Reputation: 15
also, that bash$ didn't work, neither did emacs/path/xf86config

command not found. Do i have to be in a certain directory?
 
Old 08-29-2003, 12:06 AM   #34
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
well, the bash$ is just my promt - not something you should type, sorry if that wasn't clear. as for the second command, did you leave a space between emacs and the path? emacs is the command that starts the emacs text editor, and you can either specify a file to open, or just type emacs <enter> and then Ctrl-x Ctrl-f and then specify the directory. does that help?
 
Old 08-29-2003, 12:08 AM   #35
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
btw, what's your video card?
 
Old 08-29-2003, 12:13 AM   #36
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
here's something for you to try...

in console (ie w/out X running), type

/usr/bin/X > /tmp/x.out 2>&1

then

cat /tmp/x.out

and post that here - it might give more indication what's wrong.
 
Old 08-29-2003, 12:59 AM   #37
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Original Poster
Rep: Reputation: 15
Thanks..I'll try the emacs editor. If that command doesn't work , can I use vi? or some other one? same procedure?


My video card is a Matrox G450 Dual Head 32MB

I'll try that wild looking command and post
 
Old 08-29-2003, 02:17 AM   #38
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
ok, your card is definitely supported - just make sure that under Graphics Device you have the following line:

Driver "mga"
 
Old 08-29-2003, 02:23 AM   #39
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
btw, if you want all the info on your monitor (more than you need, and more than I quite understand) do this:

bash-2.05b# /usr/bin/X11/gtf 1024 768 60 -xv

here are my results:

usage: /usr/bin/X11/gtf x y refresh [-v|--verbose] [-f|--fbmode] [-x|-xf86mode]

x : the desired horizontal resolution (required)
y : the desired vertical resolution (required)
refresh : the desired refresh rate (required)
-v|--verbose : enable verbose printouts (traces each step of the computation)
-f|--fbmode : output an fbset(8)-style mode description
-x|-xf86mode : output an XFree86-style mode description (this is the default
if no mode description is requested)

bash-2.05b# /usr/bin/X11/gtf 1024 768 60 -x -v
1: [H PIXELS RND] : 1024.000000
2: [V LINES RND] : 768.000000
3: [V FIELD RATE RQD] : 60.000000
4: [TOP MARGIN (LINES)] : 0.000000
5: [BOT MARGIN (LINES)] : 0.000000
6: [INTERLACE] : 0.000000
7: [H PERIOD EST] : 20.957954
8: [V SYNC+BP] : 26.000000
9: [V BACK PORCH] : 23.000000
10: [TOTAL V LINES] : 795.000000
11: [V FIELD RATE EST] : 60.018341
12: [H PERIOD] : 20.964361
13: [V FIELD RATE] : 60.000000
14: [V FRAME RATE] : 60.000000
15: [LEFT MARGIN (PIXELS)] : 0.000000
16: [RIGHT MARGIN (PIXELS)] : 0.000000
17: [TOTAL ACTIVE PIXELS] : 1024.000000
18: [IDEAL DUTY CYCLE] : 23.710691
19: [H BLANK (PIXELS)] : 320.000000
20: [TOTAL PIXELS] : 1344.000000
21: [PIXEL FREQ] : 64.108795
22: [H FREQ] : 47.699997
17: [H SYNC (PIXELS)] : 104.000000
18: [H FRONT PORCH (PIXELS)] : 56.000000
36: [V ODD FRONT PORCH(LINES)] : 1.000000

# 1024x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 64.11 MHz
Modeline "1024x768_60.00" 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync


along with my config:



Section "Monitor"

Identifier "My Monitor"
HorizSync 31.5 - 50.0
VertRefresh 40-90

Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

DefaultDepth 24

# "1024x768" is also a conservative usable default resolution. If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubsection


maybe that will help you configure yours
 
Old 08-30-2003, 12:01 PM   #40
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Original Poster
Rep: Reputation: 15
Hey guys. Nothing's working
I can't use emacs. It keeps saying command not found. I use
vi XF86Config , but I don't know how to save my changes. I type startx after I thought i had configured via that xf86config command but it just say fatal server error...screens found but none with right configuration. What do i do? My internet still doesn't work either. I'm starting to lose faith in this Linux deal.
 
Old 08-30-2003, 02:52 PM   #41
zsejk
Member
 
Registered: Apr 2003
Distribution: Slackware
Posts: 345
Blog Entries: 5

Rep: Reputation: 30
Just use that command on finding out about your screen stuff mcd just gave you, write that down, and go through that "xf86config" program again. Just go through the entire thing, and guess at some stuff if you *really* have no idea about the value (make educated guesses though; and remember that it's always better to choose some conservative value if you're absolutely unsure).

Do that, try running startx again, and if it doesn't work, post your *exact* error message here (it shouldn't be *too* long...hopefully).



-zsejk
 
Old 08-30-2003, 03:13 PM   #42
Tesl
Member
 
Registered: Jun 2003
Location: Durham, UK
Distribution: Slackware 9, Mandrake 9.1
Posts: 163

Rep: Reputation: 30
this might not appear to be that helpful, but if your totally totally new to Linux you might be better trying something like RedHat. I ran RedHat for a while and it auto configured all internet settings very easily, and i had no problems. When it came to some other distributions i have huge amount of troubles though
 
Old 08-30-2003, 03:26 PM   #43
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Original Poster
Rep: Reputation: 15
OK I'll do that right now. What text editor can I use to alter XF86Config-4 , AND be able to save changes? I tried vi but i don't know how to save. Are there any others? should I even be messing with this?

Will post errors in a second.

Here goes...
 
Old 08-30-2003, 03:42 PM   #44
zsejk
Member
 
Registered: Apr 2003
Distribution: Slackware
Posts: 345
Blog Entries: 5

Rep: Reputation: 30
If you run the program "xf86congif" you don't need to manually edit or save anything. But if you, after you've run xf86config, still want to manually edited some stuff in the XF86Config file, you can do so by typing the following at the command prompt:

pico XF86Config

It should open a file starts off with a bunch of text and #'s.

But really... *first* run that xf86config... and run it *completely*. Then try startx, and then come back here if it doesn't work. And also please post the output of that "lsconfig eth0" command... I'm still curious about it.

-zsejk
 
Old 08-30-2003, 03:50 PM   #45
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Original Poster
Rep: Reputation: 15
This is what I typed at my prompt just now and it didn't work

/usr/bin/X11/gtf 1024 768 60 -xv and nothing happend.

i tried it with a 'cd' in front as well...and nothing.

I went to the /usr/bin/X11 directory and typed 'ls' and didn't see anything that said 'gtf'

I'll do the 'ifconfig eth0' now and get back to you.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 05:29 PM
Connecting to the Internet jthomas98 Linux - Networking 1 10-29-2005 03:26 PM
Connecting to the internet... redkazan Linux - Newbie 12 01-22-2004 07:04 AM
connecting to internet reznik Linux - Networking 2 07-19-2003 08:37 PM
Connecting to the Internet mjl1297 Linux - Software 2 02-06-2002 05:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration