LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   connecting to samba (https://www.linuxquestions.org/questions/linux-newbie-8/connecting-to-samba-243880/)

ejbest 10-17-2004 04:30 PM

connecting to samba
 
Here is the problem, there are Fedora 2 servers running Samba that I try to connect to with using a Windows XP machine. On the Windows Box both Samba servers are seen under 'Entire Network' 'Workgroup name' and are listed. Browsing or connecting to them beyond seeing them in this list is the problem.

When clicking on them, a message appears as follows.

\\servername is not accessable. You might no have permission to use this network resource. Contact the administrator (duh myself) of this server to find out if you have permissions.

Anyway the username on the Windows box is entered on the 'Authentication' portion; more over, the Samba boxes are set to 'browse' for 'anyone'. Both samba servers have been made dam near totally open and still there is no ablility to browse or connect. And yes, the password option is encrypted.

Thank You in advance,

crm 10-17-2004 05:56 PM

well samba usually alwaise needs authentication.....

first off make accounts on your linux box for everyone accessing the shares giv em a username and password as normal (if you like security its alwaise fun to make there shells /bin/false -- try cracking that one! :P )
next tell samba that theese users are likley to be accesing samba shares via the network by adding them to the samba password list....

smbpasswd -a <USERNAME>

(the -a option means ADD.. omitting it changes an already existing smb password... the smb password and unix passwords dont haev to be the same!
finially have a look over your smb.conf file type and then reed 'man smb.conf' for security and fine tuning...

remember, samba = fun

ejbest 10-17-2004 08:26 PM

Thank you for the post; however, all was done.

The user name was the same, and the password was the same on.....

1) the xp machine
2) the smbpasswd
3) the /etc/passwd file

Again, 'more over', with things like this, this should be expected to show up 'anyway'

[tmp]
comment = /tmp
path = /tmp
guest ok = yes

Also I turned off the firewall on the xp box.

Thanks again in advance, any ideas are cool.

SweetLou 10-18-2004 12:23 AM

I have had that same message before. With me, it was caused my Norton Anti-virus changing a registry key. There was a fix to change it back and everything was fine. I just did a quick google search and there seems to be other reasons also. I saw on Microsoft's site that Trend Micro caused the same problem but on a W2K box. I know this isn't much help but it might lead you in the right direction. It seems to me, it is a problem on the XP box and not with Samba. But, that could be a problem also.


All times are GMT -5. The time now is 12:56 AM.