LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   connect to wireless in debian (https://www.linuxquestions.org/questions/linux-newbie-8/connect-to-wireless-in-debian-671715/)

idyllhands 09-23-2008 12:14 AM

connect to wireless in debian
 
Hi. I'm trying to set up Machboot (machboot.com) to fire up a browser on my laptop and/or desktop (both have wireless). The problem is that it doesn't connect up. I am pretty new to Linux, having just recently installed Ubuntu and messed with it some. My question is: how do I get it to connect wirelessly to my wpa2 encrypted router? It boots up to a desktop that says Debian on the "start" button, so I am assuming it is a minimal debian distro...
My laptop is a Toshiba satelite pro m15 s405 with an intel 2100 (I think) wireless card. It can connect just fine in XP to WPA2.
My router is dlink. I'm not sure what version of Debian it is...tell me how to find out, or tell me if you need more info and I can report back!

(Basically what I want is a way to boot my computers up to a browser just to look things up quickly on the web..so I am open to any other methods you can suggest)

farslayer 09-23-2008 09:26 AM

cat /etc *version
uname -a

What wireless card do you have ? Could you post the output of:
lspci
if no wireless device is shown, you can also try:
lspcmcia
lsusb

idyllhands 09-23-2008 10:45 AM

<double post pls ignore>

idyllhands 09-23-2008 10:54 AM

The wireless card lists as an Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 4)

Did you mean to put cat /etc/*version ?
The output of that is "testing/unstable"
uname -a gives
Linux MACHBOOT 2.6.16 #21 Sun Mar 25 01:15:39 JST 2007 i686 GNU/Linux

idyllhands 09-23-2008 12:54 PM

I had tried Puppy Linux too and got my wireless nic to work in it, but only when I turned off WPA2 encryption on my router...I need a distro that will work with my encryption, but meets the criteria (has a gui browser--preferably firefox for now, boots fast as heck, and can connect to WPA2 encrypted wireless)

farslayer 09-23-2008 02:08 PM

Err yes, that was a typo (DOH !!)


You need to use wpa_supplicant to handle the encryption.. here are a few links you can draw from..

http://hostap.epitest.fi/wpa_supplicant/

http://linux.die.net/man/5/wpa_supplicant.conf

http://wiki.debian.org/WPA

http://www.vollink.com/gary/deb_wifi.html

http://www.varesano.net/blog/fabio/w...ntrino+ipw2100

http://www.debianadmin.com/enable-wp...ntu-linux.html

Quakeboy02 09-23-2008 02:13 PM

Take a look at this minimalist approach, as well: http://www.linuxquestions.org/questi...5/#post3275215

Added:
If you want to see the entry in my /etc/network/interfaces file, just ask.

idyllhands 09-23-2008 03:56 PM

I'm having some other troubles with Puppy too and am getting a headache with it, do you think it's possible to set up Machboot on the HDD? Also, would wpa and wpa2 be the same steps?

@Quakeboy02: I'm not sure what that file means, but if you think it will help me understand how to set up wireless, please go ahead and post =) I'm learning all I can!

Quakeboy02 09-23-2008 05:18 PM

What I already posted will get you going with a wpa connection. When (not before) you get that to work, then you can look at this; assuming you're using Debian or a Debian derivative, such as Ubuntu. This is worthless to you until you actually get the connection to work through wpa_supplicant.

Have you run wpa_passphrase yet?



snippet from /etc/network/interface:
Code:

auto wlan0
iface wlan0 inet dhcp
        pre-up /sbin/wpa_supplicant -B -Dwext -c/etc/wpa_supplicant.conf -iwlan0


idyllhands 09-23-2008 06:56 PM

Ok, I got this response:
bash: wpa_passphrase command not found

Quakeboy02 09-23-2008 07:11 PM

Quote:

Originally Posted by idyllhands (Post 3289734)
Ok, I got this response:
bash: wpa_passphrase command not found

Are you sure you have the wpasupplicant package installed? It's in /usr/bin (i.e. /usr/bin/wpa_passphrase) and is part of the wpasupplicant package.

idyllhands 09-23-2008 10:16 PM

No it is not listed in that directory. I just plugged to ethernet (and was able to browse in FF) and tried apt-get wpasupplicant (it logs me in as root automatically, so sudo doesn't work/isn't needed) to see if it would get it and it tried to download the files but it wasn't able to connect to the URL.
It was a .jp site that it was trying...so I'm assuming here that each distro has its own location to download updates from and this one does not have a wpasupplicant available? Like I said, I'm new, so I don't know how apt-get really works.
Any advice here?

idyllhands 09-24-2008 10:36 AM

So no way to install wpasupplicant package here? Or would it be a huge pain? Should I work on installing to HDD first so that the work I do is actually saved?

Quakeboy02 09-24-2008 12:00 PM

I'd suggest that you go to debian.org and download etch or better yet lenny. During the install process it will ask you which repo to use - don't select the one in japan this time.

idyllhands 09-25-2008 12:46 AM

I think the reason the repo is in Japan is because the distro (machboot) is Japanese. It boots super quick (8 seconds) but I wish I knew more about Linux so I could just get the thing on my harddrive and booting up with my wireless. I didn't want to have to spend a week doing it, but every option I try I end up spending several hours on and then having to switch my approach. Damn Small Linux booted to a command prompt which I am not comfortable enough with yet (but I may go back and try now that I've learned more), Puppy Linux would detect my wireless card, but wouldn't hook up to my WPA, Machboot doesn't even have the wireless repos (and I had to learn what a repo was just to figure that out) I tried NimbleX but it boots so slow off a CD that I am discouraged from even trying to get wireless going on it...
I will try Lenny next and probably be back here bugging you kind folks again =)
Thanks for you help and patience with a novice!


All times are GMT -5. The time now is 08:49 AM.