LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2015, 09:28 PM   #1
cyberf4n
LQ Newbie
 
Registered: Nov 2015
Posts: 1

Rep: Reputation: Disabled
conky autostart


Hello,
I have this conky-startup script:

Code:
#!/bin/bash
sleep 15 &&
conky -d -c /home/cyberf4n/.config/conky/infinity/.conkyrc &
exit
Now... I want this script to autostart and I tried the following:
1. I created conky.desktop in /.config/autostart with the code:

Code:
[Desktop Entry]
Name=conky.desktop
GenericName=conky
Comment=Some description about your script
Exec=/home/cyberf4n/.config/conky/conky # I tried with sh /home/cyberf4n/.config/conky/conky - same thing
Terminal=false
Type=Application
X-GNOME-Autostart-enabled=true
Name[en_GB]=conky.desktop
...not working
2. I created conky.service in /etc/systemd/system/ with the following code:

Code:
[Unit]
Description=conky

[Service]
Type=application
ExecStart=/home/cyberf4n/.config/conky/conky

[Install]
WantedBy=multi-user.target
....not working
If I double click on conky.desktop or I run the script in terminal or by just double clicking it everything is working fine.
What the hell is wrong?

I am using ArchLinux with gnome if it matters
 
Old 11-21-2015, 07:57 AM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu, Linux Mint
Posts: 1,709

Rep: Reputation: 393Reputation: 393Reputation: 393Reputation: 393
Is your conky program located in /home/cyberf4n/.config/conky/ or in /usr/bin? Try this:
Code:
[Desktop Entry]
Name=conky.desktop
GenericName=conky
Comment=Some description about your script
Exec=conky -d -c /home/cyberf4n/.config/conky/infinity/.conkyrc
Terminal=false
Type=Application
X-GNOME-Autostart-enabled=true
Name[en_GB]=conky.desktop
 
Old 11-22-2015, 06:36 AM   #3
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 12,301
Blog Entries: 9

Rep: Reputation: 3306Reputation: 3306Reputation: 3306Reputation: 3306Reputation: 3306Reputation: 3306Reputation: 3306Reputation: 3306Reputation: 3306Reputation: 3306Reputation: 3306
the line with "sleep 15 &&" is wrong.
simply remove the "&&" and try again.
fwiw, conky has an inbuilt pause option; "conky -p 15" would do the same.
open a terminal, type "man conky". happy reading.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to configure Conky with a GUI-based Conky config tool LXer Syndicated Linux News 0 04-09-2014 11:50 AM
Conky Autostart Problems with Kubuntu 13.10 nbob Linux - Newbie 1 10-18-2013 01:13 PM
LXer: Conky Manager Simple GUI for managing Conky config files LXer Syndicated Linux News 0 07-19-2013 11:01 AM
LXer: Configure conky-Lua in Ubuntu (11.10 & 12.04), Fedora, debian and LinuxMint | Howto Conky LXer Syndicated Linux News 0 03-06-2012 12:40 PM
LXer: Conky Colors Makes Your Conky Beautiful In Seconds (Version 3.20 Released) LXer Syndicated Linux News 0 08-01-2010 11:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration