LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Confused with Madwifi and kismet configuration (https://www.linuxquestions.org/questions/linux-newbie-8/confused-with-madwifi-and-kismet-configuration-613893/)

gordon__1 01-16-2008 01:29 AM

Confused with Madwifi and kismet configuration
 
I would appreciate any input that will help me learn more about Madwifi and Kismet. I've got an eee running Backtrack3 off USB flash. I'm a noob, but i have been learning at as fast rate, but have frustrating gaps in my knowledge, so please help.

lspci - AR5006EG
iwconfig

lo no wireless connection
eth0 no wireless connection
wifi0 no wireless connection
ath0 is in Managed Mode (I can't cut and paste all details, I'm on a different computer at the moment)

My kismet.conf file has the line source=madwifi_g,wifi0,madwifi

Now, I run Kismet and it brings up the Network list = great, it works
Now, i have something called kis0, and i don't know what that is
I don't really understand what's going on with my system, when i try to use aircrack, the instructions are to stop ath0, so i can start it in monitor mode. But it doesn't work,
airmon-ng stop ath0

wifi0 atheros madwifi-ng
ath0 atheros madwifi-ng VAP (parent: wifi0) (VAP destroyed)
kis0 atheros madwifi-ng VAP (parent: wifi0)

SO I've destroyed ath0 VAP - seems good
airmon-ng start ath0
wifi0 atheros madwifi-ng
kis0 atheros madwifi-ng VAP (parent: wifi0)

Kismet is still working, i guess its using the kis0 VAP to monitor, but all the aircrack instructions describe using ath0, and my system never works when i start using commands with ath0

Its gone and i'm stuck
I spent a lot of time trying to understand what is happening and why. I would appreciate someone filling in the blanks, I hope this is enough information.


All times are GMT -5. The time now is 03:57 PM.