-   Linux - Newbie (
-   -   configuring ADMTek wi-fi (

bitamois 05-07-2004 10:16 AM

configuring ADMTek wi-fi
I am a total newbie to Linux and installed it on my laptop with Fedora Yarrow i386.

I can't seem to figure out how to install drivers for my SMC22635W wi-fi card following the read me instructions in the drivers zip file.

I wrote SMC for a Linux driver and they promptly sent me a ADMtek driver for RedHat 9.0.

The zip file contains:

I follow all the steps until step 4 wher it reads:

4. Install your ADMtek ADM8211 Wireless Adapter Linux driver for different
OS version.
a. If your OS is RedHat 7.3, please tar zxvf Install_RH73_100.tar.gz.
If your OS is RedHat 8.0, please tar zxvf Install_RH80_100.tar.gz.
The directory "Install" will be made.
b. Type command "cd Install" to enter directort "Install".
c. Type command "./install" to begin installing Linux driver.

I went ahead and copied the files to the a folder called Install and tried to use the shell terminal to do this, but I cannot figure out what I am supposed to do.

So, I'm assuming I need to go onto step 5 which says:

5. If you get the source code and you want to compile it by yourself.
a. Install wireless-tool by yourself.
(We recommand wireless-tools-25)
b. Make sure you have the kernel 2.4.x source code.
c. You can modify the Makefile to fit your enviroment. We recommad
you make a soft link linux-2.4 of kernel source in /usr/src/
eg. If you had kenrel source linux-2.4.20 in /usr/src/
type "ln -s linux-2.4.20 linux-2.4"
d. Type "make"
e. The file 8211.o is the ADM8211 linux driver
f. "insmod 8211.o" to test your linux driver
(If you encounter some error messages, please try "insmod -f 8211.o")

I think I need someone to explain this step in more detail, so a newbie like me can figure it out.

Any help is much appreciated. Until then, I'll keep reading the Red Hat documents to try to figure this out.
Thank you very much.

Muzzy 05-07-2004 03:54 PM

The zip file (zip file?? why are they using zip?) does not contain the file 'Install_RH73_100.tar.gz'. That's your problem : the instructions don't match the files they sent you. Are you sure that you are reading the correct set of instructions? Perhaps you should get back to the company.

SMC22635W does not appear on Google at all - zero matches! Why not? Is this a flaw in Google?

bitamois 05-07-2004 04:44 PM

Sorry Muzzy,

It is supposed to read SMC2635W. I must have gotten jittery from my morning coffee.

Yes, SMC did send me the driver in .zip format. I think I have to follow the directions in step 5 and compile the source in the Make file. But what directory do I put it in? Hmmm. Anybody with advice?

I am reading RH's Developer tools guide, but this could take some time to figure out.

I will ask SMC to send the tar.gz as you suggested and try to solve this from that direction also.

Although the readme file instructions say drivers RH73 and RH80. SMC actually sent me the driver for Red Hat 9.0, so I am pretty confident they sent the correct driver, but just the source code assuming I knew what to do with it.

Thanks for the advice. Keep it coming.

Muzzy 05-07-2004 05:36 PM

If you want to try compiling this:

I'm sure it doesn't matter what directory you put the files in, a new subdirectory of your home directory would be fine. Then go through the steps one by one, and post any errors you get. There will be a wireless-tools package for fedora that you can download and install. To find out your kernel version type 'uname -r', it hopefully is 2.4.something. Your kernel source code will be in /usr/src/linux-2.4.something (unless u chose not to install it when you installed Linux - then you will have to download it). You will need to create the link they mention.

Do the steps one at a time, and make sure that you complete each one correctly before moving onto the next.

Good luck,

Muzzy 05-07-2004 05:44 PM

You might also want to check out this thread:

bitamois 05-08-2004 10:01 AM


I'm already confused.

Let me start with step 1
1. I powered on in the Root account. FYI: I have installed Fedora's desktop configuration. Is this enough to do all this?
2. I made sure PCMCIA device works. typed lsmod and saw "pcmcia_core" listed in devices
3. Choose proper installation file. Yes, I believe I have the correct file sent to me from SMC for RH9.0.

4. (see thread above) OK, I can't install this because they sent me the source in a zip file, so I go onto step 5.

5. (see thread above) OK, I downloaded the wireless-tools-26 (not 25 anymore) from the suggested website.

a. I extracted the wireless-tools-26 files and put them in a folder in the Root next to the ADM8211 folder with the driver stuff. I do not understand by "install by yourself" means. The read me file for the wireless tools just talks about the commands?
b. I have kernel 2.4.22-1.2115.npt
c. I guess they're talking about the Makefile in the ADM8211 folder, right?
To make the softlink I do this in the terminal window?

Muzzy 05-08-2004 10:15 AM

To install the wireless tools, you can't just extract it into a folder of your choice, you have to install it properly.

If you got the source version of wireless tools, then its easy: read README, then usually:
./configure && make && make install

If you got the rpm then I don't know how to do it because I have never used rpm's. There should be a good discription somewhere on this site though, if you do a search.

Once it is installe dyou should be able to type 'iwconfig' as root and it reply with a few lines, rather than 'command not found'.


Muzzy 05-08-2004 10:23 AM

To make the link:

First make sure that you have the sources for your kernel installed:

ls /usr/src/linux-2.4*

Then do as root (replace 'something' with the correct name, as shown in the output of the above command):

ln -s /usr/src/linux-2.4.something /usr/src/linux-2.4

bitamois 05-08-2004 11:04 AM


How do I know if I got the source or the RPM?

Thanks for all the help. I really need it.


bitamois 05-08-2004 07:35 PM

Hi Muzzy,

I just got an email from SMC tech support containing the following file:

I think I should rename it so it has the .gz extension? I'm not sure, but I will just to be consistent with the instructions.

Now I think I can continue with step number 4 and install the driver without having to compile the source. Correct?

Then I will continue with the rest of step 5 and install the wi-fi tools etc.




Muzzy 05-09-2004 04:38 AM

No don't rename it. gz means compressed. It just means you have to untar it without the z flag.


tar -xvf 2635ADM8211_Linux_driver_1.03.tar
instead of


tar -zxvf 2635ADM8211_Linux_driver_1.03.tar.gz
There is a sticky thread about compiling and installing from source which you can read which will hopefully answer some of your questions...

This also mentions something on rpms at the bottom.

I have to go out today. I'll be back later to check how it's going.

Good luck,

bitamois 05-10-2004 11:20 AM


I'm going back to step 4.

I've copied the ADM8211...tar.gz to the root directory.

I then did a tar xzvf on it.

It listed each of the files and no errors.

Now I'm lost again.

I typed ./configure

I get "no such file or directory"
I've tried "cd Install", again "no such file or directory"
I tried "make install", "no such file or directory"

OK what now?



Muzzy 05-10-2004 12:36 PM

First thing is to check what files and directories you can see:


You will have to find where your tar files are and cd into that directory. It is important that you are in the right directory or the commands won't work.


cd xxxxxxxx
I can't tell you what to type because I don't know where you downloaded your files, you will have to work this out for yourself. Eventually you should be able to find the tar file you received. When you extract a tarfile, it usually creates a directory with a very similar name to the tar file, but without the .tar.gz extension. You need to cd into this directory and then ls to see whether you have an 'install' or a 'configure' file. Then follow the appropriate instructions, according to whether you have install or configure. If it says file not found, check with ls to see what files are there. If you still can't work it out, then post the output of pwd and ls so that I can see where you are at.

bitamois 05-10-2004 01:25 PM


I copied the tar file into the root directory and did the tar -xzvf 2635ADM8211 Linux driver 1[1].03.tar

I now have a directory in root called ADM8211 containing the following files:


The ReadMe contains the installation instructions I mentioned above. I am on step 4. Here I will recap those instructions:

4. Install your ADMtek ADM8211 Wireless Adapter Linux driver for different
OS version.
a. If your OS is RedHat 7.3, please tar zxvf Install_RH73_100.tar.gz.
If your OS is RedHat 8.0, please tar zxvf Install_RH80_100.tar.gz.
The directory "Install" will be made.
b. Type command "cd Install" to enter directort "Install".
c. Type command "./install" to begin installing Linux driver.

I can't seem to find the Install directory and can'd "cd Install" to do the next step.


Muzzy 05-10-2004 01:39 PM

What happens if you enter that directory and then type


All times are GMT -5. The time now is 11:12 AM.