LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Configure USB as Serial Port for Fortinet Firewall Configuration. (https://www.linuxquestions.org/questions/linux-newbie-8/configure-usb-as-serial-port-for-fortinet-firewall-configuration-4175617889/)

eferrara@esferrara.com 11-18-2017 12:46 PM

Configure USB as Serial Port for Fortinet Firewall Configuration.
 
Hi, I'm trying to access a Fortinet 60D firewall by using a USB cable and associated mini-port. This is an Ubuntu 16.04 system running under Parallels on a Mac. The Fortinet firewall is recognized by the Linux system.

$ dmesg | tail

produces:

[17648.321755] usb 1-3: USB disconnect, device number 4
[17653.955719] usb 1-1: new high-speed USB device number 10 using ehci-pci
[17654.108269] usb 1-1: New USB device found, idVendor=22a7, idProduct=1001
[17654.108271] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[17654.108273] usb 1-1: Product: Fortinet FortiGate Device
[17654.108274] usb 1-1: Manufacturer: Fortinet Technologies
[17654.108275] usb 1-1: SerialNumber: FGT60D4QXXXXXX8

However there are no /dev/ttyUSB* devices in /dev. I have installed the moserial package. Still no joy.

Thank you,

eferrara@esferrara.com 11-18-2017 01:10 PM

OK Here is an update after further exploration. I ran the following:

sudo mknod /dev/usb/ttyUSB0 c 188 0
sudo mknod /dev/usb/ttyUSB1 c 188 1
sudo mknod /dev/usb/ttyUSB2 c 188 2
sudo mknod /dev/usb/ttyUSB3 c 188 3
sudo mknod /dev/usb/ttyUSB4 c 188 4
sudo mknod /dev/usb/ttyUSB5 c 188 5
sudo mknod /dev/usb/ttyUSB6 c 188 6
sudo mknod /dev/usb/ttyUSB7 c 188 7
sudo mknod /dev/usb/ttyUSB8 c 188 8
sudo mknod /dev/usb/ttyUSB9 c 188 9
sudo mknod /dev/usb/ttyUSB10 c 188 10
sudo mknod /dev/usb/ttyUSB11 c 188 11
sudo mknod /dev/usb/ttyUSB12 c 188 12
sudo mknod /dev/usb/ttyUSB13 c 188 13
sudo mknod /dev/usb/ttyUSB14 c 188 14
sudo mknod /dev/usb/ttyUSB15 c 188 15

and now have the necessary USB devices in the /dev/usb directory. Now I am looking for the command to gain access to the Fortinet and link the Fortinet USB device to the appropriate COMM port.

Thank you,

michaelk 11-18-2017 01:51 PM

Welcome to LinuxQuestions.

From what I can determine the fortiexplorer i.e. the application that connects the computer to the USB management port is only for Windows and MacOS. I have not found anything that indicates there is a linux version.

However, it appears that the 60D has a real serial port on the other side. Using a USB serial port adapter like a FTDI model should be automatically recognized and create a /dev/ttyUSB device ID. You can then use a comm port program like putty or minicom to connect to the firewall.

https://docs.fortinet.com/uploaded/f...-%20Online.pdf

Then again just use MacOS.
FYI hopefully your username is not your real email address.


All times are GMT -5. The time now is 08:25 AM.