LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-25-2003, 11:03 AM   #1
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Rep: Reputation: 0
Exclamation Configure Redhat (Redhard?) for Window XP workgroup


hi,i'm new in this linux thing, ive tryng to connect a redhat 9 to my network group which is a windows xp workgroup, but i can't connect them,also i've really confuse with the network configuration in RH9 the eth0 things!i've try with the dhcp and static setup but both not working!i don't know how to check whether the RH9 get the conection or not!anyway the internet conection is share from the main server (xp pro using DSL) do ineed to setup something in my XP ?i already enable the internet conection sharing!i wonder why is it so hard to setup a linux ?is this the reason why people won't use it,coz it's so hard to find a reference or a guide for linux configuration!this thing bad for marketing it drag down the popularity of the OS!

Last edited by coffemachine; 07-25-2003 at 11:04 AM.
 
Old 07-25-2003, 11:14 AM   #2
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
OK.. first thing is first. The way I understand it, you are trying to use internet connection sharing on the WinXP box to connect your Linux box to the internet. Have you been successful in doing this yet? Once ICS is turned on, it acts like a mini DHCP server and should spit out an IP address to the linux box. Leave linux as DHCP enabled, and that should get you started. Lets address this issue first. Once we know that the Linux box is on the internet, and that you can ping the XP box, then we can worry about setting up SAMBA and getting you into the workgroup.

slight
 
Old 07-25-2003, 01:15 PM   #3
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Original Poster
Rep: Reputation: 0
not yet, when i tryed to active the eth0 the conection was fail coz the eth0 alert me that SIOCSIFFLAGS can't assign address!have any clue?
thank you for answering me
 
Old 07-25-2003, 01:22 PM   #4
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Original Poster
Rep: Reputation: 0
otherways it showing message like this" fail to determine the ip info" so i can't active it
can i talk to you directly?do you have any messenger things?email?
thank you so much for your time slightcrazed
 
Old 07-25-2003, 03:06 PM   #5
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Original Poster
Rep: Reputation: 0
man please i know you all have seen my problem could you help me on this?this thing really make me dizzzzziiii!
 
Old 07-25-2003, 03:46 PM   #6
mylo2003
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
dood, does the Linux box have an IP adress? you get check by going in the /sbin and typing ./ifconfig.

post results here.
 
Old 07-25-2003, 04:18 PM   #7
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Original Poster
Rep: Reputation: 0
i set it to DHCP automaticly setting
 
Old 07-25-2003, 04:23 PM   #8
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Original Poster
Rep: Reputation: 0
the result the eth0 can't be active by me is always showing this result " unable to determine ip info "
wuih..is this coz of DHCP thing?do ineed manually active the dhcp thing?how i enable the DHCP?
 
Old 07-25-2003, 04:27 PM   #9
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
OK.... back up for a sec. You have ICS enabled on the Windows box. So you should have 2 NIC cards on the WinXP box, (Or I should say 2 'connections', because you could have the DSL plugged into the USB port.)..... So, the external connection on your XP box has an IP that is assigned by your ISP. You should then have a NIC bound with 192.168.0.1 that is hooked with a Cat5 cable to the NIC on the linux box. The linux box should have an IP address like 192.168.0.5, and the Default gateway should be 192.168.0.1. This will enable ICS to work properly. Do a man ifconfig as root and it will show you how to manually assign an IP address for eth0 on your linux machine. Manually assign the IP if you have to, and then get eth0 activated.

Was eth0 installed properly during setup? RedHat should have detected and installed the proper module for it, and it should be DHCP enabled (unless you chose to manually set it) meaning that it should pick up the DHCP offer from the XP box. Is your DHCP server service turned on on the XP box?

Don't worry, we'll walk you through this.

slight
 
Old 07-25-2003, 04:36 PM   #10
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Original Poster
Rep: Reputation: 0
precisely,i have two card on my windows box, one for the dsl conection and the other for the workgroup, now should i set the workgroup card to ip autodetect or set it manually to 192.168.0.1 ? thank you i'try your way man
i'll let you know if i fail..
 
Old 07-25-2003, 06:49 PM   #11
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Original Poster
Rep: Reputation: 0
well i failed to get the connection to the internet
coz when i set the linux to using the ip 192.168.0.3 i've got the network but i can't connect to the internet!but when i'm using the dhcp enable i 've got message " determining ip nformation : FAILED" wooooowww headache!!
 
Old 07-25-2003, 07:09 PM   #12
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
They're directly connected using a crossover cable yah?

Forget about DHCP then if you've got an IP 192.168.0.3 static stick with it

Can you ping 192.168.0.1 if so super if not back to drawing board

Next, have you set the gateway 192.168.0.1?

If not do it, then rather than say anymore just reboot the linux machine

Try and ping an external address by IP here's a valid one 62.253.162.30 if no response back to drawing board

if response

get your ISP DNS servers from windows (or if you already know them)

ipconfig/all as far as I remember and add them to your network settings

blah...blah...reboot.

Last edited by Looking_Lost; 07-25-2003 at 07:11 PM.
 
Old 07-25-2003, 07:22 PM   #13
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Wooww this is sound good, i can ping outside my network
but where should i put the ISP DNS ?network setting ?can you tell me the exact location to put the ISP DNS?how to conect the browser to this connection? anyway thank you so much man...
 
Old 07-25-2003, 07:33 PM   #14
coffemachine
LQ Newbie
 
Registered: Jul 2003
Posts: 12

Original Poster
Rep: Reputation: 0
helloo Looking_Lost
you advice works well but i still can get the internet conection and i got really confuse on puting the ISP DNS,can you tell me exact location?thank man
 
Old 07-25-2003, 07:35 PM   #15
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
seeing as I can't be sure what desktop your using edit the file as root /etc/resolv.conf


add the entries:

nameserver ip_address_of_your_ISP_primary_dns_server
nameserver ip_address_of_your_ISP_secondary_dns_server

I can't help you with the IP address'es you'll either have to know them or go to the windows machine and do ipconfig/all

Reboot linux just for good measure

fingers crossed thats it sorted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to configure the x server in terminal window in diskless clients novavm Linux - Newbie 1 08-17-2005 10:56 AM
How to Configure Window Mngr in SUSE? wardialer SUSE / openSUSE 3 04-24-2005 12:49 PM
when i try to configure mandrake 10.0 the window crashes when i put in password ethereal9 Mandriva 5 11-14-2004 07:55 AM
unable to configure window manager settings corbis_demon Linux - Newbie 0 07-12-2004 01:25 PM
xemacs configure unable to detect x11 window system macshark Linux - Software 0 11-22-2003 03:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration