LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-02-2010, 04:18 PM   #1
edwinbradford
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Rep: Reputation: 0
./configure -prefix ~ # returns a problem on server


Hi all,

First, thanks for being there to help out us newbies. I'm not a programmer but I've picked up a little experience navigating around Linux systems over the years in a terminal/console window and am able to do a few basic tasks.

I've been trying to follow a tutorial here to get Unison, a file synchronization and back up tool, installed on my host provider. I got past the first stage yesterday and successfully have SSH running, now I'm trying to install Ocaml but have a problem.

When I type:
Code:
$ ./configure -prefix ~
...it returns the message:
Code:
Configuring for a x86_64-unknown-linux-gnu ...
gcc found
Unable to compile the test program.
Make sure the C compiler gcc -O  is properly installed.
I don't know if it helps but I tried:
Code:
$ which gcc
...and got
Code:
/usr/bin/gcc
...I tried
Code:
$ gcc -v
...and got:
Code:
permission denied
I'm out of ideas now. Prior to this point all went exactly as indicated in the tutorial.

Please let me know if you want any more info. My host provider is HawkHost in case anyone knows them.

Really appreciate any help, thanks all.
 
Old 04-02-2010, 04:29 PM   #2
edwinbradford
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Original Poster
Rep: Reputation: 0
My host provider uses CentOS, I just tried:
Code:
yum install gcc
...but it returned:
Code:
CRITICAL:yum.cli:Config Error: Error accessing file for config file:///etc/yum.conf
I think I have to wait for help.
 
Old 04-03-2010, 12:39 PM   #3
edwinbradford
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Jeezus that was a great guess of mine . Since no-one replied yet I tried my host provider Hawk Host who are always really helpful I have to say. Access to their gcc compiler is disabled by default, hence the "permission denied" output.

I'm surprised no-one here replied with that suggestion as I know absolutely nothing about compiling on linux but it seems like I was on the right track.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
./configure --prefix= plan9 Slackware 5 01-03-2013 05:44 AM
[SOLVED] problem with "./configure --prefix=usr/local/apache --enable-module=so" dynamiteboy Linux - Newbie 12 09-15-2009 12:42 PM
./configure --prefix ?? itzig Linux - Software 10 02-03-2006 08:30 PM
./configure --prefix=/??? mykrob Linux - Newbie 7 06-24-2004 10:59 AM
prefix argument to ./configure luck___ Linux - Software 2 03-13-2004 03:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration