LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   ./configure: Permission denied on removable media (https://www.linuxquestions.org/questions/linux-newbie-8/configure-permission-denied-on-removable-media-750572/)

wakrein 08-27-2009 03:03 AM

./configure: Permission denied on removable media
 
I have googled all about this issue, i have tried many things. I searched the forums and found many issues without a resolution. I cant seem to find a resolution.
I am trying to ./configure with an output of "Permission Denied"

D:is the loction of the program i want to ./configure
If i ls -l D: (D: my removable media) i get lrwxrwxrwx 1 root root 9 2009-08-26 18:55 D: -> /media/D:/
dont know if this is relevant but could help...maybe

Also when i su and ./configure i also get the same output of "Permission Denied"

I dont know what to do im at loss for options. Any help is appriciated.

vishesh 08-27-2009 03:08 AM

What you want to configure? where configure script is located, be more clear .
what is output of mount command ?

thnks

wakrein 08-27-2009 03:14 AM

Quote:

Originally Posted by vishesh (Post 3659209)
What you want to configure? where configure script is located, be more clear .
what is output of mount command ?

thnks

I want to configure shed a hex editor
the script is located in /home/user/D:/shed-1.15
the output of the mount command is
Code:

rootfs on / type rootfs (rw)
/dev/sda1 on /.ro type ext2 (ro)
/dev/sda2 on /.rw type ext3 (rw,noatime,data=ordered)
none on / type aufs (rw,xino=/.rw/.aufs.xino,br:/.rw=rw:/.ro=ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw)
tmpfs on /dev/shm type tmpfs (rw)
tmpfs on /tmp type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/sdb1 on /media/D: type vfat (rw,nosuid,nodev,noexec,fmask=0111,dmask=0000,codepage=cp850,iocharset=utf8,shortname=mixed)
/dev/sda1 on /ro type ext2 (ro)


colucix 08-27-2009 03:18 AM

The noexec option of mount do not allow execution on the filesystem. Try to umount /dev/sdb1 and mount again using simply:
Code:

mount -t vfat /dev/sdb1 /media/D
then run ./configure again.

wakrein 08-27-2009 03:22 AM

Quote:

Originally Posted by colucix (Post 3659219)
The noexec option of mount do not allow execution on the filesystem. Try to umount /dev/sdb1 and mount again using simply:
Code:

mount -t vfat /dev/sdb1 /media/D
then run ./configure again.

mount -t vfat /dev/sdb1 media/D:

output: mount: mount point media/D does not exist

colucix 08-27-2009 03:24 AM

Code:

mkdir /media/D && mount -t vfat /dev/sdb1 /media/D

wakrein 08-27-2009 03:37 AM

Quote:

Originally Posted by colucix (Post 3659227)
Code:

mkdir /media/D && mount -t vfat /dev/sdb1 /media/D

mkdir /media/D
ok i did this still the same output
mount -t vfat /dev/sdb1 media/D
output: mount: mount point media/D: does not exist

colucix 08-27-2009 03:54 AM

Quote:

Originally Posted by wakrein (Post 3659237)
mkdir /media/D
ok i did this still the same output
mount -t vfat /dev/sdb1 media/D
output: mount: mount point media/D: does not exist

You forgot a leading slash: is /media/D, not media/D.

wakrein 08-27-2009 03:56 AM

Quote:

Originally Posted by colucix (Post 3659246)
You forgot a leading slash: is /media/D, not media/D.

oh

darn i get thi output now

mount: special device /dev/sbd1 does not exist

wakrein 08-27-2009 04:00 AM

Quote:

Originally Posted by colucix (Post 3659246)
You forgot a leading slash: is /media/D, not media/D.

i see what i did wrong i need was typing sbd instead of what i should of typed sdb heh sorry well let get it a shot

wakrein 08-27-2009 04:03 AM

Quote:

Originally Posted by colucix (Post 3659246)
You forgot a leading slash: is /media/D, not media/D.

mount: /dev/sdb1 already mounted or /media/D: busy
mount: according to mtab, /dev/sdb1 is already mounted on /media/D:

sorry for my tripple post.

colucix 08-27-2009 04:16 AM

Well, let's start from the beginning: you have first to umount /dev/sdb1:
Code:

umount /dev/sdb1
because the system automatically mounted it with noexec. Now, re-mount it under /media/D using
Code:

mount -t vfat /dev/sdb1 /media/D
As further step check the output of the mount command again (without options) to see if the disk has been mounted correctly (without noexec).

vishesh 08-27-2009 04:18 AM

use following
#mount -o remount,exec /dev/sdb1

thnks

wakrein 08-27-2009 04:27 AM

Quote:

Originally Posted by vishesh (Post 3659263)
use following
#mount -o remount,exec /dev/sdb1

thnks

done
here is mount output
Code:

rootfs on / type rootfs (rw)
/dev/sda1 on /.ro type ext2 (ro)
/dev/sda2 on /.rw type ext3 (rw,noatime,data=ordered)
none on / type aufs (rw,xino=/.rw/.aufs.xino,br:/.rw=rw:/.ro=ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw)
tmpfs on /dev/shm type tmpfs (rw)
tmpfs on /tmp type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/sdb1 on /media/D: type vfat (rw,nosuid,nodev,fmask=0111,dmask=0000,codepage=cp850,iocharset=utf8,shortname=mixed)
/dev/sda1 on /ro type ext2 (ro)

./configure
Code:

bash: ./configure: No such file or directory
mount -t vfat /dev/sdb1 /media/D:
Code:

mount: /dev/sdb1 already mounted or /media/D: busy
mount: according to mtab, /dev/sdb1 is already mounted on /media/D:


colucix 08-27-2009 04:46 AM

Quote:

Originally Posted by wakrein (Post 3659270)
Code:

bash: ./configure: No such file or directory

Be sure you're in the directory where configure is placed:
Code:

pwd
ls



All times are GMT -5. The time now is 11:09 PM.