LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-30-2013, 03:42 PM   #1
parviz
LQ Newbie
 
Registered: Jul 2013
Posts: 22

Rep: Reputation: Disabled
compose key does not work with xfce


Hello,

I am in the course of trying out Slackware, and my system is slackware 14.

I am trying to make a compose key using the following reference:

http://forum.xfce.org/viewtopic.php?id=5995

These are the steps that I took according to the reference:

1) Created the file ~/.xinitrc
2) Placed this code in the file: setxkbmap -option compose:ralt
3) Logged out and tried to make the changes effective.
However, it was impossible to start X again.

Normally, I use the command "startx" as normal user to start the X. But after the above changes, the command "startx" would no longer work. So, I deleted the file ~/.xinitrc, and was able to start X again using the command "startx".

It seems that making a file by the name of ~/.xinitrc somehow violates the settings of xfce. I am looking forward to recommendations to make the compose key work.

Thanks for reading this!
 
Old 08-30-2013, 04:30 PM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 (pre-systemd)
Posts: 2,798

Rep: Reputation: 749Reputation: 749Reputation: 749Reputation: 749Reputation: 749Reputation: 749Reputation: 749
man startx explains that if you have ~/.xinitrc then it doesn't run the default script in /etc/X11/xinit/xinitrc. Copy that to your .xinitrc and modify it to do what you want.
 
Old 08-31-2013, 09:43 AM   #3
parviz
LQ Newbie
 
Registered: Jul 2013
Posts: 22

Original Poster
Rep: Reputation: Disabled
The file /etc/X11/xinit/xinitrc in my system points to another file by the name of /etc/X11/xinit/xinitrc.xfce
I copied this latter file to my home directory under the name of /home/user/.xinitrc
Also I added to the end of ~/.xinitrc this code: setxkbmap -option compose:ralt
The command "startx" now works when I log out of X. But the compose key still does not work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] 'Compose' key not working Doug Hutcheson Linux - General 2 01-13-2013 02:39 AM
Entering special chars with compose key doesn't work in all applications. Geremia Linux - Software 4 04-13-2012 04:12 AM
[SOLVED] Lost compose key after changing to utf-8 BroX Slackware 4 03-04-2012 10:30 AM
Creating new compose and dead-key combinations DavidMcCann Linux - General 3 10-13-2007 05:01 AM
compose key not working jkobrien Linux - Hardware 1 08-05-2004 08:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration