Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-04-2010, 11:53 AM   #1
Registered: Nov 2005
Location: India
Distribution: Fedora 11
Posts: 196

Rep: Reputation: 30
compiz slow on fedora 12


I am having this problem of slow response when I enable the desktop effects that uses compiz.

Please do let me know if there is a solution for this.

I use fedora 12 on toshiba m200 satellite laptop.

Old 03-04-2010, 11:55 AM   #2
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
And the video chipset is .... ?
Old 03-04-2010, 12:13 PM   #3
Registered: Aug 2009
Location: England
Distribution: Fedora 13
Posts: 73

Rep: Reputation: 15
Type into a terminal
lspci | grep -i VGA
and paste the output here.
Old 03-04-2010, 05:10 PM   #4
John VV
LQ Muse
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,400

Rep: Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584
Compiz will Always be a bit slow on a laptop

Compiz-fusion runs on the GPU and not the cpu so for a laptop with a"built-in" chip they are about one in the same.

and will be slow.
Old 03-08-2010, 10:27 AM   #5
Registered: Nov 2005
Location: India
Distribution: Fedora 11
Posts: 196

Original Poster
Rep: Reputation: 30
heres the output:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

On the previous fedora version I was able to work around with the Desktop Effects but I think things have changed since then. I really hope I can get this working.

Thanks for the replies.
Old 04-25-2010, 11:52 AM   #6
LQ Newbie
Registered: Apr 2010
Posts: 1

Rep: Reputation: 0
Hi arunvk,

I met the same problem as yours and fixed it this way :

When you log in fedora 12 gnome or XFCE with compiz enabled, the speed is dramatically slow. To fix this,go to compiz-fusion icon, click on the right mouse button, choose "Compiz Options" and enable "Loose Binding" and "Indirect Rendering". After this my compiz on gnome and XFCE became very very fast.

Hope this will help



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 10 - compiz issue when running compiz-manager manuleka Linux - Newbie 3 02-28-2009 08:28 AM
xcompmgr really slow... worse than compiz! nonis Slackware 1 10-07-2008 11:15 AM
Since compiz install, Xscreensaver is super slow tensigh Linux - Desktop 2 03-04-2008 11:22 AM
GeForce 8400GS rubbish and slow with compiz. Adrian Baker Linux - General 8 01-12-2008 05:35 PM
my nv graphics card too slow for compiz? Kropotkin Fedora 1 11-11-2006 07:21 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:44 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration