-   Linux - Newbie (
-   -   Compiz Fusion will work in SUSE 10.3 but not in Ubuntu 7.10 (lag) (

Jason21 10-26-2007 06:06 AM

Compiz Fusion will work in SUSE 10.3 but not in Ubuntu 7.10 (lag)
Hey guys. I've been having some trouble making compiz fusion work in Ubuntu. Let me explain.

I used to run openSUSE 10.3 and, following the instructions demonstrated here I installed and ran the program successfully. Needless to say I was thrilled. But then, the Ubuntu 7.10 release notes thrilled me even more, so I decided that I should change my OS.

And so I did. I browsed through Gnome for a little while and then decided I should install Compiz Fusion, which I already knew was in the system but needed to be installed. So I used the command


sudo apt-get install compiz compizconfig-settings-manager
as instructed here.

Even though the program worked well in that session, when I restarted my system (because the network manager had stuck) I got a notification that the session I'd logged into had XGL turned on and that from that moment on, unless I changed the configuration, all my default sessions would be XGL sessions. However, the whole GUI would lag. Badly. I disabled some of the effects I thought might had been too heavy, like Wobbly Windows (even though they would work great in openSUSE), but still, the system would lag. Believing that there were incompatibility issues between my graph card drivers and Ubuntu (and I still believe that) I tried to change the drivers for my graphics card from system->administration->screens and graphics. This resulted in my GUI being screwed so I reinstalled Ubuntu (no big deal, the system was fresh anyway).

I have an Intel 945 graphics card and a 15'' screen. I love compiz fusion, but would rather run Ubuntu. Must I download new drivers? How can I do this? =/

Thanks in advance.

Edit: I didn't mean to use the "thumbsup" smiley for this thread, but now I can't get it out of there.=/

seelenbild28 10-29-2007 07:15 PM

as an old suse junkie I cannot understand why you did change your os, but anyway looks like the suse guys did a better job*g

All times are GMT -5. The time now is 12:38 AM.