-   Linux - Newbie (
-   -   Compiling RTL8192SE Linux driver : Strange error after make (

jv2112 04-10-2011 02:52 PM

Compiling RTL8192SE Linux driver : Strange error after make
I am running Debian 6 & picked up a wireless nic for my desktop since I want to locate it in an area that would be a challenge to wire. I downloaded the driver and ran make and got the strange error below. I tried doing some web research but could not find anything. I also booted up the machine w/ a Ubuntu Live disk to ensure the card was good and found no issues ( I also have the same nic in my kids machine running Ubuntu 10.10. )

Any direction would be appreciated. :hattip:

The Nic ->

The Error ->


joe@Tux-Box:/media/E-Space/Packages/Roesewill Wireless/rtl8192se_linux_2.6.0019.1207.2010$ sudo bash
[sudo] password for joe:
root@Tux-Box:/media/E-Space/Packages/Roesewill Wireless/rtl8192se_linux_2.6.0019.1207.2010# make
make[1]: Entering directory `/usr/src/linux-headers-2.6.32-5-amd64'
make[3]: *** No rule to make target `Wireless/rtl8192se_linux_2.6.0019.1207.2010/HAL/rtl8192'. Stop.
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-5-amd64'
make: *** [all] Error 2

Make File -->


LINUX_KSRC_MODULE = /lib/modules/$(shell uname -r)/kernel/drivers/net/wireless/
RTL819x_DIR = $(shell pwd)
KVER = $(shell uname -r)
KSRC = /lib/modules/$(KVER)/build
RTL819x_FIRM_DIR = $(RTL819x_DIR)/firmware
HAL_SUB_DIR = rtl8192
MODULE_FILE = $(RTL819x_DIR)/rtllib/Module.symvers
SCRIPT_FOLDER = /etc/realtek


ifeq ($(shell uname -r|cut -d. -f1,2), 2.4)
# @make -C $(RTL819x_DIR)/rtllib
@make -C $(RTL819x_DIR)/HAL/$(HAL_SUB_DIR)
@make -C $(RTL819x_DIR)/wapi_supplicant
# @make -C $(KSRC) SUBDIRS=$(RTL819x_DIR)/rtllib modules
# @test -f $(MODULE_FILE) && cp $(MODULE_FILE) $(RTL819x_DIR)/HAL/$(HAL_SUB_DIR) || echo > /dev/null
ifeq ($(NIC_SELECT), RTL8192SE_SA)
@make -C $(RTL819x_DIR)/hostapd-0.6.10/hostapd
@make -C $(KSRC) SUBDIRS=$(RTL819x_DIR)/HAL/$(HAL_SUB_DIR) modules
# @make -C $(RTL819x_DIR)/wapi_supplicant
install: all
@rm -f /etc/acpi/
@rm -f /etc/acpi/events/
@cp -fr realtek/ /etc
@make -C HAL/$(HAL_SUB_DIR)/ install
# @cp $(RTL819x_DIR)/wapi_supplicant/wapi_supplicant /usr/bin/
@make -C HAL/$(HAL_SUB_DIR)/ uninstall
@rm -fr $(SCRIPT_FOLDER)
@rm -f /usr/bin/wapi_supplicant
@make -C HAL/$(HAL_SUB_DIR)/ clean
@make -C rtllib/ clean
@test -r mshclass/ && make -C mshclass/ clean|| echo > /dev/null
@test -r wapi_supplicant/ && make -C wapi_supplicant/ clean|| echo > /dev/null
@rm -fr Modules.symvers
@rm -fr Module.symvers
@rm -fr Module.markers
@rm -fr modules.order
@rm -fr .tmp_versions
@rm -fr *~
@rm -f tags
ifeq ($(NIC_SELECT), RTL8192SE_SA)
@make -C $(RTL819x_DIR)/hostapd-0.6.10/hostapd clean
ifeq ($(NIC_SELECT), RTL8192CE_BT30)
@make -C btlib clean

EDDY1 04-10-2011 05:20 PM

The README says nothing about permissions, I'm almost positive that you'll have to chmod before installing

jv2112 04-12-2011 10:54 AM

I'll give it a shot and post my results this weekend when I get back in town when I have access to my machine.

Set the permissions wide open 777 , you think . :scratch:

Thanks for the input.

jv2112 04-15-2011 07:11 PM

Opened up permissions and I got to work :cool:

I now have to issues that stemmed from the install.

1. I have to run the script step (6 section 2 ( .wlano0up)) to start it up each boot.

2. Signal is somewhat spotty and the computer now "freezes" ( refuses input ) for 10-20 seconds at a clip every 1-2 minutes minutes.

Any thoughts ? :scratch:

Steps Taken :


II. Compile & Installation & uninstall
You can enter top-level directory of driver and execute follwing command to
Compile, Installation, or uninstall the driver:
0. Change to Super User
sudo su

1. Compile driver from the source code

2. Install the driver to the kernel
make install

3. uninstall driver
make uninstall

III. Start Up Wireless
You can use two methord to start up wireless:
<<Method 1>>
1. Install driver like II. and reboot OS
2. Wireless will brought up by GUI, such as NetworkManager
3. If Wireless is not brought up by GUI, you can use:
ifconfig wlan0 up
Note: some times when you have two wireless NICs on your computer,
interface "wlan0" may be changed to "wlan1" or "wlan2", etc.
So before "ifconfig wlan0 up", you can use "iwconfig" to check
which interface our NIC is.

<<Method 2>>
Not install driver But Only load the driver module to kernel and
start up nic.
1. Compile the drivers from the source code

2. Copy firmware to /lib/firmware/ or /lib/firmware/(KERNEL_VERSION)/
cp -rf firmware/RTL8192SE /lib/firmware or
cp -rf firmware/RTL8192SE /lib/firmware/(KERNEL_VERSION)
Note: This depends on whether (KERNEL_VERSION) subdirectory exists
under /lib/firmware

3. Load driver module to kernel.
Note: when "insmod: error inserting 'xxxx.ko': -1 File exists" comes
out after run ./wlan0up, please run ./wlan0down first, then it
should Be ok..
Note: If you see the message of "unkown symbol" during ./wlan0up, it
is suggested to start up nic use <<Method 1>>.

4. start up nic
ifconfig wlan0 up

wlan0up script ->



# Select NIC type

SYSTEM=`uname -r|cut -d. -f1,2`

if [ $SYSTEM = 2.4 ]
cd rtllib
#insmod rtllib_crypt-rsl.o
#insmod crypto-rsl.o
#insmod michael_mic-rsl.o
#insmod aes-rsl.o
#insmod rtllib_crypt_wep-rsl.o
#insmod rtllib_crypt_tkip-rsl.o
#insmod rtllib_crypt_ccmp-rsl.o
#insmod rtllib-rsl.o

case "$card" in
cd ../HAL/rtl8192u;
insmod r8192_usb.o;;
cd ../HAL/rtl8192u;
insmod r8192s_usb.o;;
cd ../HAL/rtl8192;
insmod r8190_pci.o;;
cd ../HAL/rtl8192;
insmod r8192e_pci.o;;
cd ../HAL/rtl8192;
insmod r8192se_pci.o;;
cd ../HAL/rtl8192;
insmod r8192se_pci_mesh.o;;
cd ../HAL/rtl8192;
insmod r8192ce_pci.o;;
echo "Unknown NIC type"

cp /etc/acpi/events

cd rtllib/
#insmod rtllib_crypt-rsl.ko
#insmod rtllib_crypt_wep-rsl.ko
#insmod rtllib_crypt_tkip-rsl.ko
#insmod rtllib_crypt_ccmp-rsl.ko
#insmod rtllib-rsl.ko

case "$card" in
cd ../HAL/rtl8192u;
insmod r8192_usb.ko;;
cd ../HAL/rtl8192u;
insmod r8192s_usb.ko;;
cd ../HAL/rtl8192;
insmod r8190_pci.ko;;
cd ../HAL/rtl8192;
insmod r8192e_pci.ko;;
cd ../HAL/rtl8192;
insmod r8192se_pci.ko;;
cd ../HAL/rtl8192;
insmod r8192se_pci_mesh.ko;;
cd ../HAL/rtl8192;
insmod r8192ce_pci.ko;;
echo "Unknown NIC type"

cd ../..
#ifconfig wlan0 up

EDDY1 04-15-2011 11:47 PM

Now that you've built your module you'll probably need to look at your dmesg to see if you have conflicts. You should probably post output of dmesg and let someone help you. At this point I may or may not be able to help you but someone here can.
This may help.,563

Phorize 04-15-2011 11:48 PM


Originally Posted by jv2112 (Post 4325952)
Opened up permissions and I got to work :cool:

I now have to issues that stemmed from the install.

1. I have to run the script step (6 section 2 ( .wlano0up)) to start it up each boot.

2. Signal is somewhat spotty and the computer now "freezes" ( refuses input ) for 10-20 seconds at a clip every 1-2 minutes minutes.

Any thoughts ? :scratch:

Steps Taken :

wlan0up script ->

The reason you needed to run make install as root is because it needs to write to the / file system.

You need the load the r8192se module at boot. See here for managing debian modules at boot:


I have this card in my thinkpad and it's pretty vile. System lockups occur fairly regularly. It's still in the kernel staging tree and won't be in a stable kernel until at least 2.6.40. You could hack the make file to remove the power saving functions, which I think are at the root of the lockups, but you'll still be stuck with a flaky connection!Unless you can swap out the card then you are stuck with most of these issues until realtek sort the driver out.

More explanation here:

jv2112 04-17-2011 06:34 AM

Thanks for the direction. Looks like I just got a bad card.......:mad:

Any Suggestions on a Good Card ?

Running Debian/ Testing - Kernel 2.6.38-2 amd64.

I really don't want to attempt to snake 100 feet of network cable from the basement to the third floor.... :(

jv2112 04-22-2011 04:41 AM

I have tried this card on another machine running Ubuntu 10.10 and my machine running on a Live Ubuntu disk and no issue. Works perfectly. Can anybody direct me on what the difference is on the default "network" packages. I see that DHCP3 is on the Ubuntu install an not my Debian box. I installed them ( see below) and still no good.

Any ideas. I don't want to go back to Linux with training wheels. :cry:


joe@Tux-Box:~$ sudo dpkg -l | grep -i dhcp
ii dhcp3-client 4.1.1-P1-16.1 ISC DHCP server (transitional package)
ii dhcp3-common 4.1.1-P1-16.1 ISC DHCP common files (transitional package)
ii dhcp3-server 4.1.1-P1-16.1 ISC DHCP server (transitional package)
rc dhcpcd 1:3.2.3-8 DHCP client for automatically configuring IPv4 networking
rc dhcpcd-dbus 0.5.2-2 DBus bindings for dhcpcd
ii dnsmasq-base 2.57-1 A small caching DNS proxy and DHCP/TFTP server
ii isc-dhcp-client 4.1.1-P1-16.1 ISC DHCP client
ii isc-dhcp-common 4.1.1-P1-16.1 common files used by all the isc-dhcp* packages
ii isc-dhcp-server 4.1.1-P1-16.1 ISC DHCP server for automatic IP address assignment

EDDY1 04-22-2011 05:08 AM

I may be wrong and sometimes I am, but aren't transitional packages drivers to hold a position to place the actual driver?
I just checked my system and I'm running transitional too, so I guess I'll be also waiting for someone to enlighten me on that 1.

jv2112 04-22-2011 05:11 AM


I believe you are correct but the wierd thing is when I did an update on the Ubuntu machine it just this week updated dhcp3 ...... :scratch:

Thanks for the response.

EDDY1 04-22-2011 05:16 AM

Well I have transitional also, so I guess I need to research and see if it makes a difference.

All times are GMT -5. The time now is 06:15 AM.