LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   compiling problem (https://www.linuxquestions.org/questions/linux-newbie-8/compiling-problem-405318/)

manicman 01-19-2006 05:24 AM

compiling problem
 
Hi im trying to compile fontconfig on my system but with out much luck i keep getting the following error
Code:

checking pkg-config is at least version 0.9.0... yes
checking for LIBXML2... configure: error: Package requirements (libxml-2.0 >= 2.6) were not met:

Requested 'libxml-2.0 >= 2.6' but version of libXML is 2.5.0

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBXML2_CFLAGS
and LIBXML2_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

chris@home2-linux:~/Desktop/fontconfig-2.3.93$

now ive tried updateing libxml and the same thing happens what should i do ive looked into changeing my enviroment varibles but i dont have the slightest clue how to do this could do with some help thanks

Flesym 01-19-2006 06:02 AM

You have the wrong version of libxml2. The current version in Ubuntu's breezy-repository is 2.6.21 and should do. So:
Code:

sudo apt-get install libxml2

manicman 01-19-2006 06:50 AM

ok i done that and it says i have already have the newest version
Code:

chris@home2-linux:~$ sudo apt-get install libxml2
Reading package lists... Done
Building dependency tree... Done
libxml2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 61 not upgraded.
chris@home2-linux:~$

any other ideas ?

enemorales 01-19-2006 07:03 AM

Two ideas.

First:
sudo apt-get install fontconfig

Second:
Maybe you are using only the local repository, or you have forgotten to update the package meta-data.

1) Check that you are using the right repositories (you can use symaptic for that).
2) sudo apt-get update
3) sudo apt-get install libxml2

manicman 01-19-2006 07:33 AM

hi thanks but still no luck according to synaptic i already have libxml2-2.6.21-ubuntu1 installed and although sudo apt-get install fontconfig works it doesnt not solve my problem beacuse the reason i want fontconfig is so that openbox will compile for some reason when i install it by apt-get it has loads of probems and ive solved this by compileing it in the past. this is the error i get when i try to compile openbox
Code:

checking for xft... Package fontconfig was not found
in the pkg-config search path. Perhaps you should add the directory
containing `fontconfig.pc' to the PKG_CONFIG_PATH environment
variable Package 'fontconfig', required by 'Xft', not found
configure: error: Library requirements (xft) not met; consider
adjusting the PKG_CONFIG_PATH environment variable if your libraries
are in a nonstandard prefix so pkg-config can find them.


Flesym 01-19-2006 08:10 AM

Maybe this is bold, but did you try what your computer told you to do? -Often it is as simple as that ;-)
Quote:

Perhaps you should add the directory containing `fontconfig.pc' to the PKG_CONFIG_PATH environment variable
So figure out where your 'fontconfig.pc' is:
Code:

find / -name fontconfig.pc 2> /dev/null
and then add the found path to the specified env-var:
Code:

export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/here/the/path/to/fontconfig.pc

manicman 01-19-2006 08:52 AM

thanks but unfortunately
Code:

find / -name fontconfig.pc 2> /dev/null
doesnt actuley find anything

Flesym 01-19-2006 09:53 AM

I think the file "fontconfig.pc" comes with the development library of fontconfig so try:
Code:

sudo apt-get install libfontconfig1-dev

manicman 01-19-2006 11:54 AM

Thanks everyone that worked thanks for your help :)


All times are GMT -5. The time now is 05:48 AM.