LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Compiling 2.6.6 kernel in fedora core 2... (https://www.linuxquestions.org/questions/linux-newbie-8/compiling-2-6-6-kernel-in-fedora-core-2-a-183660/)

SpItoS 05-20-2004 07:00 AM

Compiling 2.6.6 kernel in fedora core 2...
 
Any ideas? I recompiled it as I would with any kernel using my kernel source 2.6.6 and my old .config file and modifying it to fit my needs . Everything is in /usr/src/linux-2.6.6 then I type make && make modules_install && make install which worked a lot of times using 2.6.5 kernel... It appears as usual with grub but when I load it stays on Uncompressing linux... OK, bootking kernel or something similar and it doesn't load...

I don't know what to do, I get no errors or anything while compiling the kernel and my .config file seems ok too. I would like it to work since I can't use my nvidia drivers in fedora core 2 and it seems that recompiling kernel is the way to go.


It's a new kernel so I can access the other kernels. I did it several time with 2.6.5 the same exact way (well some stuff in .config were different) and it always worked.

It gets stuck right before the part where it says something like : Loading Red hat nash 3.... I don't see that part as I would in other kernels.

I looked and everything is fine in my .config and my grub.conf.

comprookie2000 05-20-2004 04:48 PM

When you first started did you cd src
rm linux
not sure if you have to some say yes some say not nessesary,I go ahead and do it if it is there from another kernel,david

SpItoS 05-20-2004 06:37 PM

Well I did remove all unnecessary kernels only keeping my current one and a backup one. I tried making a config file for 2.6.6 from scratch using make xconfig and removed every unneccessary things and adding those I needs but It won't go past :

Uncompressing linux... Ok, bootking kernel.
audit:34653463(I just typed random numbers) and it freezes there.

The weirdest thing is my .config file is fine cause I used it with 2.6.5 kernels and it worked #1. I really can't find the problem... maybe it's a fedora core 2 test 3 problem or some option in grub that won't make it boot...

Anyway if someone has any advice at all I could test I'm willing to test pretty much anything since I have nothing to lose I just want my nvidia drivers to work and in fedora core 2 they won't work in any kernel I tried but 2.6.6 seems to be ok since it has option CONFIG_4KSTACKS=n.

Belerefontis 06-02-2004 05:59 PM

It does tha same to me but after about a minute,it starts booting !!!Don't know how much you have waited but try waiting little longer.

Xaque208 01-17-2005 02:51 PM

I am haveing a very simil problem. However I think I have narowed it down to being the image file in my /boot directory.


All times are GMT -5. The time now is 02:05 PM.