LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   compiler not found (https://www.linuxquestions.org/questions/linux-newbie-8/compiler-not-found-510398/)

Atomtomate 12-14-2006 09:32 AM

compiler not found
 
hi,
i set up a new root server with SuSE 10.0. as i tried to compile the source for some programs i got following error message "configure: error: no acceptable cc found in $PATH" but the gcc compiler IS installed under /usr/lib/gcc/i586-suse-linux/4.0.2/
i couldn`t even reinstall it due t the fact i didn`t find any .rpm packeges and everything i found was about desktop systems with YAST.


would be nice if anybody could help me :)

Atomtomate

cyber-worx 12-14-2006 10:01 AM

please give the output of:
Code:

which gcc

Atomtomate 12-14-2006 10:03 AM

there is no output :( the cursor just jumps into the next line.

johnson_steve 12-14-2006 10:08 AM

that means it isn't in your path. mine looks like:
Code:

steve@localhost ~ $ which gcc
/usr/bin/gcc

this may not fix your problem but maybe as root:

Code:

ln -s /usr/lib/gcc/i586-suse-linux/4.0.2/gcc /usr/bin/gcc
then at least it should be able to find it. alternatively you could change your $PATH.

cyber-worx 12-14-2006 10:08 AM

ok, as root:
please paste the output of:
Code:

echo $PATH
if you see /usr/bin/ in the path then try:

Code:

ln -sf /usr/lib/gcc/i586-suse-linux/4.0.2/gcc /usr/bin/gcc
ln -s /usr/bin/gcc /usr/bin/cc


Atomtomate 12-14-2006 10:13 AM

echo $PATH output was
Code:

/sbin:/usr/sbin:/usr/local/sbin:/opt/gnome/sbin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin
suse100m:/usr/local/gcc-4.1.1 # ln -sf /usr/lib/gcc/i586-suse-linux/4.0.2/gcc /usr/bin/gcc

so entered both comamnds, nothing changed, i still get the same error.

Atomtomate 12-14-2006 12:29 PM

the links were created, i tried to copy the whole gcc (cc1 file) to the bin directory, still the same error. it`s not a error of this program, too. i tried it with two different.

hope anybody can help me with this. I want to get my servers online today... links are welcome, too :study:

/edit after copiing the gcc file into the bin directory something changed:
Code:

checking for gcc... no
checking for cc... cc
checking whether the C compiler (cc  ) works... yes
checking whether the C compiler (cc  ) is a cross-compiler... yes
checking whether we are using GNU C... yes
checking whether cc accepts -g... no

there it stops....

skullmunky 12-15-2006 01:05 AM

another solution: download suse 10.1 and re install. gcc is so fundamental that if there's something awry with it, this might be faster than trying to fix it, especially if this is a new server anyway.

cyber-worx 12-15-2006 02:32 AM

I agree with the last post.

Better to have the system in a known working state before you turn it into a full server!

Atomtomate 12-15-2006 09:56 AM

that would take days again -.- is there no way to fix the problem in another way? :cry:

Atomtomate 12-15-2006 12:07 PM

my host told me there wouldn`t be a gcc compiler anymore in the new SuSE version(sounds strange, i know -.-) so i just have the cahnce to solve this without reinstalling.perhaps reinstalling the gcc package would help, does anybody have a link to a .rpm package working for SuSE 10.x?

skullmunky 12-15-2006 01:21 PM

i just saw a similar problem from a student who was having a hard time installing the NVIDIA driver - namely, no gcc so no ability to compile anything. turns out it was because the default install options (suse 10.1 original release) didn't actually include the compiler. we put the dvd back in & installed it, much better now.

if you don't want to do a full re-install, there might be an online repository via novell; opensuse.org has the repositories for 10.1 and 10.2 but you're on 10.0, right?

do you still have the installer discs?

i doubt there wouldn't be a gcc compiler included in newer versions of suse. your host might be mistaking gcc for something else.

Atomtomate 12-15-2006 02:12 PM

as i said we are talking about a root server. this machine actually has no cd-rom drive and i don`t have any chance to install something from another source than a file :o


All times are GMT -5. The time now is 07:02 PM.