LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-17-2015, 12:24 PM   #1
eladzv
LQ Newbie
 
Registered: Nov 2015
Posts: 6

Rep: Reputation: Disabled
Talking compile new kernel error


hello

my system is red-hat enterprise 7.
I encounter this problem when I was trying to compile new kernel ..
first i downloaded new kernel (v 4.3) from kernel.org
installed the groupinstall 'Development Tools' and use the make clean..
I extract it (to /usr/src/linux-4.3) and create the .config file with
make menuconfig command
(without changing any default option)
when i try to use make/make bzImage i got this error :
**********************************
CALL scripts/checksyscalls.sh
HOSTCC scripts/sign-file
scripts/sign-file.c:23:30: fatal error: openssl/opensslv.h: No such file or directory
#include <openssl/opensslv.h>
^
compilation terminated.
make[1]: *** [scripts/sign-file] Error 1
make: *** [scripts] Error 2
***********************************

i read that if i will install the openssl-devel package
it will create the file openssl/opensslv.h

when i tryed to install it i got this error :

[teacher@localhost linux-4.3]$ sudo yum install openssl-devel
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
: manager
rhel-7-server-eus-rpms | 3.8 kB 00:00
rhel-7-server-rpms | 3.7 kB 00:00
rhel-7-server-rt-beta-rpms | 3.8 kB 00:00
rhel-7-server-rt-rpms | 3.8 kB 00:00
rhel-ha-for-rhel-7-server-eus-rpms | 2.9 kB 00:00
rhel-ha-for-rhel-7-server-rpms | 3.7 kB 00:00
rhel-rs-for-rhel-7-server-eus-rpms | 2.9 kB 00:00
rhel-rs-for-rhel-7-server-rpms | 3.7 kB 00:00
(1/7): rhel-7-server-eus-rpms/7Server/x86_64/updateinfo | 491 kB 00:01
(2/7): rhel-7-server-eus-rpms/7Server/x86_64/group | 648 kB 00:01
(3/7): rhel-7-server-rt-rpms/7Server/x86_64/group | 895 B 00:01
(4/7): rhel-7-server-rt-rpms/7Server/x86_64/updateinfo | 16 kB 00:01
(5/7): rhel-7-server-rt-rpms/7Server/x86_64/primary_db | 30 kB 00:00
(6/7): rhel-7-server-eus-rpms/7Server/x86_64/primary_db | 17 MB 00:17
(7/7): rhel-7-server-rpms/7Server/x86_64/primary_db | 15 MB 00:24
rhel-7-server-rpms/7Server/x86_64/updateinfo | 662 kB 00:08
Resolving Dependencies
--> Running transaction check
---> Package openssl-devel.x86_64 1:1.0.1e-42.el7_1.9 will be installed
--> Processing Dependency: krb5-devel(x86-64) for package: 1penssl-devel-1.0.1e-42.el7_1.9.x86_64
--> Processing Dependency: zlib-devel(x86-64) for package: 1penssl-devel-1.0.1e-42.el7_1.9.x86_64
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.12.2-15.el7_1 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.12.2-15.el7_1 for package: krb5-devel-1.12.2-15.el7_1.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.12.2-15.el7_1.x86_64
--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.12.2-15.el7_1.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.12.2-15.el7_1.x86_64
--> Processing Dependency: libverto-devel for package: krb5-devel-1.12.2-15.el7_1.x86_64
--> Processing Dependency: libkdb5.so.7()(64bit) for package: krb5-devel-1.12.2-15.el7_1.x86_64
---> Package zlib-devel.x86_64 0:1.2.7-13.el7 will be installed
--> Processing Dependency: zlib = 1.2.7-13.el7 for package: zlib-devel-1.2.7-13.el7.x86_64
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.5.8-3.el7 will be installed
---> Package krb5-devel.x86_64 0:1.12.2-15.el7_1 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.12.2-15.el7_1 for package: krb5-devel-1.12.2-15.el7_1.x86_64
--> Processing Dependency: libkdb5.so.7()(64bit) for package: krb5-devel-1.12.2-15.el7_1.x86_64
---> Package libcom_err-devel.x86_64 0:1.42.9-7.el7 will be installed
---> Package libselinux-devel.x86_64 0:2.2.2-6.el7 will be installed
--> Processing Dependency: libsepol-devel >= 2.1.9-1 for package: libselinux-devel-2.2.2-6.el7.x86_64
--> Processing Dependency: pkgconfig(libpcre) for package: libselinux-devel-2.2.2-6.el7.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.2.2-6.el7.x86_64
---> Package libverto-devel.x86_64 0:0.2.5-4.el7 will be installed
---> Package zlib.i686 0:1.2.7-13.el7 will be installed
--> Processing Dependency: libc.so.6 for package: zlib-1.2.7-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: zlib-1.2.7-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: zlib-1.2.7-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: zlib-1.2.7-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: zlib-1.2.7-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: zlib-1.2.7-13.el7.i686
--> Running transaction check
---> Package glibc.i686 0:2.17-78.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-78.el7 for package: glibc-2.17-78.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-78.el7.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-78.el7.i686
---> Package krb5-devel.x86_64 0:1.12.2-15.el7_1 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.12.2-15.el7_1 for package: krb5-devel-1.12.2-15.el7_1.x86_64
--> Processing Dependency: libkdb5.so.7()(64bit) for package: krb5-devel-1.12.2-15.el7_1.x86_64
---> Package libsepol-devel.x86_64 0:2.1.9-3.el7 will be installed
---> Package pcre-devel.x86_64 0:8.32-14.el7 will be installed
--> Processing Dependency: pcre(x86-64) = 8.32-14.el7 for package: pcre-devel-8.32-14.el7.x86_64
--> Running transaction check
---> Package glibc.i686 0:2.17-78.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-78.el7 for package: glibc-2.17-78.el7.i686
---> Package krb5-devel.x86_64 0:1.12.2-15.el7_1 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.12.2-15.el7_1 for package: krb5-devel-1.12.2-15.el7_1.x86_64
--> Processing Dependency: libkdb5.so.7()(64bit) for package: krb5-devel-1.12.2-15.el7_1.x86_64
---> Package nss-softokn-freebl.i686 0:3.16.2.3-13.el7_1 will be installed
---> Package pcre-devel.x86_64 0:8.32-14.el7 will be installed
--> Processing Dependency: pcre(x86-64) = 8.32-14.el7 for package: pcre-devel-8.32-14.el7.x86_64
--> Finished Dependency Resolution
Error: Package: pcre-devel-8.32-14.el7.x86_64 (rhel-7-server-eus-rpms)
Requires: pcre(x86-64) = 8.32-14.el7
Installed: pcre-8.32-15.el7.x86_64 (@anaconda/7.2)
pcre(x86-64) = 8.32-15.el7
Available: pcre-8.32-12.el7.x86_64 (rhel-7-server-eus-rpms)
pcre(x86-64) = 8.32-12.el7
Available: pcre-8.32-14.el7.x86_64 (rhel-7-server-eus-rpms)
pcre(x86-64) = 8.32-14.el7
Error: Package: krb5-devel-1.12.2-15.el7_1.x86_64 (rhel-7-server-eus-rpms)
Requires: libkdb5.so.7()(64bit)
Available: krb5-libs-1.11.3-49.el7.x86_64 (rhel-7-server-eus-rpms)
libkdb5.so.7()(64bit)
Available: krb5-libs-1.12.2-14.el7.x86_64 (rhel-7-server-eus-rpms)
libkdb5.so.7()(64bit)
Available: krb5-libs-1.12.2-15.el7_1.x86_64 (rhel-7-server-eus-rpms)
libkdb5.so.7()(64bit)
Installed: krb5-libs-1.13.2-7.el7.x86_64 (@anaconda/7.2)
~libkdb5.so.8()(64bit)
Error: Package: krb5-devel-1.12.2-15.el7_1.x86_64 (rhel-7-server-eus-rpms)
Requires: krb5-libs(x86-64) = 1.12.2-15.el7_1
Installed: krb5-libs-1.13.2-7.el7.x86_64 (@anaconda/7.2)
krb5-libs(x86-64) = 1.13.2-7.el7
Available: krb5-libs-1.11.3-49.el7.x86_64 (rhel-7-server-eus-rpms)
krb5-libs(x86-64) = 1.11.3-49.el7
Available: krb5-libs-1.12.2-14.el7.x86_64 (rhel-7-server-eus-rpms)
krb5-libs(x86-64) = 1.12.2-14.el7
Available: krb5-libs-1.12.2-15.el7_1.x86_64 (rhel-7-server-eus-rpms)
krb5-libs(x86-64) = 1.12.2-15.el7_1
Error: Package: glibc-2.17-78.el7.i686 (rhel-7-server-eus-rpms)
Requires: glibc-common = 2.17-78.el7
Installed: glibc-common-2.17-105.el7.x86_64 (@anaconda/7.2)
glibc-common = 2.17-105.el7
Available: glibc-common-2.17-55.el7.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-55.el7
Available: glibc-common-2.17-55.el7_0.1.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-55.el7_0.1
Available: glibc-common-2.17-55.el7_0.3.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-55.el7_0.3
Available: glibc-common-2.17-55.el7_0.5.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-55.el7_0.5
Available: glibc-common-2.17-78.el7.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-78.el7
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: pcre-devel-8.32-14.el7.x86_64 (rhel-7-server-eus-rpms)
Requires: pcre(x86-64) = 8.32-14.el7
Installed: pcre-8.32-15.el7.x86_64 (@anaconda/7.2)
pcre(x86-64) = 8.32-15.el7
Available: pcre-8.32-12.el7.x86_64 (rhel-7-server-eus-rpms)
pcre(x86-64) = 8.32-12.el7
Available: pcre-8.32-14.el7.x86_64 (rhel-7-server-eus-rpms)
pcre(x86-64) = 8.32-14.el7
Error: Package: krb5-devel-1.12.2-15.el7_1.x86_64 (rhel-7-server-eus-rpms)
Requires: libkdb5.so.7()(64bit)
Available: krb5-libs-1.11.3-49.el7.x86_64 (rhel-7-server-eus-rpms)
libkdb5.so.7()(64bit)
Available: krb5-libs-1.12.2-14.el7.x86_64 (rhel-7-server-eus-rpms)
libkdb5.so.7()(64bit)
Available: krb5-libs-1.12.2-15.el7_1.x86_64 (rhel-7-server-eus-rpms)
libkdb5.so.7()(64bit)
Installed: krb5-libs-1.13.2-7.el7.x86_64 (@anaconda/7.2)
~libkdb5.so.8()(64bit)
Error: Package: krb5-devel-1.12.2-15.el7_1.x86_64 (rhel-7-server-eus-rpms)
Requires: krb5-libs(x86-64) = 1.12.2-15.el7_1
Installed: krb5-libs-1.13.2-7.el7.x86_64 (@anaconda/7.2)
krb5-libs(x86-64) = 1.13.2-7.el7
Available: krb5-libs-1.11.3-49.el7.x86_64 (rhel-7-server-eus-rpms)
krb5-libs(x86-64) = 1.11.3-49.el7
Available: krb5-libs-1.12.2-14.el7.x86_64 (rhel-7-server-eus-rpms)
krb5-libs(x86-64) = 1.12.2-14.el7
Available: krb5-libs-1.12.2-15.el7_1.x86_64 (rhel-7-server-eus-rpms)
krb5-libs(x86-64) = 1.12.2-15.el7_1
Error: Package: glibc-2.17-78.el7.i686 (rhel-7-server-eus-rpms)
Requires: glibc-common = 2.17-78.el7
Installed: glibc-common-2.17-105.el7.x86_64 (@anaconda/7.2)
glibc-common = 2.17-105.el7
Available: glibc-common-2.17-55.el7.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-55.el7
Available: glibc-common-2.17-55.el7_0.1.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-55.el7_0.1
Available: glibc-common-2.17-55.el7_0.3.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-55.el7_0.3
Available: glibc-common-2.17-55.el7_0.5.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-55.el7_0.5
Available: glibc-common-2.17-78.el7.x86_64 (rhel-7-server-eus-rpms)
glibc-common = 2.17-78.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
 
Old 11-18-2015, 10:50 PM   #2
tomwest
Member
 
Registered: Aug 2013
Posts: 58

Rep: Reputation: Disabled
eladzv wrote:
Quote:
I extract it (to /usr/src/linux-4.3)
I draw your attention to the README file in the kernel source:

Quote:
INSTALLING the kernel source:

- If you install the full sources, put the kernel tarball in a
directory where you have permissions (eg. your home directory) and
unpack it:

xz -cd linux-4.X.tar.xz | tar xvf -

Replace "X" with the version number of the latest kernel.

Do NOT use the /usr/src/linux area! This area has a (usually
incomplete) set of kernel headers that are used by the library header
files. They should match the library, and not get messed up by
whatever the kernel-du-jour happens to be.
 
Old 11-19-2015, 12:31 PM   #3
eladzv
LQ Newbie
 
Registered: Nov 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
hi tomwest

i moved the kernel folder to ~/linux-4.3

i use chmod 777 ~/linux-4.3 to eliminate any problem with permissions
even used the root account to run the make command
and still im getting the openssl error ...
 
Old 12-15-2015, 06:07 AM   #4
xserty
LQ Newbie
 
Registered: Apr 2015
Posts: 1

Rep: Reputation: Disabled
Hi,
you are missing the openssl header files.
Try installing openssl-devel
Good luck

Last edited by xserty; 12-15-2015 at 06:10 AM.
 
Old 12-15-2015, 02:28 PM   #5
eladzv
LQ Newbie
 
Registered: Nov 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi,

i will try it ..

thanks for all the help ( :
 
Old 05-16-2016, 03:44 PM   #6
nbull
LQ Newbie
 
Registered: May 2016
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by xserty View Post
Hi,
you are missing the openssl header files.
Try installing openssl-devel
Good luck

Thank you men, this works fine for me....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in Compile Kernel 3.18 hamsaeed Linux - General 3 02-03-2015 11:26 AM
error when compile kernel just.centos Linux - Kernel 4 05-05-2011 02:39 AM
kernel compile error ShawnNelson Slackware 1 06-12-2009 01:11 PM
Kernel compile error rael_kid Linux - Newbie 14 04-25-2005 12:41 PM
Error during the kernel (2.6.10) compile. Whynot Debian 1 03-03-2005 08:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration