LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2006, 01:36 AM   #1
leiw
Member
 
Registered: Apr 2006
Posts: 131

Rep: Reputation: 15
Compile kernel on FC5


I want install Dazuko on FC5, I tried to rebuild the kernel which following http://www.dazuko.org/tgen.shtml#FEDORA , when I type make command, so I don;t know how can fix this problem.

have error in /usr/src/kernels/2.6.15-1.2054_FC5-i586/

[root@scalix 2.6.15-1.2054_FC5-i586]# make
CHK include/linux/version.h
SPLIT include/linux/autoconf.h -> include/config/*
HOSTCC scripts/genksyms/genksyms.o
HOSTCC scripts/genksyms/lex.o
scripts/genksyms/lex.c:546:5: warning: "YY_STACK_USED" is not defined
scripts/genksyms/lex.c:1424:5: warning: "YY_ALWAYS_INTERACTIVE" is not defined
scripts/genksyms/lex.c:1427:5: warning: "YY_NEVER_INTERACTIVE" is not defined
scripts/genksyms/lex.c:1718:5: warning: "YY_MAIN" is not defined
HOSTCC scripts/genksyms/parse.o
scripts/genksyms/parse.c:819:6: warning: "YYLTYPE_IS_TRIVIAL" is not defined
HOSTLD scripts/genksyms/genksyms
CC scripts/mod/empty.o
MKELF scripts/mod/elfconfig.h
HOSTCC scripts/mod/file2alias.o
HOSTCC scripts/mod/modpost.o
HOSTCC scripts/mod/sumversion.o
HOSTLD scripts/mod/modpost
make[1]: *** No rule to make target `init/main.o', needed by `init/built-in.o'. Stop.
make: *** [init] Error 2
 
Old 12-11-2006, 06:47 AM   #2
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,285

Rep: Reputation: 61
You need to recompile the kernel, compile in a few extra things that are needed to be able to compile dazuko from source, just out of curiosity are you wanting dazuko so you can use Klamav?
 
Old 12-12-2006, 10:17 PM   #3
leiw
Member
 
Registered: Apr 2006
Posts: 131

Original Poster
Rep: Reputation: 15
Ok, after I use google serach for the Klamav, I need control Klamav

in GUI, but my server in datacentre, because I using ssh to remote

the server , so how can I remote to server using GUI ?


Thanks

Last edited by leiw; 12-12-2006 at 10:27 PM.
 
Old 12-13-2006, 10:30 PM   #4
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,285

Rep: Reputation: 61
Quote:
Originally Posted by leiw
Ok, after I use google serach for the Klamav, I need control Klamav

in GUI, but my server in datacentre, because I using ssh to remote

the server , so how can I remote to server using GUI ?


Thanks
Probably the best gui to use for remote login will depend on what is install on the server. If you have xserver installed and running a GUI like KDE or Gnome you could use Remote Desktop.

But seeing how this is a server it's most likely wont have a desktop manager like KDE or Gnome installed. So I would probably suggest something like gFTP if it has sftp enabled in the ssh server, gFTP can use ssh to connect securely to the server. Or if your using a windoze box something like Putty and WinSCP.


The reason I ask about Klamav is, dazuko is installed when you install Klamav, but I had such problems trying to get dazuko to install even after recompiling the kernel many times, and kept getting compiling errors. Eventually I just installed Klamav without installing dazuko, thought you may have been doing something similar
 
Old 12-14-2006, 09:38 AM   #5
leiw
Member
 
Registered: Apr 2006
Posts: 131

Original Poster
Rep: Reputation: 15
###Eventually I just installed Klamav without installing dazuko###

How can I installing Klamav without install dazuko ? I know when installing Klamav required to choose Klamav and Dazuko, is that
I only to choose Klamav for installation , so can without install dazuko ?


Thanks
 
Old 12-17-2006, 02:10 AM   #6
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,285

Rep: Reputation: 61
Downloaded the source file, not the installer binary, extracted them to my home directory, removed the 2 dazuko dorectories just incase klamav searches for these directories. Then just changed into the klamaav directory and compiled from source using these commands:

Code:
./configure --prefix=/opt/kde
make
make install

if you need the source file you can get it from here, just get the version that matches the version of clamav that is installed:

http://sourceforge.net/project/showf...roup_id=102171
 
Old 12-17-2006, 06:49 AM   #7
leiw
Member
 
Registered: Apr 2006
Posts: 131

Original Poster
Rep: Reputation: 15
To fotoguy,

I using my Centos 4.3 and Klamav-0.37 to compile during have following problem:

The following error during ./configure
..........................
..........................
checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and libraries) not found. Please check your installation!

I have qt installed :

#rpm -qa | grep qt
qt-3.3.3-10.RHEL4
qt-devel-3.3.3-10.RHEL4


Thanks
 
Old 12-17-2006, 09:44 PM   #8
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,285

Rep: Reputation: 61
Quote:
Originally Posted by leiw
To fotoguy,

I using my Centos 4.3 and Klamav-0.37 to compile during have following problem:

The following error during ./configure
..........................
..........................
checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and libraries) not found. Please check your installation!

I have qt installed :

#rpm -qa | grep qt
qt-3.3.3-10.RHEL4
qt-devel-3.3.3-10.RHEL4


Thanks

If QT is installed and it's not finding the libraries, sounds like the developers of CentOS may have compiled them to a different place other than the default location, then you need to pass the directory location of QT libraries during the ./configure stage.


Code:
./configure --prefix=/opt/kde --with-qt-libraries=/usr/lib/qt
make
make install

I don't use CentOS so I don't know where the libraries might be, on slackware its under /usr/lib/qt, you may just need to search for them or google for the location
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cant compile ffmpeg on FC5 aditya1 Linux - Software 1 09-19-2006 10:06 PM
qgspider fails to compile on FC5 maclover2@mail.com Linux - Software 0 06-07-2006 09:59 PM
Why do many things fail to compile on FC5? Zaventh Fedora 2 04-02-2006 11:29 AM
Kernel Problems. Howto Compile a new kernel from 4.2 with backwards compatibility ? ShoCkwave Linux - General 2 06-19-2004 07:02 AM
Kernel 2.4.23 compile causes kernel panics on ATA RAID-1 (mirror) array Raptor Ramjet Slackware 3 12-18-2003 02:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration