LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   command to view permission of directories (https://www.linuxquestions.org/questions/linux-newbie-8/command-to-view-permission-of-directories-594998/)

babu198649 10-27-2007 07:00 AM

command to view permission of directories
 
hi

what is the command to view permission of files and directories

thank u

mobs99 10-27-2007 07:01 AM

u can hit "ls -l" it will give u the permissions.. minus the speech marks tho lol..

KrazyKanuk 10-27-2007 07:01 AM

do you mean ls -la /directory ?

babu198649 10-27-2007 07:12 AM

thank mobs99

actually i want to delete a directory in the trash i tried by changing the permission by using chmod command like this


user@localhost:~/.Trash$ chmod 777 ksquirrel-libs-0.7.1/


then i tried to delete using rm like this

user@localhost:~/.Trash$ rm ksquirrel-libs-0.7.1/
rm: cannot remove `ksquirrel-libs-0.7.1/': Is a directory


so i viewed the permissions again it displays like this

user@localhost:~/.Trash$ ls -l
total 8
drwxrwxrwx 4 user user 4096 2007-10-26 11:40 ksquirrel-libs-0.7.1


how can i delete the file

thanks

mobs99 10-27-2007 07:14 AM

u can delete the file manually by going into ur directories.. i cant remember the actual command line for it...i think its rmdir "filename[/B]" minus the speech marks again....

babu198649 10-27-2007 07:19 AM

when i tried to delete manually i got the following message in the message box.



"/home/user...e/requests" cannot be deleted because you do not have permissions to modify
its parent folder.

mobs99 10-27-2007 07:22 AM

wots the actual permisions uve set.. set it to. is it a folder or a file inside a folder... if its a folder set it to.. chmod 711... file chmod 644

babu198649 10-27-2007 07:33 AM

its a directory i have tried

[root@localhost .Trash]# chmod 711 ksquirrel-libs-0.7.1/



and then


[root@localhost .Trash]# ls -l ksquirrel-libs-0.7.1/
total 1108
drwx--x--x 2 root root 4096 2007-09-19 15:10 autom4te.cache
-rwx--x--x 1 root root 1026936 2007-09-19 15:11 configure
-rwx--x--x 1 user user 681 2007-08-31 00:20 INSTALL
drwx--x--x 59 user user 4096 2007-09-19 15:10 kernel
-rwx--x--x 1 root root 326 2007-09-19 14:53 ksquirrellibs.pc
-rwx--x--x 1 user user 321 2007-08-30 23:45 ksquirrellibs.pc.in
-rwx--x--x 1 root root 26027 2007-09-19 15:11 Makefile.in
-rwx--x--x 1 user user 4536 2007-08-30 23:45 mng_LICENSE
-rwx--x--x 1 user user 0 2007-09-15 01:17 stamp-h.in
-rwx--x--x 1 user user 11 2007-08-30 23:45 subdirs



now when tried to remove using

[root@localhost .Trash]# rm ksquirrel-libs-0.7.1/
rm: cannot remove `ksquirrel-libs-0.7.1/': Is a directory


it is a directory

thanks for u r time

selva146 10-27-2007 07:47 AM

hi
if you want to delete a directory, use the following command..


rm -rf dirname

this will delete the files and subdirs inside the dir recursively and delete the dir

-r ------recursive
-f ------ force


ok

babu198649 10-27-2007 07:56 AM

thankyou selva it has worked


All times are GMT -5. The time now is 05:40 AM.