LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2010, 07:57 AM   #1
linuxcluster
LQ Newbie
 
Registered: Mar 2010
Posts: 6

Rep: Reputation: 0
cluster not working after removing network cable


Dear all

We were moving our cluter and during this process eth1 cable(external internet cable) was pluged-out. After pulg-in that wire again cluster is not working nicely and some process including mysql is not working. Can anyone please help on this

Thanks
HP
 
Old 03-16-2010, 08:03 AM   #2
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
How do you mean 'not working nicely'? Is it working, but not as expected, or is it not working at all? As for MySQL, how are you coming to the conclusion that removing the cable did this?
 
Old 03-17-2010, 01:19 AM   #3
linuxcluster
LQ Newbie
 
Registered: Mar 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Internet and remote access is not working at all.
When tried to restart mysql service it failed and it not working.
 
Old 03-17-2010, 01:24 AM   #4
Sayan Acharjee
Member
 
Registered: Feb 2010
Location: Chennai, India
Distribution: Manjaro
Posts: 616

Rep: Reputation: 64
Restart mysqld, that is the only solution.
 
Old 03-17-2010, 08:00 AM   #5
linuxcluster
LQ Newbie
 
Registered: Mar 2010
Posts: 6

Original Poster
Rep: Reputation: 0
we tried to restart the mysqld service again but it failed.
 
Old 03-17-2010, 08:02 AM   #6
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
Did MySQLD give you an error message? What have you tried so far to fix the connectivity?
 
Old 03-17-2010, 08:10 AM   #7
Sayan Acharjee
Member
 
Registered: Feb 2010
Location: Chennai, India
Distribution: Manjaro
Posts: 616

Rep: Reputation: 64
Check the log file for error messages:
Quote:
#tail -f /var/log/mysqld.log
 
Old 03-17-2010, 09:25 AM   #8
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,150

Rep: Reputation: 887Reputation: 887Reputation: 887Reputation: 887Reputation: 887Reputation: 887Reputation: 887
Quote:
Originally Posted by linuxcluster View Post
Internet and remote access is not working at all.
with ethernet plugged in, type
ifconfig
ifconfig -a
lspci | grep -i net

on all the machines you care about.

Last edited by schneidz; 03-17-2010 at 09:27 AM.
 
Old 03-18-2010, 01:18 AM   #9
linuxcluster
LQ Newbie
 
Registered: Mar 2010
Posts: 6

Original Poster
Rep: Reputation: 0
When we tried to restart mysqld service it showd
[root@cluster sbin]# service mysqld restart
Stopping MySQL: [FAILED]

we also tried to restart the server again and but that also didnt work..
 
Old 03-18-2010, 01:21 AM   #10
Sayan Acharjee
Member
 
Registered: Feb 2010
Location: Chennai, India
Distribution: Manjaro
Posts: 616

Rep: Reputation: 64
Is there any error messages in the log file?
 
Old 03-18-2010, 06:56 AM   #11
linuxcluster
LQ Newbie
 
Registered: Mar 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Hi mysqld.log says

[root@cluster media]# tail -f /var/log/mysqld.log
Number of processes running now: 0
100318 04:02:29 mysqld restarted
100318 4:02:29 InnoDB: Started; log sequence number 0 43675
100318 4:02:29 [ERROR] /usr/libexec/mysqld: Error writing file '/var/run/mysqld/mysqld.pid' (Errcode: 28)
100318 4:02:29 [ERROR] Can't start server: can't create PID file: No space left on device


I guess this can be fixed by making some space in it. But another thing is eth1(Internet is not working). We also tried to restart the netwrok service but it says no eth1 link.
 
Old 03-18-2010, 07:02 AM   #12
linuxcluster
LQ Newbie
 
Registered: Mar 2010
Posts: 6

Original Poster
Rep: Reputation: 0
ifconfig is as it was earlier. Static IP is assigned to it.
lspci | grep -i net shows

root@cluster media]# lspci | grep -i net
05:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
 
Old 03-18-2010, 11:31 AM   #13
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,150

Rep: Reputation: 887Reputation: 887Reputation: 887Reputation: 887Reputation: 887Reputation: 887Reputation: 887
have you tried:
Code:
sudo ifconfig eth1 down
sudo ifconfig eth1 up
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cluster network stop rajatjpatel Red Hat 1 11-03-2009 12:59 PM
CMAN cluster over long network fft9qh Linux - Enterprise 0 10-22-2008 08:29 AM
Removing survivable cluster configuration Almost Lost Linux - Enterprise 1 12-27-2005 06:46 PM
need Network install HELP for Mandrake 9.2! using network.img w/ cable modem physans Mandriva 6 02-25-2004 04:15 PM
Beowulf Cluster or Network CCParrish Linux - General 3 12-24-2000 11:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration