LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-13-2009, 01:09 AM   #1
suvirj
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Rep: Reputation: 0
Angry Classic grub problem


Hello, this seems like a classic grub problem.

I had a Ubuntu Jaunty and Vista on dual-boot. Got a special Ubuntu Fiesty LiveCd with a book. I installed the Ubuntu Fiesty on a seperate partition and NOW my new grub (changed by Fiesty) does list Ubuntu 9 and Vista. But I am not able to load the Ubuntu 9. Apparently there is a "Error 2:Bad file or directory type".Vista loads fine.

I read few other forums and saw something about a 256-bit inode. But what exactly should I do to fix it? I don't want to end up with a machine that cant load any of the installed OS.

Thanks for any help!

Additional Info:
I went to the grub menu in my terminal and tried "find (hd0,7)" since my ubuntu9 is on sda8 and it returned "File not found".
 
Old 07-13-2009, 01:28 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
When you said `grub menu', did you mean the grub shell?

I think you need to determine whether something happened to your Ubuntu 9's partition. Another possibility is that the partitions have changes. E.G. /dev/sda7 -> /dev/sda8. From Ubuntu Fiesty, look at the partition that has Ubuntu 9 on it. See if you can mount it manually. If you can, you can fix up the /boot/grub/menu.lst file and the /etc/fstab file, and try to boot up to it from the grub menu. Using fdisk, check the type of partition. There is a character in the MBR of a partiton determining the type. Maybe it changed but the filesystem is fine. If that is the case, you can fix it using fdisk.

I don't know what you mean by the 256-bit inode.

What is the filesystem that your old Ubuntu 9 partition uses? Another possibility is that it uses a filesystem that your new grub installation doesn't support. Look at this listing of /boot/grub/ on my laptop:
Code:
ls /boot/grub
default     device.map.old  fat_stage1_5  iso9660_stage1_5  menu.lst      minix_stage1_5     stage1  stage2.old     vstafs_stage1_5
device.map  e2fs_stage1_5   ffs_stage1_5  jfs_stage1_5      menu.lst.old  reiserfs_stage1_5  stage2  ufs2_stage1_5  xfs_stage1_5
The *_stage1_5 files are what supply support for the different filesystems. If you used xfs on Ubuntu 9, but you don't have the /boot/grub/xfs_stage1_5 file, grub won't understand the xfs filesystem.
 
Old 07-13-2009, 02:03 AM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,935

Rep: Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209
Very likely the inode change is causing the problem - Jaunty will have a patched grub, and you just trashed it. See here for some background.
Simplest would be to use the Jaunty loader again - from a Feisty terminal
Code:
sudo grub
root (hd0,7)
setup (hd0)
You'll need to add a stanza from the Feisty menu.lst to the Jaunty menu.lst to get all your systems in the boot menu.
 
Old 07-13-2009, 02:26 AM   #4
suvirj
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
@jschiwal : My ubuntu9 is on sda8[ext3, confirmed by GNOME partition editor] and fiesty even loaded it. I even have an icon on my desktop with which I can browse the files in it.

@sig00 : I did what you said, but it returns
________________________________________________
Checking if "/boot/grub/stage1" exists... no
Checking if "/grub/stage1" exists... no

Error 2: Bad file or directory type
_______________________________________________

So, it appears that my sda8 is fine, how do i boot it now?

[EDIT : I meant syg00]

[EDIT : Pasting a copy of my /etc/fstab in fiesty.

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda4
UUID=b08cab64-7c1a-4568-90d0-c889031d1500 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda1
UUID=0A66AACD66AAB8B9 /media/sda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
# /dev/sda2
UUID=A48054A280547CAC /media/sda2     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
# /dev/sda5
UUID=D6A1-8292  /media/sda5     vfat    defaults,utf8,umask=007,gid=46 0       1
# /dev/sda6
UUID=D564-036F  /media/sda6     vfat    defaults,utf8,umask=007,gid=46 0       1
# /dev/sda8
UUID=e37b9227-9810-4681-93ae-0fb31c998746 /media/sda8     ext3    defaults        0       2
# /dev/sda7
UUID=37537973-b5ea-4f8a-a2b2-15f82f48d066 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0

Last edited by suvirj; 07-13-2009 at 02:49 AM.
 
Old 07-13-2009, 02:49 AM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,935

Rep: Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209Reputation: 2209
Is your system still bootable ?. Do you have both the Ubuntu install CDs ?.
 
Old 07-13-2009, 02:54 AM   #6
suvirj
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Yes, my system boots. But the bootloader only lets me access fiesty [which installed the present grub] and the Vista. For some reason, it gives error for ubuntu9.
 
Old 07-13-2009, 04:44 AM   #7
suvirj
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
I did it. Problem solved. I used my Ubuntu 9 live CD and made the Grub installed in sda8 to MBR. All works.
The bright side is that I now know my way around GRUB. Cool!

Thanks for all the suggestions and the help guys!!
 
Old 08-06-2009, 08:05 AM   #8
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 234Reputation: 234Reputation: 234
I hear it's possible for OP to use "Thread Tools" to mark this [solved].
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ipod classic problem using gtkpod on aspire one (linpus lite) GeraintElberion Linux - Newbie 0 04-10-2009 08:23 AM
can't fix classic problem: internet connection c_323_h Linux - Networking 12 05-29-2006 04:12 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 09:13 PM
gnucash on 2.7 classic? walterbyrd Libranet 1 04-15-2004 12:26 PM
Libranet 2.7 Classic Download Problem Robert Simandl Debian 4 09-01-2003 11:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration