LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Clamav not starting at boot time. (https://www.linuxquestions.org/questions/linux-newbie-8/clamav-not-starting-at-boot-time-4175598180/)

swamprat 01-24-2017 09:26 PM

Clamav not starting at boot time.
 
Greetings:

I installed Clamav using YUM on CentOS 7.2 and I can't seem to get it started at boot time.

Tried a number of different things but nothing seems to work.

Below is the output of some of commands I ran and I can see a failure message but I can't resolve it.

Just to mention, I tried clamscan and it seems to work.

Some help in getting this resolved would be much appreciated.

Thanks.


[root@localhost rifkinho]# freshclam
ClamAV update process started at Tue Jan 24 21:20:39 2017
main.cvd is up to date (version: 57, sigs: 4218790, f-level: 60, builder: amishhammer)
daily.cvd is up to date (version: 22943, sigs: 1438675, f-level: 63, builder: neo)
bytecode.cld is up to date (version: 289, sigs: 57, f-level: 63, builder: neo)
[root@localhost rifkinho]# systemctl start clamd.service
[root@localhost rifkinho]# systemctl status clamd.service
● clamd.service - clamd scanner daemon
Loaded: loaded (/usr/lib/systemd/system/clamd.service; enabled; vendor preset: disabled)
Active: failed (Result: start-limit) since Tue 2017-01-24 21:21:17 EST; 36s ago
Process: 4996 ExecStart=/usr/sbin/clamd -c /etc/clamd.d/clamd.conf --nofork=yes (code=exited, status=1/FAILURE)
Main PID: 4996 (code=exited, status=1/FAILURE)

Jan 24 21:21:17 localhost.localdomain systemd[1]: clamd.service: main process exited, code=exited, status=1/FAILURE
Jan 24 21:21:17 localhost.localdomain systemd[1]: Unit clamd.service entered failed state.
Jan 24 21:21:17 localhost.localdomain systemd[1]: clamd.service failed.
Jan 24 21:21:17 localhost.localdomain systemd[1]: clamd.service holdoff time over, scheduling restart.
Jan 24 21:21:17 localhost.localdomain systemd[1]: start request repeated too quickly for clamd.service
Jan 24 21:21:17 localhost.localdomain systemd[1]: Failed to start clamd scanner daemon.
Jan 24 21:21:17 localhost.localdomain systemd[1]: Unit clamd.service entered failed state.
Jan 24 21:21:17 localhost.localdomain systemd[1]: clamd.service

Ztcoracat 01-24-2017 09:51 PM

Hi:

Did you use these commands to install clamav?

Code:

# yum install -y epel-release

# yum install -y clamav

-::-On Community Enterprise Operating System (CentOS) the clamav package requires the Extra Packages for Enterprise Linux (EPEL) repository.-::-

Running 'freshclam' manually is giving you a failure:
Code:

Failed to start clamd scanner daemon
It might mean that you need to install clamav-daemon but I'm not 100% sure.
OR>
Maybe you need to setup a link in /etc/rc3.d to the clamd and clamav-milter startup scripts?

-::-Best to wait on members that have this experience. Sorry I don't know more I'm still learning about servers.-::-

Maybe these links will help:-
https://ismailyenigul.wordpress.com/...v-on-centos-7/

http://forum.directadmin.com/showthread.php?t=53145


All times are GMT -5. The time now is 10:05 PM.