LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Chilibox Root Password Reset (https://www.linuxquestions.org/questions/linux-newbie-8/chilibox-root-password-reset-685276/)

techwebhosting 11-21-2008 06:11 PM

Chilibox Root Password Reset
 
Alright everyone, I have some serious problems. I don't know if anyone has ever heard of the chilibox. Back in its day it was a great idea and it was executed well. Anyway problem is now the company is out of business and has been for a while. A client of mine had a chilibox, it went belly up. I have the hard drive installed in another machine and it works and will boot up the software that ran on it. Problem is all of shares that were setup on it are gone, and I need to reset the root password so that I can get in and work on it. I have called the company and any other numbers I can find looking for someone, I have done everything within my power to find someone to help me. Now I guess I am going to have to try to hack into it.

I can get to the boot loader, its running some type of proprietary version of freebsd. To be honest I am not the greatest person when it comes to linux but I learn quick and I need to get this working. I have been poking around the internet and found that it can be booted into single user mode and then you can reset the password that way.

This is exactly what it gives me when I get to the boot loader in the command line.

>>FreeBSD/i386 BOOT
Default: 0:ad(0,a)
boot:

I have tried all of the commands there with no luck, the only thing that does anything is if I put a question mark. When I do that, I get this.

. .. dev usr var stand etc cdrom proc dist bin boot mnt modules root sbin temp sys .cshrc .profile COPYRIGHT kernel.GENERIC kernel boot.config compat newbox.pl shutdown.gif TLBX_INFO devel hdlabel.txt home jail kernel.old modules.old reboot.gif opt toolconf shuttingdown squid.core

Please any help would be appreciated, I am going to be working on this all night so I will be refreshing the post and keeping it up to date. If there is anymore information you would like to know feel free to ask. I have all the time in the world, and for the record I absolutely hate the chilibox and the company that made them.

-DJ

r3sistance 11-21-2008 06:19 PM

I have had to do a FreeBSD root password reset before. I used this source to do it. You should get that menu a few seconds after that boot: part.

Also technically speaking, this should be in the BSD forum as BSD is not linux, it's a distro of unix.

techwebhosting 11-21-2008 06:23 PM

So when I do that, at the prompt that I mentioned first in my original post it says this

>> FreeBSD/i386 BOOT
Default: 0:ad(0,a)/boot/loader
boot: -s <--- I added the -s hit enter and then it goes to the

BTX Loader 1.00 BTX Version is 1.01

Then it boots the chilibox stuff.

r3sistance 11-21-2008 06:24 PM

and if you leave it and don't hit any button?

techwebhosting 11-21-2008 06:26 PM

So, when it beings to boot it loads

/boot.config -Dh

then if I hit like ctrl or ctrl c it brings me to this

>> FreeBSD/i386 BOOT
Default: 0:ad(0.a)/boot/loader
boot:

at the boot: its a flashing cursor like it wants a command.

Admin please move this to the correct forum on the board, thanks.

Right now its sitting but I don't think its going to do anything.

r3sistance 11-21-2008 06:28 PM

Strange, well I dunno, might be chillbox, I have seen several FreeBSD boxes and they all bring up that part but go to the boot options menu 3 seconds later as long as no key is pressed what so ever.

techwebhosting 11-21-2008 06:31 PM

This is what I was afraid of, its a hacked and chopped version for their use. I was really praying that they didn't take this stuff out. I hate it when stuff is proprietary it just makes life harder for everyone else. Especially when you go out of business and you don't list the root password, or at least keep part of your support open.

On a different note, I have tried a couple of other things too with no success. I tried taking the hard drive out and putting it in another freebsd machine and trying to mount the partions that have important data on them that way, and that doesn't work either. They are ufs partitions.


Anyone else have any ideas?

techwebhosting 11-21-2008 06:36 PM

On a different note, I can get into the terminal using another user, and I am sure that you could get into something from there.

Problem is when I login I get this.

Last Login: Sun Jan 2 02:45:41 on ttyv0
Copyright (c).(omitted some unimportant stuff)...

Unauthorized access is strictly prohibited. By logging into this server you are consenting to being monitored.

Then it doesn't show anything and if I hit enter I get this

WinSCP: this is end-of-file:0

techwebhosting 11-22-2008 11:32 AM

Anyone have any ideas?

kevinalm 11-22-2008 12:07 PM

Quote:

Originally Posted by techwebhosting (Post 3351040)
Anyone have any ideas?

Stick the hd into a linux box whose kernel has been compiled with support for whatever fs and partition types Chilibox used?

Then just mount it and copy off whatever files you want. Of course that assumes that chilibox didn't do something creative like hack together a proprietary/nonstandard fs or partion system.

>>Edit Even better, try RIP 7.2

http://www.tux.org/pub/people/kent-r...looplinux/rip/


All times are GMT -5. The time now is 05:05 PM.