LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   checking for NM_UTILS... configure: error: Package requirements (https://www.linuxquestions.org/questions/linux-newbie-8/checking-for-nm_utils-configure-error-package-requirements-4175468433/)

srijivdimri 07-04-2013 02:55 AM

checking for NM_UTILS... configure: error: Package requirements
 
Hi Experts,

I am trying to install NetworkManager for Openconnect vpn s/w on RedHat. I downloaded the NetworkManager-openconnect-0.99(2).tar.gz, untar it and got the NetworkManager-openconnect-0.99 . When I go under this directory, I see:-

aclocal.m4 autom4te.cache config.guess config.sub depcomp intltool-merge.in MAINTAINERS missing nm-openconnect-service.name.in src
AUTHORS ChangeLog config.h.in configure install-sh intltool-update.in Makefile.am mkinstalldirs po
autogen.sh compile config.log configure.in intltool-extract.in ltmain.sh Makefile.in nm-openconnect-service.conf properties

When I do .configure, it comes up with an error message:-

"checking for NM_UTILS... configure: error: Package requirements (NetworkManager >= 0.7.0 libnm-util libnm_glib libnm_glib_vpn) were not met:

No package 'NetworkManager' found
No package 'libnm-util' found
No package 'libnm_glib' found
No package 'libnm_glib_vpn' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables NM_UTILS_CFLAGS
and NM_UTILS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
"

If I open Autogen.sh via vim, I see that I need to install gnome-common. I installd the package for the same using yum install gnmome-common.noarch. But still getting the same error.

Please advice on the same.

Your inpus would be highly appreciated.

Thanks and Regards,
Srijiv Dimri

knudfl 07-04-2013 04:29 AM

NetworkManager-openconnect-0.99 : A future version.
( Fedora 19 : version 0.97* ).

I.e. please use a version that will accept your version of NetworkManager-devel.
→ → # yum install NetworkManager-devel

* No package 'NetworkManager' found : /usr/lib/pkgconfig/NetworkManager.pc
.. provided by NetworkManager-devel.

Which version is your OS ? → $ cat /etc/*release*

-

srijivdimri 07-04-2013 09:51 AM

Hi,

Thanks for looking into this.

The OS version is :-
[root@MCXALGO2 ~]# cat /etc/*release*
cat: /etc/lsb-release.d: Is a directory
Red Hat Enterprise Linux Server release 6.1 (Santiago)
Red Hat Enterprise Linux Server release 6.1 (Santiago)
cpe:/o:redhat:enterprise_linux:6server:ga:server

Please let me know if anything else is required from my end.

knudfl 07-04-2013 10:48 AM

# 3. OK, RHEL 6.x : NetworkManager-openconnect-0.8.1 can be used.
http://archives.fedoraproject.org/pu...1.fc14.src.rpm

# yum install \
NetworkManager-devel openconnect-devel NetworkManager-glib-devel
Code:

$ rpmbuild -bb NetworkManager-openconnect.spec
.
.
Wrote: /home/knudfl/rpms/RPMS/i686/NetworkManager-openconnect-0.8.1-1.el6.i686.rpm
.



All times are GMT -5. The time now is 11:59 AM.