-   Linux - Newbie (
-   -   Changing Xf86 config file (

toosdedoos 09-26-2003 09:05 AM

Changing Xf86 config file
hi ppl, I have a problem and i'd be very pleased if you took a moment to look at it.
Plz plz plz help me on the following:

When i startup my computer, i see the bootloader:
some others

when i choose linux, i get an kernel error. when i choose windows, my pc reboots and i see the bootloader without windows. when i enter linux now, startup works correctly. Why???
(bootloader is installed on the Linux partition) Windows doesn't even exist on my system anymore. I just reinstalled my entire system and deleted all partitions.

Then when linux finally starts i see the cursor for a moment and the linux textmode asking me for a login. I already asked this in another thread and i made up out of the answers i should have chosen more conservative settings for my monitor. With my most recent installation however i chose 800x600 16 bits, while my monitor could handle 1024x768 at 32 bits under windows. Maybe i should have chosen even more conservative settings, but since installing linux is something i already tried twice for the exact same problem and is a very timerobbing thing, i'd like to avoid that one this time. Instead i tried to type startx again under root login but didn't work. i also tried 'xf86config' and went through all settings, but when it came to saving the whole thing to the file xfconfig-4, i didn't get acces to it. No permission to overwrite this file or something like it (I was logged in as ROOT!!!) Should i use chmod on the file? How do i do that? Or should i choose to run another configuration file instead? How do i select another one? plz help i'm desperate and noob.
Tanx for reading it all through here

tangle 09-26-2003 09:17 AM

Was Windows on the first partition on the drive? Where did you install the bootloader when you had Windows install?

If it was in the MBR (master boot record), put a windows boot floppy in and boot to it. Then type fdisk /mbr. This will clear the master boot record. This sould allow your boot loader on the Linux partition to load.

Did you see anything when you where booting that said mounting partition as read-only? It sounds like it mounted as read-only, since you can't write to the /etc/X11/XF86Config file as root.

All times are GMT -5. The time now is 03:11 AM.