LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-24-2009, 04:05 AM   #1
anaigini45
Member
 
Registered: Nov 2009
Posts: 49

Rep: Reputation: 15
Changing SELinux settings for PCLinuxOS


I want to change the SELinux settings to permissive mode (temporarily) in my PCLinuxOS distro. But I can't find the configuration file to do so there. It is very different from Centos and Fedora settings.

Please help.
 
Old 12-24-2009, 04:14 AM   #2
Fadoksi
Member
 
Registered: Apr 2006
Location: Finland
Distribution: Ubuntu, Gentoo, Debian
Posts: 88

Rep: Reputation: 15
Hi!

Try this link:
http://www.crypt.gen.nz/selinux/disable_selinux.html

Merry Christmas!
 
Old 12-24-2009, 04:25 AM   #3
anaigini45
Member
 
Registered: Nov 2009
Posts: 49

Original Poster
Rep: Reputation: 15
I've already tried the commands there, but it does not work....
It returns lots of error like

Code:
bash : newrole: command not found
Code:
bash : setenforce: command not found
The grub.conf file does not even exist in /boot/grub
 
Old 12-24-2009, 11:33 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,735

Rep: Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317
Why do you think, you have selinux in PCLinuxOS ? ?

There isn't any by default.
No packages available, AFAIK.
So unless you did build it, new kernel module etc. :
No selinux'.

.....

By the way, the file 'grub.conf' has two names :
A link 'menu.list' is common, or the file name is
menu.list
.....
 
Old 12-27-2009, 09:17 PM   #5
anaigini45
Member
 
Registered: Nov 2009
Posts: 49

Original Poster
Rep: Reputation: 15
Actuallly, I'm in the process of installing and making nagios work in my PCLinux.One of the steps is to set SELinux to permissive mode. Since SElinux doesn't exist in PCLinux, what other settings do I have to change?

Because when I skip that step, I can't launch nagios through http://localhost/nagios.
The error message that I get is Error 404 : Object not found.

But apache works with http://localhost.

Last edited by anaigini45; 12-27-2009 at 09:24 PM.
 
Old 12-27-2009, 09:43 PM   #6
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Do you have /etc/selinux?
There should be a config file, and inside SELINUX=permissive

I am actually as well start to play with it.
 
Old 12-27-2009, 09:57 PM   #7
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Or in grab boot selinux=1 enforcing=0, if you have it.
 
Old 12-27-2009, 09:59 PM   #8
anaigini45
Member
 
Registered: Nov 2009
Posts: 49

Original Poster
Rep: Reputation: 15
No I don't have any of those. I don't have /etc/selinux nor the lines selinux and enforcing. These are the contents of the menu.lst file in /boot/grub.

Quote:
timeout 10
color black/cyan yellow/cyan
gfxmenu (hd0,0)/boot/gfxmenu
default 0

title linux
kernel (hd0,0)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=f7a48909-825c-420a-83a1-$
initrd (hd0,0)/boot/initrd.img

title linux-nonfb
kernel (hd0,0)/boot/vmlinuz BOOT_IMAGE=linux-nonfb root=UUID=f7a48909-825c-420a$
initrd (hd0,0)/boot/initrd.img

title failsafe
kernel (hd0,0)/boot/vmlinuz BOOT_IMAGE=failsafe root=UUID=f7a48909-825c-420a-83$
initrd (hd0,0)/boot/initrd.img

Last edited by anaigini45; 12-27-2009 at 10:02 PM.
 
Old 12-28-2009, 11:26 AM   #9
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Do you have manual:
man selinux ?

In mine says about config file, check yours.
 
Old 12-29-2009, 03:31 AM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,735

Rep: Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317
*

I can repeat : There is no selinux in / for PCLinuxOS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
selinux - changing file attributes back to targeted? dansawyer Linux - Security 1 02-15-2007 06:32 AM
Changing monitor settings? gregorian Linux - Newbie 3 05-17-2006 11:37 PM
changing settings help imdeemvp Slackware 6 09-26-2004 12:16 AM
Changing US keyboard settings to Spain (SP) settings or Mexico. zLinuxz Linux - General 4 12-01-2002 01:49 AM
Changing settings hfi556 Linux - Newbie 1 05-24-2001 11:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration