LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Changing screen resolution from the command line (https://www.linuxquestions.org/questions/linux-newbie-8/changing-screen-resolution-from-the-command-line-786575/)

fbr 02-02-2010 10:52 PM

Changing screen resolution from the command line
 
I am having an install problem where the distro I am installing, installed at the wrong screen resolution. The display settings menu doesn't offer the correct resolution so I'm using half my screen real estate.

Any help will be greatly appreciated.

Thanks in advance!

foodown 02-03-2010 01:04 AM

If you are referring to the resolution of the console, and if your distro uses LILO, find this section in /etc/lilo.conf:
Code:

# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769

Uncomment the "vga=XXX" line for the resolution that you want, run 'lilo' and then reboot. (All of this as root, of course.)

If you mean the resolution while in X, you can set up your /etc/X11/xorg.conf file to define the resolution that you want. This file is well documented. You are looking for the "Screen" section.

fbr 02-03-2010 06:14 AM

Thanks foodown I'm using Zenwalk a Slackware deritive so I am using LILO. I'm not sure whether the problem is LILO or in X but you have given me enough information to do the research.

I'm off to work but anxious to give it a try again this evening.

Many thanks

onebuck 02-03-2010 06:46 AM

Hi,

Quote:

Originally Posted by fbr (Post 3850667)
Thanks foodown I'm using Zenwalk a Slackware deritive so I am using LILO. I'm not sure whether the problem is LILO or in X but you have given me enough information to do the research.

I'm off to work but anxious to give it a try again this evening.

Many thanks

You should change the thread title to reflect. If it is a 'X' problem, how do you have the hardware configured? You can use '/var/log/Xorg.0.log' to get some useful information that may lead to potential solutions for the warnings or errors. If you are going to use the framebuffer then setup through the global section of '/etc/lilo.conf' but be sure to run 'lilo' again to update the loader.

You can do a 'man xorg.conf' to get some insight on the confguration of 'X'.

:hattip:

fbr 02-03-2010 07:30 PM

Ok after reading the above posts I've done some research and this is what I think I know.

/etc/lilo.conf file the resolution options are exactly as shown in foodown's post. Currently the vga=791 line is currently uncommented. My system resolution should be 1680 x 1050 which is not one of the file options. I assume you could use vi to insert a line but I am not sure how you would determine the vga number or if that is in fact what needs to be done.

/etc/X11/xorg.conf I read the man page and while I don't want to sound dense but I did not get any sense of how you would configure the resolution settings nor did I see anything in the file that looked like a resolution setting.

Section "screen"
SubSection "display"
Depth 24
End SubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
End Section

Again being a Linux newbie, I,m not sure, but it doesn't look like much going on here.

/var/log/Xorg.0.log contained the following lines

EE VBoxVideo(0): Failed to initialize the Virtualbox device (rc=22) Make sure the that the VirtualBox additions are properly installed. If you are not sure , try reinstalling them. The X windows graphics drivers will run in in compatibility mode.

This was followed by more output, which suggested to me that it attempted to load a "vboxvideo" module and then failed.
[drm] failed to load module "vboxvideo"
(EE) [drm]Open failed.

So it appears to me the problem is related to the VB GuestAddition not loading properly. However, whenever I attempt to install the Guest Additions package I get a window with the following message "Auto-Run capability detected. Would you like to allow autorunsh to run? The problem is, neither option "allow auto run" or "ignore", appear to do anything. Clicking on either option, results in the window clearing and nothing further, neither a confirmation (that the install succeeded), nor a message indicating that the installation failed.

I apologize for the long post and thank those who took the time to read. I'm hoping somewhere in the detail lies an answer.

onebuck 02-03-2010 07:39 PM

Hi,

First, setting the framebuffer within the '/etc/lilo.conf' files is for the console not 'X'.

Second, you never stated you were installing as a guest with VB. You need to do the configuration via the VB Guest setup.

'How to Ask Questions the Smart Way' would be a recommended read when you need to formulate a complete query.

:hattip:


All times are GMT -5. The time now is 01:08 PM.