LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-18-2020, 10:03 PM   #1
gnu noob
Member
 
Registered: Mar 2003
Location: CA
Distribution: Manjaro
Posts: 146

Rep: Reputation: 16
changing hostname locks up system


Hello everyone, I followed the online directions to change my hostname (both /etc/hostname and /etc/hosts) in vim and after rebooting and logging in, I was unable to right click to get my menu (running Openbox on XFCE with obmenu-generator) Changing it back to the original and rebooting makes everything work again.

Dell Inspirion 3583 12G Ram
i3 processor
Artix XFCE running Openbox

Thank you in advance for your help.
 
Old 07-18-2020, 10:10 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,060
Blog Entries: 27

Rep: Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226
That is truly strange.

Can you link to the online directions that you followed so that others can review them?
 
Old 07-18-2020, 10:26 PM   #3
gnu noob
Member
 
Registered: Mar 2003
Location: CA
Distribution: Manjaro
Posts: 146

Original Poster
Rep: Reputation: 16
I'm using runit instead of systemd so that may make things a little more complicated, but here's what I followed:

https://wiki.artixlinux.org/Main/Configuration

https://wiki.archlinux.org/index.php...t_the_hostname

https://www.tecmint.com/set-hostname...ntly-in-linux/
everything is good until etc/init.d/hostname restart gives no such file

Last edited by gnu noob; 07-18-2020 at 10:32 PM. Reason: additional information
 
Old 07-23-2020, 04:28 PM   #4
gnu noob
Member
 
Registered: Mar 2003
Location: CA
Distribution: Manjaro
Posts: 146

Original Poster
Rep: Reputation: 16
It has something to do with running openbox on XFCE, I'm working around it by using openbox only until I upgrade hardware and reinstall.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Not able to get system mail logs in mutt after changing hostname. nicedreams Linux - Networking 2 07-23-2018 01:02 AM
[SOLVED] Sparky Linux (Debian Testing) Locks Up, FF Locks Up, Have to perform Hard Shutdowns Ztcoracat Debian 17 06-30-2017 12:15 PM
HOSTNAME = hostname -> HOSTNAME: command not found ? thomas2004ch Linux - Software 2 08-26-2013 09:25 PM
hostname vs. HOSTNAME ? sirius56 Linux - Newbie 2 02-16-2007 09:16 AM
hostname command vs. $HOSTNAME env. variable Silly22 Linux - Networking 2 03-29-2002 06:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration